How to skip compulsory app update?

When there’s an update for an app, I’m getting a page like this on Nextcloud:

Is there any way to skip this page and not update? It’s weird that I’m locked out of my installation until I update some random app, which maybe I don’t want to update.

Any idea if skipping the update can be done, and how?

It is a usual mechanism, that apps are being updated when you run and ./occ upgrade command. The app itself has already been downloaded and this task updates the related database tables etc., so not a big deal. It isn’t possible to jump over it, because otherwise your system stability might be impacted.

Is it not? Updates now and then break, and I need to ssh to the server to manually fix them. The message recommends to backup everything too, which shows it’s not something small. If I need Nextcloud now, I don’t want to accidentally break it and have to spend one afternoon fixing it.

That’s why it’s strange to be locked out of my server for this. WordPress and most other web applications out there allow you to update plugins and themes in your own time.

It seems that you’ve executed the upgrade command, haven’t you? So you were aware of whjat are you doing. A backup is usually recommend when updating Nextcloud, but not for an app.

Not what the upgrade message says.

But anyway I was just asking if the upgrade can be skipped or delayed and the answer is “no”, which is awful design but it is what it is.

I was just asking if the upgrade can be skipped or delayed

As you already figured out the answer is no.

which is awful design

Probably. There are some awful design decision around. But keep in mind that there is no auto update functionality. That makes your question a bit confusing. Usually manual interaction is required to trigger this page (for example via app manager or occ app:update).

I don’t see a issue with that . Perhaps a alternative choice “skip update and disable app” could added. But then it’s better to not update the app and work with the older version instead of downloading the app and not applying the update.

If this page came out of nowhere (without your interaction) and you are able to reproduce this somehow please log a issue at https://github.com/nextcloud/server/issues/new/choose.

hi i have the same problem. i accidentially clicked on an upgrade of the app polls. but that upgarde breaks and i only have ftp access to the server. does anyone knows how to roll back that update?

Hi @ulph0

Had the same problem as well going from Polls 1.8.3 to 2.0.0. My instance was locked out, but these steps brought it back:

sudo -u www-data php occ maintenance:mode --on
sudo -u www-data php nextcloud/occ app:disable polls
sudo -u www-data php occ maintenance:mode --off

Not sure if the maintenance mode is required, but reporting what I did. So no polls until a fix is figured out it seems.

EDIT: oh you only have ftp access. Sorry, ignore this answer

You also can manually download the app, decompress in /apps dir and then reload the website.

Read Problematic versions in the appstore (1.9.5 and 2.0.0)

thanks for your answer. maintenance mode is switchable over changing config.php but it wasn’t on at all.

what i found is this:

what i did is this:

  • disabling polls over the database (similar to this: How to disable an app without access to the GUI? - FAQ - ownCloud Central but changing “storage_charts” to “polls”. also you could change it manually over phpmyadmin, what i prefer). this removed that screen.

  • to solve my certain problem i deleted apps folder, overwrite it with the files described in the issue above and re-enabled it over the db.

that helped.

regards,
ulf

@ulph0 Read my article i posted above. It worked for me. I only downloaded and decompressed the polls app and the website worked.

1 Like

thank you @devnull , so i did the same except in addition dis- and reenabled the app. hope this mails here will help others with the same problem.