How do you link OnlyOffice to NextCloud?

I have been trying to Integrate OnlyOffice to Nextcloud so that I can add the OnlyOffice editing functions to Nextcloud “Files”
Nextcloud files
I have installed “Onlyoffice Community” on another server.

Both nextCloud and Onlyoffice servers are SSL. I have the OnlyOffice Connector installed.
Onlyoffice Connector
When I try to use the Onlyoffice connector to connect my Onlyoffice Server, I just get a “curl” error.

I have also tried leaving the document editing service address blank and clicking “save” to use the internal onlyoffice community on the nextcloud server. The connector says it is connected, but I never see any options on the files menu added.

I have read everything everywhere. Am I doing something wrong? Please advise. This is a home installation for myself and family members.

I don’t have an answer to your questions, but am running a standalone OnlyOffice server (linked to Nextcloud and ownCloud using the connector apps) for a long time without problems.
All servers on public IPs with Let’s Encrypt SSLs…

I used this guide to setup the standalone server

Looks like searching for that exact error returns a number of results. Here is a DNS solution from their github repo.

Did you perform the build from source code?

The jist of that article was to make a local dns entry in /etc/hosts. So the question is, are they talking about a local dns entry for the NextCloud server or the Onlyoffice server and both my servers are behind NginX Proxy Manager and are reachable by their DNS web names by reverse proxy. Neither my Nextcloud or my OnlyOffice have local DNS names and I don’t see how that could factor in since my reverse proxy will never relate to the local dns names if there were any. Please explain further.

Hi @vmsman, the onlyoffice server is on your local network ?
if yes i suggest you this :


No, I have not. I used their VM…

IIRC, the available source needs to be compiled on Ubuntu 14.
At least this applied around the time I did it…

I set the Onlyoffice instance to point to the internal copy of onlyoffice as you showed in your screenshot above. The settings took immediately and appear to be configured as you indicated. In the "Files section of NextCloud, my Plus menu looks like this:
plus menu

I have read where you need to log off and back on to Nextcloud. I also stopped and started the server. The menu still looks the same. When I choose new text document:

Perhaps the Onlyoffice integration is streamlined to look just like the the standard text editing inside Nextcloud. I guess it works after all. Since the menu has no visual differences, I think I will delete the external server and remove the onlyoffice integration. I can use onlyoffice at the desktop because it has a much better editing interface. Thanks for all the help. I guess I expected a web integrated version of onlyoffice, but from what I can see, that’s not how it works.

I now realize that all the videos and blogs online dealing with Onlyoffice integration really just were showing running onlyoffice at the desktop and uploading your documents to nextcloud. The community document server is just a “how to” giving an example of an api for the desktop. I thought you could actually edit onlyoffice documents with some kind of web based version of onlyoffice. Apparently I was totally off base. I think I will just keep my word, excel, and powerpoint on the desktop and put them on a NAS share when needed. It doesn’t appear that Nextcloud does much with documents with the exception of sharing them with nextcloud users. However the extra step of an upload to nextcloud is not needed because I can just give other users an easy file share link.

Thinking Nextcloud might not be useful overall for basic users.

@vmsman you can edit online with onlyoffice server but I don’t know why yours doesn’t work. I have installed onlyoffice server on ubuntu using manual installation : Installing ONLYOFFICE Docs for Debian, Ubuntu, and derivatives - ONLYOFFICE

and I’m using a reverse proxy to have https on the domain.

This is the onlyoffice web editor on pc :

when your onlyoffice server is correctly link with onlyoffice connector you have this : ( last 3 menu)


I installed Onlyoffice document server on Ubuntu 20.04. When I go to the Onlyoffice URL of that domain (by the way through NginX Reverse Proxy Manager) I get a web page "Onlyoffile Docs Community edition – Welcome. That page has a link to an API guide. I thought all I had to do was reference that server from my nextcloud instance which is also accessible reverse proxy on my network. This doesn’t do anything unless the URL in the connector needs some path inside the server or a particular port opened.

@vmsman yes on the onlyoffice connector, you have to point the URL used for edition for users but in some case like me the domain doesn’t works ( can’t acces to my domain when connected to my home) for onlyoffice connector because when no information is set in advanced settings, onlyoffice connector use this URL to make requests. so I have set the advanced settings using local ip and port but you have to check how to access to your server using local ip and port. if you use https for local access, put https for Document editing services adress.

when I go to my domain, I have the same page you have

I have added this line in nextcloud config.php file to allow local ip for nextcloud:
'allow_local_remote_servers' => true,

I feel so stupid because I have configured hundreds of services like this and from what I am seeing the nextcloud connector just does not work. I tried to use the local IP and the connector says "Error trying to connect (Mixed active content is not allowed. HTTPS address for document server is required).

where you write your local ip ? in advances settings ?
nextcloud server and onlyoffice server are on the same machine ?

I added the ‘allow_local_remote_servers’ => true, to config.php.

I added the local address http;// to the advanced "Document Editing Service address for Internal requests from the server and the connector took that.

When I go back into the connector, it seems to be pointing to the internal onlyoffice document server.

I still have no editing options. I would have sent you screenshots but this forum is refusing to upload my screenshots now.

I have now disabled and removed the Internal Next cloud community document server on my Next Cloud add-in list so that it is not even on the system. In the connector, I give it the address of my Onlyoffice document server. By the way, the local address of my nextcloud server is Still no luck. Interesting that the connector keeps reverting back to pointing back to the Internal document server which is completely disabled and removed.

@vmsman onlyoffice server has no specific port ?

Well the URL is displayed on port 80 in my case since it is on a dedicated server. By the way, from the command line I can curl to the local address from either server back to the other and it works. My initial error in the connector has always been a curl timeout. I do not have curl connectivity from the onlyoffice server command line going through the reverse proxy via https and I think that’s something with NginX reverse proxy manager.

@vmsman check this for nginx reverse proxy configuration :

So, the demo Onlyoffice server works. I looked at the link you mentioned previously. I use NginX Reverse Proxy Manager ( to do all my certificates and my reverse proxies to make life easy. Unfortunately, all that dirty down in the weeds settings of nginx just confuse me even after about 10 years of messing with it. For that reason, has been my dream. I have no idea what to add to make this work. I have 26 other containers using reverse proxy with this product and onlyoffice/nextcloud integration is the only one with issues. This has exceeded my understanding for sure.