Help testing RC1 version of 14.0.2, 13.0.7 and 12.0.12


#1

Hey,

we just packaged the RC1 version of 14.0.2, 13.0.7 and 12.0.12. Feel free to help testing it. As usually it can be found in the prereleases folder on the download server: https://download.nextcloud.com/server/prereleases/

Happy testing :rocket:

The changelog looks like this:

14.0.2 RC 1

13.0.7 RC 1

12.0.12 RC 1


#2

Successfully updated my private server as well as a test server :wink:


#3

Hey,

Sure i will Test it.

Thanks


#4

Es gibt einige Warnungen bei Deiner Systemkonfiguration.

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/caldav/” aufzulösen. Weitere Informationen findest Du in der Dokumentation.
  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/carddav/” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

After the update came this message.I did not change anything on the server.


#5

Same here. I tested my with my WebDAV clients but everything still works. Additionally I have the following Message

  • Einige Dateien haben die Integritätsprüfung nicht bestanden. Weiterführende Informationen befinden sich in unserer Dokumentation. ([Liste der ungültigen Dateien…]

The following file seems to be affected:

[FILE_MISSING] => Array
(
[vendor/ezyang/htmlpurifier/maintenance/.htaccess] => Array


#6

Hey,

We actually fixed the check. That means that the URL just didn’t worked before but was not properly defected like that.

https://cloud.example.com/.well-known/caldav should point to „/remote.php/dav/„ of your Nextcloud installation. Because the Nextcloud installation can be in a subfolder we can’t always generate this URL thus the Webserver sometimes needs this redirect directly configured. If the Nextcloud is in a subfolder then the .well-known URL still needs to be configured in the root, but pointing to /subfolder/remote.php/dav

Morris


#7

And the well-known URL is only for Auto Discovery. If you entered the WebDAV URL in your clients manually it works nevertheless, but some clients do auto discovery and then you only need to enter the domain and the client will fetch the rest. :wink:


#8

This issue will be fixed in the next release of the news app.


#9

Thanks al lot! What a fast response!

About the DAV topic. My DAV configuration looks like this:
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]

that seems to be OK, if I understand you right. But I get the same error JoMatr described.


#10

I have this redirect, but still the warning.

Nextcloud checks for https://cloud.example.com/.well-known/caldav/ (with trailing slash) and not for https://cloud.example.com/.well-known/caldav

What is the correct URL?

Edit: rfc6764 lists the URI without trailing slash, so nextcloud should check without it.


#11

Thank you for the fast answer! Have the redirect entries copied to the apache.conf. Now the error message is gone. :wink:


#12

For anyone else coming across this error. On CentOS 7.5 with apache, I put the suggested lines into /etc/httpd/conf.d/nextcloud.conf so that my VirtualHost file looked like this:

<VirtualHost *:80>
  DocumentRoot /var/www/html/
  ServerName my-server.com
  <Directory "/var/www/html/">
       Require all granted
       AllowOverride All
       Options FollowSymLinks MultiViews
  </Directory>
  Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
  Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav
</VirtualHost>

and Nextcloud can be found at my-server.com/nextcloud

This is on NC13.0.7

I just did a basic install of this, nothing fancy, but it seems like all is well btw :slight_smile:


#13

I do not get the warning, and I don’t have the .well-known directory configured. Is there anything wrong?


#14

As far as the feature request for “ADD GROUPS” I checked and works OK.


#15

I’m still not able to see my files, if external storage (which is shared to me by another user) is offline.

see github: https://github.com/nextcloud/server/issues/11545
shall i open up another issue?


#17

We just released a RC2 of all three versions. All of them have those two changes included:

On 12 only the second one is included.

Happy testing. It should show up in the beta channel right now.

:rocket:


#18

I’m on Nextcloud 14.0.1 stable but I’m sure it still applies to the 14 RC 2. On the desktop in Nextcloud Talk going full screen on the chat window prevents the user from accessing “File to Share” when hitting the + button they first have to exit full screen then share then go back to full screen mode.


#19

Seems, that the issue still exists:

NC 14.0.2 RC2 - still wrong checks … #11748


#20

Correct - we discussed if we should delay the release or keep it as known issue. We have a fix but will ship it with 14.0.3. The issue does not happen on the default Apache config. For Nginx the configuration usually is correct, but the setup check gives a false postive. We will check today if we will maybe move the fix into the release or not.


#21

Will be fixed in the 14.0.2.