Help test the next generation Nextcloud Desktop Clients!


#1

Originally published at: https://nextcloud.com/blog/help-test-the-next-generation-nextcloud-desktop-clients/

Over the past months, the Nextcloud desktop team has been working hard to integrate End-to-end Encryption as well as a number of other improvements in the Nextcloud desktop client. To facilitate testing, we’ve set up daily builds for Windows, Linux and Mac and we’d like to encourage you all to help test the clients!
[caption id=“attachment_4268” align=“aligncenter” width=“864”]

The new token-based login flow of the client [/caption]
The coming weeks will be spent merging the last planned features currently in pull requests in our repo (review and testing welcome there, too!) and stabilizing the clients for a release. As always, our goal is to release a very stable product and that, in no small part, depends on you, our community! Get involved, help us make this the best Nextcloud client release ever!

You can find the daily builds on the download server.


macOS Client with E2E?
Desktop client has less releases and is behind master
Nextcloud only synchronise sometimes
High CPU load (Linux Desktop Client)
Verschlüsselung Shared Hosts
Does Nextcloud 14 have End to End Encryption?
#2

Great :slight_smile:
First feedback (Nextcloud-2.5.0.0-Debug-20180627.exe):

  • Quite long to install (Windows 10, Core I7) → 2 minutes
  • It triggered a restart of my machine without asking : I blocked that but it closed all other application open
  • “Launch Nextcloud” box is ticked, but it does nothing
  • I try to launch it from Explorer: nothing either [EDIT] : actually, it does start :slight_smile:
  • Filters in “not synchronized files” tab are very useful while for a standard user, it’s not visible enough that we don’t see all problems when it’s filtered. I think a very visible message should explain that there are other issues which are not visible because of filters
  • Congrats!

#3

At the first show I can’t find any news. On CentOS 7 it doesn’t run:
./Nextcloud-2.5.0.20180628-daily-x86_64.AppImage: /lib64/libstdc++.so.6: version CXXABI_1.3.9' not found (required by ./Nextcloud-2.5.0.20180628-daily-x86_64.AppImage) ./Nextcloud-2.5.0.20180628-daily-x86_64.AppImage: /lib64/libstdc++.so.6: versionGLIBCXX_3.4.21’ not found (required by ./Nextcloud-2.5.0.20180628-daily-x86_64.AppImage)
./Nextcloud-2.5.0.20180628-daily-x86_64.AppImage: /lib64/libstdc++.so.6: version CXXABI_1.3.9' not found (required by /tmp/.mount_Nextcl6xAXKx/usr/bin/../lib/libQt5DBus.so.5) ./Nextcloud-2.5.0.20180628-daily-x86_64.AppImage: /lib64/libstdc++.so.6: versionCXXABI_1.3.9’ not found (required by /tmp/.mount_Nextcl6xAXKx/usr/bin/…/lib/libQt5Xml.so.5)

On Fedora 28 it works perfect .

Andreas


#4

Can I safely install the new client besides the old client and connect the new one with a test account?


#5

Thanks for the update. I tried the windows version a few days back. The OpenSSL version against which the debug version of the NC client was built is a very old version OpenSSL dating back to 2014. Is it still the case?


#7

Can I safely install the new client besides the old client and connect the new one with a test account?

On Windows, No: it will take automatically your configuration and use your configured sync. Then, if you want to use the current official version, you’ll have to reconfigure everything :frowning:


#8

Windows 10 Enterprise - [Nextcloud-2.5.0.0-Debug-20180628.exe]
I agree the auto reboot is an annoyance. I’ve installed this now on two workstations. The second workstation it prompted for the E2E mnemonic (after I had to force close the app and relaunch it)

Is there support for the mobile app yet?

Thanks for all the awesome work. I’m excited about this feature!


#9

Vale es super interesante, esta característica.
En Windows 10 Pro [Nextcloud-2.5.0.0-Debug-20180627] es muy molesto el reinicio automático. La aplicaión se ejecuta y al instante devuelve el error siguiente

Estoy seguro que este proyecto saldrá adelante.

Muchas gracias por el trabajo realizado.


#10

The mobile apps have pretty good E2E support already, just keep in mind: it is still experimental!


#11

Just tried

latest.AppImage

on my Rock64 4GB but got the usual

sudo ./latest.AppImage
./latest.AppImage: 1: ./latest.AppImage: Syntax error: “(” unexpected

I have discovered, though, that the owncloud client is working well on my Rock64 with my RPi Nextcloud server, but I assume that the owncloud client wont work forever.

OS Details

uname -a
Linux rock64 4.4.126-rockchip-ayufan-239 #1 SMP Sun May 27 18:38:24 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux


#12

Hallo, ich habe heute den neuesten build des Nextcloud e2e clienten für Windows herunterladen und installiert. Das erste was auffiel war daß er 6 Bilder auf dem Nextcloud Server löschte. Warum keine Ahnung.

  1. Problem ist, der Client schließt sich nachdem er von mir gestartet wurde immer nach 2-3 Minuten meistens beim Synchronisieren, komplett ohne Fehlermeldung. Er ist nichtmehr aktiv.

Installiere ich nun den stable clienten dann lädt dieser als erstes die 6 gelöschten Bilder wieder auf den Server. Der Client läuft stabil


#13

Installed and directly updated the current stable client on macOS and seems to work flawlessly so far (Version 2.5.0daily (build 20180629). App icon still missing but the rest seems to do its job as expected without problems so far.


#14

so far so good but i use app social login on my server, witch use google for auth.
In my case, i use U2F Yubiko NEO key for auth on my accounts.
When use in conjonction with Opera or Chrome, i am able to use my neo key for auth.
When using firefox or Edge, i need to switch to alternate app google to get a code

nextcloud sync desktop build20180629

  • imcompatible with U2F
  • loose connection on a regular basis. Is there a token timing ?? If yes, this is a non-sense.
  • sometime, when app is reduce, the app icone in desktop bar loose it’s drop down menu.
  • seem https://github.com/nextcloud/desktop/issues/398 is not reproducing.

please, could we stick to english language here.
Sil vous plais, restons a l’anglais ici.
Bitte, Lasst uns weiterhin Englisch sprechen.
Por favor, sigamos hablando inglés
lad os fortsætte med at tale engelsk.
Āsuna inrēji kathā balatē thāki.


#15

The OpenSSL is still the very old one and I guess it urgently needs an upgrade.


#16

latest opensssl is 1.1.1-pre9 ! or 1.1.0h [27 Mar 2018], 1.1.0i is on the way already !

seem’s latest QT version is 5.10 or 5.11 …


#17

Qt 5.9.x is the long term support branch and it only supports building against OpenSSL 1.0.x. This is not a problem since 1.0.x is as secure as 1.1.x in the foreseeable future. But a more recent 1.0.x is preferred for example the latest 1.0.x is 1.0.2o released in March this year.

Support for building against OpenSSL 1.1.x has been added since Qt 5.10.


#18

#19

Already on the way as it seems:


#20

For Arch/Manjaro users, I just added the daily AppImage to the AUR for a convenient installation process. All the script does is to copy the latest version to /opt/appimages/

I simply like to manage software through repos more than AppImage files everywhere :wink:


#21

I got Redirecting … and nothing, i tested it on two Nextcloud server.

I’m on the windows Build of 2rd of July