Have php 8.2 but nextcloud thinks it's 8.0

Nextcloud version 27.0.1
Operating system and version, Rocky 9
Apache 2.4
PHP 8.2

Not sure it’s a bug or something I have to fix but thought I should mention it.
On my system with 8.2 installed, I still get;

You are currently running PHP 8.0.30. Upgrade your PHP version to take advantage of [performance and security updates provided by the PHP Group ↗](https://secure.php.net/supported-versions.php) as soon as your distribution supports it.

Are you really sure that you’re using PHP v8.2 for both components, the WEB and the CLI one? How have you checked it in detail?

Hi, I’m not really sure what you mean.

From the cli, I see;

php -v

PHP 8.2.9 (cli) (built: Aug 3 2023 11:39:08) (NTS gcc x86_64)

From the GUI, it shows the server is running 8.0.


Am I missing something?

As usual the search function of the forum points you into to the right direction :wink:

And as usual, someone feels the need to suggest searching when someone did before they posted.
As I said, I have CLI access to the server and know full well what the version is.
But, nextcloud doesn’t seem to know that.

I also ran these to tell the OS what it’s running but no different to nextcloud.
sudo dnf -y module disable php:remi-8.0
sudo dnf -y module enable php:remi-8.2

So thanks for the advise but the problem remains :).


You’re really bad at this.

You’ve been told twice that you’re only checking the CLI version of PHP, not the web version, but InDaClouds doesn’t seem to know that.

And as usual, someone feels the need to ignore the help they’re being given and be a dick to the person helping them.

1 Like

Nextcloud doesn’t “think” nor “know”.

Here the commands to see what php versions are in use:

Find out all php-related packages installed on your server (I am no rpm specialist, but this should do it) :

rpm -qa | grep 'php'

Find out the php version used on comandline (php-cli), either one of these commands:

php -v
readlink -f $(which php)
php -i | grep "PHP Version" | sort -u
echo $(php -r 'echo implode(".", array_slice(explode(".", PHP_VERSION), 0, 2));')

Find out what php-Version is in use by your apache2 server:

apachectl -tD DUMP_INCLUDES | sed -n '/php.*conf/ s#.*/\([^/]*\)\.conf#\1#p'

Hope this helps,

Much luck

But that is only until step 3 of the process to update from 8.0 to 8.2:

There are still some steps to be done:

1 Like

@ernolf, thanks, that showed me where the issue was.

Be a dick about it? LOL. Now you’re ganging up on me? My first time posting here and you just feel the need to make it a crummy experience. I searched, I didn’t find a solution so I posted. You don’t have to chastise people for posting when they can’t find answers.

It’s really a mystery to me how you came to that conclusion! I didn’t use the word dick!
I was only trying to help you because I like to help. Why did that turn out to be such a bad experience? Somehow I can’t quite keep up with that! I have just tried to objectively point out the points that you may have overlooked. So if you ask for help and then get some, that’s actually a good experience, isn’t it?

At least from my side a “please, you’re welcome.”

1 Like

@ernolf, I wasn’t talking about your response, it was about the previous ones before yours.

You responded with helpful information rather than the usual ‘you didn’t read’ nonsense that the others got me sucked into. When I searched, I didn’t use the right keyword combinations so wasn’t able to find a solution and decided to post.

I said thank you for your input, it helped me to solve the issue. I had overlooked some steps.