Gros problèmes d'affichages // problem displays [ probléme résolu ]

English version:

Good morning, everyone,

I’m coming to see you because I have big problems with my displays as shown in the picture below.

As you can see here I am logged in and yet the display is partial …

I also have various problems detected by the security scan, but I don’t think that these problems are related since during a later installation the same problems were present but the display was not as partial…

What’s more, I looked at one of your member’s post with the same security messages and he had no problem with postings, and all these problems are apparently solved with a capital letter.

Here’s the security report in case it can help you help me.

And there again other error messages and as you can see the display here came back suddenly

French version

Bonjour à tous,

je viens vous voir car j’ai de gros problémes d’affichages comme l’atteste l’image ci dessous.

Comme vous pouvez le voir ci je suis logué et pourtant l’affichage est partiel …

J’ai aussi divers problémes détecté par le scan de sécu, mais je ne pense pas que ces problèmes soient liées étant donné que lors d’une installation ultérieur les mêmes problémes étaient présents mais l’affichage n’était pas aussi partiel …

Qui plus est j’ai regardé le post d’un de vos membres avec les mêmes messages de sécurité et lui n’avait pas de soucis d’affichages, et tout ces problémes ce sont apparemment résolu avec une maj.

Voici le rapport de sécurité au cas où ça puissent vous aider à m’aider.

  • Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the . ([List of invalid files [/rescan?requesttoken=Nyi8G%2B1FImBtd6zo%2FxULLt0l%2Fcw9c5UKZOdM38sSXxM%3D%3AXU2LfLczaQc3M9yrulFSZ41Hnp9vN%2FljI4IhnrxlLGI%3D))
  • PHP does not seem to be setup properly to query system environment variables. The test with getenv(“PATH”) only returns an empty response. Please check the [installation documentation for PHP configuration notes and the PHP configuration of your server, especially when using php-fpm.
  • MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL. For further details read [the documentation page about
  • No memory cache has been configured. To enhance performance, please configure a memcache, if available. Further information can be found in the [documentation]
  • The database is missing some indexes. Due to the fact that adding indexes on big tables could take some time they were not added automatically. By running “occ db:add-missing-indices” those missing indexes could be added manually while the instance keeps running. Once the indexes are added queries to those tables are usually much faster.
  • Missing index “calendarobject_calid_index” in table “oc_calendarobjects_props”.
    • Missing index “schedulobj_principuri_index” in table “oc_schedulingobjects”.
  • Some columns in the database are missing a conversion to big int. Due to the fact that changing column types on big tables could take some time they were not changed automatically. By running ‘occ db:convert-filecache-bigint’ those pending changes could be applied manually. This operation needs to be made while the instance is offline.
  • mounts.storage_id
    • mounts.root_id
    • mounts.mount_id

Et là encore d’autres messages d’erreurs l’affichage est par contre revenu soudainement

En vous remerciant d’avance

Cordialement.

Hello @arawaks

Bienvenue !!

Je pense qu’il tout d’abord essentiel de régler tous les autres problèmes avant de faire quoi que ce soit. Histoire de partir sur de bonnes bases. Ce ne sont pas que des problèmes de sécurité.

Si tu rencontres des difficultés, nous sommes là pour vous aider.

Bonne chance :slight_smile:

Bye

@didi44 Bonjour ! Merci d’avoir prit le temps de répondre :slight_smile:

Par tous les autres problèmes tu entends quels problèmes ? Ceux de la 1er image où l’autre ?

Je suppose que la plupart sont déjà répertorier ici … j’avais déjà essayer d’en régler quelque un avant de m’inscrire ici en regardant justement les autres posts, mais j’ai eu effectivement des difficultées, la gestion des base de données comme le probléme ci dessous et ma bête noir. Avec tout ce qu’il y a d’inscrit dans php my admin ça me perd totalement …

@didi44 Pourrait tu me dire par où il faudrait selon toi commencer en priorité ? Y a t-il des problèmes qui te paraissent plus urgent où plus simple et rapide à régler que d’autres ?

Bonjour,

Je parle de ça :

Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the . ([List of invalid files [/rescan?requesttoken=Nyi8G%2B1FImBtd6zo%2FxULLt0l%2Fcw9c5UKZOdM38sSXxM%3D%3AXU2LfLczaQc3M9yrulFSZ41Hnp9vN%2FljI4IhnrxlLGI%3D))
PHP does not seem to be setup properly to query system environment variables. The test with getenv(“PATH”) only returns an empty response. Please check the [installation documentation for PHP configuration notes and the PHP configuration of your server, especially when using php-fpm.
MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL. For further details read [the documentation page about
No memory cache has been configured. To enhance performance, please configure a memcache, if available. Further information can be found in the [documentation]
The database is missing some indexes. Due to the fact that adding indexes on big tables could take some time they were not added automatically. By running “occ db:add-missing-indices” those missing indexes could be added manually while the instance keeps running. Once the indexes are added queries to those tables are usually much faster.
Missing index “calendarobject_calid_index” in table “oc_calendarobjects_props”.
Missing index “schedulobj_principuri_index” in table “oc_schedulingobjects”.
Some columns in the database are missing a conversion to big int. Due to the fact that changing column types on big tables could take some time they were not changed automatically. By running ‘occ db:convert-filecache-bigint’ those pending changes could be applied manually. This operation needs to be made while the instance is offline.
mounts.storage_id
mounts.root_id
mounts.mount_id

La deuxième image sont juste les logs.

Je te propose ici de commencer par résoudre vos problèmes certain sont simple d’autre vont demander un peux plus de temps :slight_smile: .

On va donc commencer par le plus simple :slight_smile:
Le cache
Il est peux probable, même improbable que le problème vienne de là, mais il faut absolument partir sur de bonne base pour continuer.

Le problème du cache est plutôt simple à résoudre, il permet de gagner en performance.

Pour cela il faut tout dabord installer le module suivant :
Sur Fedora/Centos php-pecl-apcu
Sur Debian/ubuntu php-apcu

Puis dans le fichier config.php rajouter la ligne suivante :
‘memcache.local’ => ‘\OC\Memcache\APCu’,

Ensuite il faut vérifier que APCU est activé par php, pour cela ce rendre dans php.ini et chercher la ligne suivante : apc.enable_cli si il y a un point virgule devant cela signifie que la ligne est commenté. Il faut l’enlevé. Puis mettre à 1 la valeur si elle est à 0.

Fait un petit reboot et dites moi si ça c’est résolue.

Source : https://docs.nextcloud.com/server/18/admin_manual/configuration_server/caching_configuration.html?highlight=cache

Bonne soirée

J’ai oublié de préciser une chose importante, je suis sur un serveur mutualisé, donc je n’ai pas la main sur le serveur à proprement parler.

J’ai rajouter tout de même la ligne au fichier

Je n’ai pas de fichier ini.php … simplement un config.php, peut être justement dû au fait que je n’ai pas installé ce que tu demandais plus haut ? La version de php utilsé par l’hébergeur est la 7.3 est en cas de besoin j’ai la possibilité de changer de version

EDIT: J’ai retirer la ligne

‘memcache.local’ => ‘\OC\Memcache\APCu’

sinon le serveur plante ce qui est j’imagine normal …

Re,

Il n’y a rien dans /etc/phpxxx/apache/php.ini ?

@didi44 re,

C’est un serveur mutualisé chez un hébergeur, donc je n’ai pas acces à apache, nginx etc, étant donné que les fichiers de mon site ne sont pas en local

Hmm,
OK je l’avais pas compris comme ça.

C’est un problème, il n’y a aucun moyen d’y avoir accès ? Comment avez vous fait pour installer le serveur ?

Bonne soirée

Si je peux simuler l’installation en local et ensuite transférer le fichier sur le serveur j’aurais du y penser plus tôt ! Je vais faire ça et je te tiens informé une fois que les manipulations plus haute sont faite :slight_smile:

OK parfait :joy:

@didi44 Hum … bon j’ai trouvé un php.ini dans ma vm mais il n’y avait pas la ligne que tu cite plus haut … donc je l’ai rajouté à php.ini et transféré sur le serveur.

Pour les fichiers de config relatif à apache je pourrais toulours les transférer sur le serveur par contre pour

ça je ne peut rien faire vu que sur l’hebergeur je ne peut rien installer

Bonjour,

Quelques petites questions pour bien comprendre.

Si je comprends bien vous avez là le server dans un VM ?
C’est éxactement les même fichier avec la même config pour faire des test ?

Autre chose.
Je peux avoir le nom de l’os, si vous utilisez apache ou nginx la verssion de php s’il vous plaît.

Merci

J’ai récupérer les fichiers du serveur mutualisé pour les placer dans une VM.
Du coup oui c’est exactement les même fichiers mais j’obtiens beaucoup d’erreur d’autorisation en faisant comme ça.

donc j’ai une autre configuration qui est un nextcloud où les fichiers proviennent directement du zip de l’installeur qui lui fonctionne bien.

En résumé j’ai 2 snapchot de cette VM. Une avec les fichiers de conf du serveur mutualisé que j’ai glissé directement dans le dossier cible du vhost mais où je n’ai pas accés à nextcloud à cause de messages d’erreurs relatif à des autorisations et beaucoup d’autres choses.

Une autre où l’installation est simillaire mais les fichiers proviennent du zip d’origine et où là tout fonctionne normalement.

Petite précision sur le serveur mutualisé tout est également d’origine malgré ces divers soucis d’affichages etc …

Sur la vm c’est apache et la version php tourne en 7.3

Bonjour,

D’accord parfait, nous allons donc pourvoir faire des tests.
(Pour le manque de droit pour la première snapshot, éssayez un simple sudo chown -R www-data:www-data /var/www/nextcloud, remplacez /var/www/ par votre chemin d’installation).

Si ça marche pas l’autre VM fera l’affaire.

Nous allons donc réessayer de résoudre le problème du cache avec les même commandes ci-dessus : Gros problèmes d'affichages // problem displays

Pour le php.ini il est éxactement dans le répertoire/etc/php/7.3/apache2/php.ini

Bonne chance :slight_smile:

Bonjour @didi44

Oui, j’avais déjà essayé mais il doit y avoir d’autres choses car ça n’a pas fonctionné.

php apcu s’installe à priori correctement, mais des que je rajoute la ligne dans config.php mon site n’est plus accessible, j’ai rééssayer aprés chaque opération et ça plante quand je rajoute la ligne …

Ah, et aucunes ligne apc_enable_cli de trouvé dans php.ini même aprés reboot une fois l’installation de php apcu

Ci joint des screens

Et voici des lignes de log les premiéres apparu à l’heure du crash

[Fri May 08 15:27:07.734087 2020] [php7:warn] [pid 2275] [client 192.168.1.100:42098] PHP Warning: Use of undefined constant \xe2\x80\x98memcache - assumed ‘\xe2\x80\x98memcache’ (this will throw an Error in a future version of PHP) in /srv/nextcloud/config/config.php on line 22
[Fri May 08 15:27:07.736883 2020] [php7:warn] [pid 2275] [client 192.168.1.100:42098] PHP Warning: Use of undefined constant local\xe2\x80\x99 - assumed ‘local\xe2\x80\x99’ (this will throw an Error in a future version of PHP) in /srv/nextcloud/config/config.php on line 22

Bonjour @arawaks

Pour le php.ini après vérification, je me suis trompé il y a plus besoins de mettre cette ligne. :slight_smile:

Pour le config.php c’est normal ce ne sont pas les bon caratères pour les cotes '". :slight_smile:

Regardes la ligne juste au-dessus.

Dis moi si ça marche.

@didi44 alors effectivement il y a une difference mais ça ne fonctionne pas plus.

ici on voit que quand les cotes sont de chaques coté ça décommente une partie de la ligne

là ça commente tout mais y a pas de cote partout et pareil serveur toujours innaccessible j’ai aussi essayé avec des au cas où … " "

et là j’ai actuellement cette synthaxe là mais idem une fois apache restart je n’ai toujours pas accès à nextcloud en local

La syntaxe est bonne mais il manque une virgule à la fin.

je l’ai rajouté entre temps mais non ça ne fonctionne toujours pas :thinking: