Getting started with NextCloudPi on Proxmox

Hello All, I followed the description of option 3. VM in Proxmox using the latest ISO image. Everything worked as it should. Thank you for the very good tutorial! Now my problem, I can reach the NCP web interface with my browser but I’m not able to get the SSH access to work. I tried to activate ssh over the NCP config panel for the pi user but the message was the user pi does not exist. So I tried with root user which worked. But now I get the message “Permission denied (publickey)” when I try to set up the ssh connection. I tried to check some ssh config via PVE console but every time I fill out my login data (ncp login) the blue NCP picture pops up a second and then I got thrown out to login again. Thus I have no access to my VM via the terminal, can anyone help? And please ask if you need further information! Thank you in advance!

1 Like

@Dani-Pi

You manage to get the VM to boot normally?

Could you check my post here: Getting started with NextCloudPi on Proxmox - #31 by Edson_Rodrigues

… and see what are the differences? I can’t get the VM image to boot :sob:

Thanks,
Edson

@Edson_Rodrigues Hi, the only thing I did different is I haven’t checked the SSD emulation checkbox and I do not have a zfs file system

Do you have any idea, why I do not have a pi user and why my SSH is not working?

Hi @Dani-Pi ,

So sorry, without access via SSH is quite difficult to debug that :thinking:. I guess that root access via SSH is disabled but I think that it should be enabled by default.

Maybe @OliverV or @nachoparker can chip in with their view. Pretty sure they will have an idea.

Thanks for your reply on my post, I will give it a try to see if I can make the image boot, maybe I can also reproduce the same issue? fingers crossed.b

Thanks,
ER

1 Like

I give up… I can figure out what I am doing wrong :frowning:

image

I tried installing in the “local-lvm” but same thing :frowning:

running

qm importdisk 105 NextCloudPi_VM_11-08-21.img local-zfs

did the trick for me, check link in my post above, for all commands I passed to PVE terminal.
Once that is done, rest can be done from the webUI.

Hi @OliverV

I did the radical thing and wiped all Proxmox and reinstalled it…

I repeated the process and I was able to boot the VM :slight_smile: thinking back, VERY likely it was the img that was corrupted and I never tried re-downloading the tar.bz2 :expressionless: that should’ve been one of my “retry” options.

Anyway, now seems ok and I will start more tests.

@Dani-Pi

I was able to boot the VM and auth with root/ownyourbits on the proxmox VM shell. Via SSH I was not able to get a session so I went to the NCP webUI on port 4443 and enabled SSH:

image

I tried SSH and I was able to get a prompt. Once I hit root > enter, I got disconnected and now I get:

image

When I went back to the Proxmox VM shell I authenticated with root/ownyourbits but this time I got a prompt:
image

I changed the password and I was inside the Proxmox VM shell, then I edited /etc/ssh/sshd_config

changed:

#PermitRootLogin prohibit-password

to:

PermitRootLogin yes

and also changed:

PasswordAuthentication no

to:

PasswordAuthentication yes

This worked for me and I am able to login via SSH and root.

Thanks!
ER.

@Dani-Pi

I can’t find the “pi” user so maybe it is not included in the VM version?

getent passwd | awk -F: ‘{ print $1}’

root
daemon
bin
sys
sync
games
man
lp
mail
news
uucp
proxy
www-data
backup
list
irc
gnats
nobody
_apt
systemd-timesync
systemd-network
systemd-resolve
messagebus
uuidd
sshd
_chrony
vagrant
systemd-coredump
mysql
postfix
redis
ncp
_rpc
statd
dnsmasq
prometheus
avahi

@Edson_Rodrigues Hi, thank you for your detailed feedback! Yes, that’s the way it should work. I will try it again in some days. I solved the problem with using the CURL Installer instead of ISO image to built up the NCP VM. Because of the pi user I think so too. Has something to do with VM ISO.

1 Like

@Dani-Pi

The curl installer worked 100% for you?

I am asking this because it always worked for me but the last times I tried to useit, I always get a error when the script is just about to finish :frowning: I think it could be a “bug” as I seen this issue happening in other situations. For the first time I posted in github:

Instalation script fails with: Column “oc_preview_generation”.“locked” is type Bool and also NotNull, so it can not store “false”. #1391

From several posts in the forum to github, I see that people like @nachoparker and @OliverV are pretty much hands-tied and cannot support/verify everything so I will wait patiently for a reply.

Cheers,
ER

EDIT: I found my error. I had installed a nextcloud LXD, not a nextcloud pi LXD. :laughing: I’ll try to get the nextcloudpi one running now.

I am trying to install nextcloudpi using method one: :new: LXD option! I already have ncp running on a pi (for a while now, maybe a year?) and I’m looking to port it over to my shiny new NUC. :slight_smile:

I’m happy to share the steps I’ve done to make whatever modest improvements I can to the documentation that you kindly maintain. :slight_smile:

I’m stuck at the moment on the splash page. I’m getting hit with the " Access through untrusted domain" message on the web gui, and when I log in through the console in proxmox, I am prompted for “NextCloudPi login:”, but none of the user/password combos mentioned here have granted me access (root/root, root/ownyourbits, root/vagrant). Are there any other passwords or methods that I can try?

My process thus far:

To start, I used the proxmox console to check the available containers (as described in the proxmox docs:

pveam available

I then copied the line for nextcloud and downloaded it with:

pveam download local debian-10-turnkey-nextcloud_16.1-1_amd64.tar.gz

From there I created the container in the GUI. I’ll try using the command line the next time I do this (I am going to help a friend if I succeed) as that is usually easier to document.

I tried to import the LXD into proxmox directly via url from the tar.gz link at Index of /downloads/NextCloudPi_LXD_10-08-21/

However, it appears that proxmox wants a tar.gz file, so I downloaded the tar.bz2 , uncompressed it with 7-zip, and then recompressed it as a tar.gz. I was able to upload the tar.gz into proxmox, but when I tried to create a container from it I got approximately one million errors. They all look like this:

Creating filesystem with 2097152 4k blocks and 524288 inodes
Filesystem UUID: cb109969-4b6f-4531-9649-7e18ee983e11
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632
extracting archive '/var/lib/vz/template/cache/NextCloudPi_LXD_10-08-21.tar.gz'
tar: backup/container/rootfs/bin: Cannot change ownership to uid 100000, gid 100000: Invalid argument
tar: backup/container/rootfs/boot: Cannot change ownership to uid 100000, gid 100000: Invalid argument
tar: backup/container/rootfs/dev: Cannot change ownership to uid 100000, gid 100000: Invalid argument
tar: backup/container/rootfs/etc/.pwd.lock: Cannot change ownership to uid 100000, gid 100000: Invalid argument
tar: backup/container/rootfs/etc/adduser.conf: Cannot change ownership to uid 100000, gid 100000: Invalid argument
tar: backup/container/rootfs/etc/aliases: Cannot change ownership to uid 100000, gid 100000: Invalid argument

I wonder if my 7-zip chicanery caused this. Does anyone have any advice on how to get the proper file into proxmox?

Hi @igijfl nice to see that you also try to get it working.
I haven’t had much time these days but was finally able to put a post together about my attempts.

I got a bit further than you, but it’s not yet working either.
See this post >> Making it possible: NextCloudPi LXD on Proxmox

For option 3, the link https://ownyourbits.com/downloads does not work anymore. And on nextcloudpi.com, VM install is mentioned, but under downloads (Releases · nextcloud/nextcloudpi · GitHub) I do not see any download for a VM?!

On the section " Pass through a drive that is used for NCP data" I am a bit lost.
I have installed NCP in Proxmox and want to continue using the HDD that so far I was using in NCP in my Raspberry Pi.
So far my datadir was /media/USBdrive/ncdata.
In the proxmox installation it is /var/www/nextcloud/data.
As it looks like I cannot change this, would I need to mount the HDD folder into /var/www/nextcloud/data? I guess that is not possible to mount into this folder, isn´t it?
But as the nc-datadir option is not available in ncp-config, what do I do?

I just updated the first post.
So the links should work again and I mentioned about the VM being Discontinued (for now).

The Pass through is for a VM so I guess that might now work the same way with a CT?

From this post I understand that you solved the other issues.

@OliverV @just @ZendaiOwl @theCalcaholic

Should we add the Proxmox Helper Script to the official NCP Documentation? It seems legit.
I like to try the script and will take screenshots and notes if we agree to put it in the official docs.
(No promises on when this will happen, we are still hard at work with our startup)

1 Like

Hi, first of all: great work! I love this guide and used it many times! But now the Second way is not working anymore, because of an automatic update of PHP. I tried to install my Debian11 VM as i did many times before and now I am not able to install Nextcloud with the curl command.
I tried also with a clean install of Debian and did not run “apt install update / upgrade” before proceed with the curl command, same issue… “this Version of NextCloud is not compatible with PHP8.2”
I think i have to downgrade PHP before I can install Nextcloud.

There was an issue in the ncp curl script. Which is solved by now.

Thank you! Thats great

The unofficial Proxmox Helper Script by tteck is broken. Getting the following error message when trying to login to the shell “This account is currently not available”. Additionally it appears the SSH module in the NCP admin panel is missing. I’ve started a Discussion topic in tteck’s github here.

1 Like