Gallery can't see full size pictures?

First, not sure if this is in the right category. Mods, feel free to move it as appropriate – sorry, it’s my first post!

Ok, I have no problems with thumbnail generation (using preview generator) or anything. The gallery is working fine EXCEPT that I cannot see full sized pictures! It loads the largest preview image instead of a full-size image when I click on it. I get that for previews this is helpful, or maybe for mobile clients on mobile data, but when I’m viewing pictures at home on my LAN, I want the full image! Also, when sharing pictures I don’t want other people only getting small preview images and having to download each file independently.

If I download the file via the link/button, I get the full image but, then I have to use an external image viewer. If I right-click on the displayed image and download that, I can see that’s it’s just a preview image.

Is there a solution to this? Perhaps an option to enable full-sized pictures instead of just previews?

Thanks in advance :slight_smile:

2 Likes

It was considered some time ago but not realized:

I totally agree! My high resolution tablet loves high res photos :wink:

1 Like

So this is not something that NextCloud can do or that the dev team is looking into as an option? Just asking because a big reason I’m using NextCloud instead of other options is easy web-access to my documents AND pictures. If there is no easy option to view full-sized pictures when desired, then I’ll look into another alternative instead and maybe check back in with NC in future versions.

Thanks for the feedback :slight_smile:

It certainly something that could be integrated. If there is a need, open a new feature request. There were some questions in the old topic, how to avoid mobile devices using up their bandwidth, … and then of course some help would be appreciated.

Thanks, I’ll post something in the feature requests as suggested. Also, if I stumble onto a possible solution, I’ll update the topic for future readers. Thanks again!