Files not getting synced (413 Request Entity Too Large)

Nextcloud version: 15
Operating system and version: docker image linuxserver/nextcloud
Apache or nginx version: nginx 1.14.2
PHP version: 7.2.13

The issue:

Some files are not getting synced and the Windows client gives me the error

"Server replied "413 Request Entity Too Large" to "PUT https://my_domain/remote.php/dav/uploads/username/XXXXXXXX/YYYYYY" (skipped due to earlier error, trying again in 6 hour(s))
PATH/TO/FILE.bmp

My nextcloud is behind a letsencrypt nginx reverse proxy. I checked there and modified the file size limits in proxy.conf file:

client_max_body_size 10G;
client_body_buffer_size 400M;

After doing this I restarted the letsencrypt container and restarted the sync, which now passed almost all the files. Alas, there are some files left (some bmp, pdf, rar, zip and doc) which are not really too big - 20M, 11M, 15M.

At the same time, If I copy a new file (I tried with a zip file) pretty large (160M) I have no problem getting it synchronized on the server.

So, is there a “flag” set on these files so that they would not sync?

I am having the same problem. Any body have any ideas?

i have the same problem! With mobile device.

If you’ve already tried the usual fixes of changing client_max_body_size in the nginx.conf, as well as the post_max_size and upload_max_filesize in php.ini, and it still doesn’t work. Please see the solution that I posted here: https://github.com/nextcloud/docker/issues/762#issuecomment-504225433