Files in empty in browser version


my Versions:

  • Nextcloud Version: 14.0.4
  • Operating system and version: Raspbian 9
  • Apache or nginx version: Apache/2.4.25 (Raspbian)
  • PHP version: PHP 7.0.30-0+deb9u1

After someone changed the upgrade path to experimental and everything broke, I made a rollback to 14.0.4 and switched to stable. After all that, there were no files shown in the web ui. WebDav works like a charm, all clients sync their files, but you cannot longer access files in browser.

Logs do not show anything, neither apache logs nor Admin->Logs shows any problem.

Any idea what I could check next?

Thank you

You can try this sudo -u www-data php /path/to/your/nextcloud/occ files:scan
example if your nextcloud Folder is in /var/www/:
sudo -u www-data php /var/www/nextcloud/occ files:scan

Hi, thank you for your answer.

I rescanned all files, but it did not change anything. :frowning:

what happend if you create another user?
or have you enabled Apache security_mod?

same issue here.
new user (ldap) shows empty files app too.
I do use Apache 2.4.18 with mod_security2 - disabling does not change anything.
sync clients are working, files app in browser is empty.

EDIT: found a JS console error: EvalError: call to Function() blocked by CSP

fixed it
for those with similar issues:
as described here: Display issues after upgrade to NC 13.0.0
rm -r data/appdata_/css/ data/appdata_/js/
occ files:scan-app-data
reload the page
browser console told me, that some not refreshed js filed used a deprecated / no longer existing function

1 Like

Oh my God this just saved my butt.
After migrating my hard disk partition table from ms-dos to gpt, my files app wouldn’t load anymore.
Gallery app, all syncs, even profile picture picker showed all files.

This was on 18.0.3 and Not after an upgrade. But this instance of nextcloud has seen lots of upgrades in its lifetime.

With this solution it worked again instantly. Thanks a lot!

After upgrading from 17 to 18 back in the days, my standard search engine wouldnt work anymore. I ended up installing full text search and built up elasticsearch which did work as a workaround.

After deleting the mentioned files, now standard search is also working again!
Solved two problems in one! It’s hard to overstate my satisfaction.™