Files deleted by accident,

I don’t know what happens. Many files are deleted…
When I open my Nextcloud in the browser and go to /apps/files/?dir=/&view=trashbin, I see an error: “This directory is unavailable, please check the logs or contact the administrator”.
Which logfiles do I have to check?
Is it safe to move the files from ./files_trashbin to ./files in the terminal? (Which command is the best to use?)

Best regards,

Hi @Marianne_van_Harten,
You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

You should not manually alter anything in the data folder unless absolutely necessary.

I agree.
But if you like you can download the files from trashbin to your local pc (then you have the files again) and then upload it again to your Nextcloud. Maybe first in a new folder.

For your problem.
You find the Nextcloud logs in /path/to/nextcloud/data/nextcloud.log
Access trashbin and post errors.

I tried to fill in the support template. I am able to answer only the first few questions. I hope it will help…

Nextcloud version (eg, 20.0.5): 24.0.4
Operating system and version (eg, Ubuntu 20.04): 20.04.4 LTS
Apache or nginx version (eg, Apache 2.4.25): nginx/1.23.1
PHP version (eg, 7.4): 7.4.3

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

(screen looks like empty; only navigation bar at the left)

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'passwordsalt' => 'XXXXXXXXXXXXXX', 'secret' => 'XXXXXXXXXXXX', 'trusted_domains' => array ( 0 => '', ), 'datadirectory' => '/var/nextcloud_data', 'dbtype' => 'mysql', 'version' => '', 'overwrite.cli.url' => '', 'dbname' => 'XXXX', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => 'nextcloud_db_user', 'dbpassword' => 'XXXXXXXXXXXXXX', 'installed' => true, 'instanceid' => 'XXXXXXXXXX', 'memcache.local' => '\\OC\\Memcache\\APCu', 'default_phone_region' => 'DE', 'logtimezone' => 'Europe/Amsterdam', 'filelocking.enabled' => 'true', 'memcache.locking' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => '/var/run/redis/redis-server.sock', 'port' => 0, 'timeout' => 0.0, ), 'maintenance' => false, 'theme' => '', 'loglevel' => 0, 'mail_smtpmode' => 'smtp', 'mail_sendmailmode' => 'smtp', 'mail_from_address' => 'mijn', 'mail_domain' => '', 'mail_smtphost' => '', 'mail_smtpport' => '587', 'mail_smtpauth' => 1, 'mail_smtpname' => '', 'mail_smtppassword' => 'XXXXXXXXXX', '' => 'stable', 'updater.secret' => 'XXXXXXXXXXXX', );