Filelink: Upload works, but no link


I just installed the add on Nextcloud for filelink. I run a Nextcloud instance on my Raspberry Pi with a Letsencrypt certificate. This works fine with the sync client and the web ui. Syncing the calendar and the contacts with Thunderbird and Cardbook works fine, too.

I configured the filelink add-on:
Port number: 443
Username: me
Path in nextcloud: /Mail-attachments (default)

The add-on creates the directory /Mail-attachments, so login works and credentials are correct. But it shows: Used memory: 16,0 GB, free memory: 0 Byte.
When I write a mail with attachment, the upload works. The file is stored in /Mail-attachments. The add-on shows an error:
“Beim Datenaustausch mit trat ein unbekannter Fehler auf.”
(“An unknown error occurred when communicating with”)
Thunderbird creates no link and sends the Mail with attachment.

How can I find the error?

Edit: In the developer tools I found:

“2017-10-08 23:20:15 Nextcloud ERROR Could not retrieve password”

Hm, but the upload works?

(Edit: english error added.)

Best regards,


Whats your current Nextcloud version?


status.php says:

Thunderbird: 52.4.0 (64-Bit)
Filelink 1.7



I have deleted the filelink account an created a new one. My developer tools gave me that error:

2017-10-11 15:54:31	Nextcloud	ERROR	Could not retrieve password
	CApp_append resource:///modules/gloda/log4moz.js:691:7
	Logger_log resource:///modules/gloda/log4moz.js:380:7
	Logger_error resource:///modules/gloda/log4moz.js:388:5
	nsNc_logon jar:file:///G:/PortableApps/ThunderbirdPortable/Data/profile/extensions/!/components/nsNextcloud.js:430:4
	nsNc_logonAndGetUserInfo jar:file:///G:/PortableApps/ThunderbirdPortable/Data/profile/extensions/!/components/nsNextcloud.js:720:10
	nsNc_refreshUserInfo jar:file:///G:/PortableApps/ThunderbirdPortable/Data/profile/extensions/!/components/nsNextcloud.js:258:11
	CFT_requestUserInfoForItem chrome://messenger/content/preferences/applications.js:633:5
	CFT_rebuildView chrome://messenger/content/preferences/applications.js:607:9
	CFT_addCloudFileAccount chrome://messenger/content/preferences/applications.js:763:5
	gCloudFileController.commands.cmd_addCloudfileAccount.doCommand chrome://messenger/content/preferences/applications.js:445:9
	gCloudFileController.doCommand chrome://messenger/content/preferences/applications.js:489:5
	goDoCommand chrome://global/content/globalOverlay.js:100:7
	oncommand chrome://messenger/content/preferences/preferences.xul:1:1
	openOptionsDialog chrome://messenger/content/mailCore.js:427:7
	oncommand chrome://messenger/content/messenger.xul:1:1
2017-10-11 15:54:31	Nextcloud	ERROR	Could not retrieve password

I made this test with portable Thunderbird and Windows. Installed Thunderbird on Ubuntu gives the same result.

see here:

you are not the first with this error. i would help you but how? it works perfect on my system.

Update: It works now. I modified my Nextcloud configuration. “Allow users to share via link” was enabled. “Enforce password protection” was enabled, too. I have disabled it. In the plugin configuration I have deleted the password. Now it works.
Configured it new, with “Enforce password protection” enabled and password in plugin, works.
I think, the password was not set correctly.

It should work with “Allow users to share via link”

So it is solved. Please check your last answer as “solution” that this thread is solved. This will help others.

Udate again:
Today, no configuration changes, just a day later, the same issue reappeared. I shut down the computer and started it again, today. I tested it on Thunderbird/Ubuntu and Thunderbird portable/Windows 7.

Dear all,
I had the same issue and found that the issue is with the configuration.:

your password must be compliant with you security settings (Uppercase, Lowercase, number of characters, weird characters and so on)


It worked for me after I created an app password for my account. (Settings, Personal, Security).

Thank you. Actually, it works for me without app password.