File was deleted from server, but still visible on web-ui (also for desktop-client)

unfortunately didnt help either, its still shown on the web-ui

So you’re syncing it from a computer with the desktop sync client right? Try creating a file with the same name, let it sync, then delete it from the webui.

im trying to do what youve mentioned, but unfortunately im not able to use my computer atm. :slight_smile:

ill come back to you and give a proper response. but thank you very much in advance!

@stratacast actually it didnt help, it just creates a 2nd entry in the webui of which only the newly generated file can be deleted, but not the old one - it remains on the webui.

any ideas? manipulating the SQL-database?

Hmmm interesting. I think that’s your next best option, but be sure to make a backup of your database before you go in and make edits ^^ I’m always leery of making db edits with this kind of stuff, so I would consider manually editing the nextcloud database a last resort

well, anything else didnt help so far… a mysql-dump is made pretty quickly, therefore i’d really appreciate if anyone knows what table/entry to modify or look for. :slight_smile:

I’ve got a similar thing on 11.0.3 since upgrading windows client to latest 2.3.1 (Win7).

Plenty of “…file was deleted from server” . I checked on the server (after occ:scan) and it’s quite a mess. Some files are not there anymore (error), others are there, but winclient gui shows “… File was deleted from server”…

I tried zipping some folders with the idea of shortening path depth and getting rid of special characters - it worked, but it’s a hassle… impossible to go through 3 GB of data. Would really be better, if all the syncable files got synced first and then the errors were thrown and client stops…

Any idea? thanks

Guys - it really seems that I’m losing files since 2.3.1 in my constellation.

I think I can nail it down either to Umlaut files (äöü) or to the combination of path depth and Umlauts, not sure… can anyone confirm something similar?

After downgrading Windows desktop client 2.3.1 back to 2.2.4 , synchronisation works again. (on 11.0.3)

Has something substantially changed in 2.3.1 that could affect synchronisation?

can confirm this!

@victorbw are you able to edit the topic’s title and add “desktop client” as well?

Maybe someone confirms our troubles.

Hi, I think I’m having the same problem since the 2.3.1 update. I’m in a small NGO and everyone has the “file was deleted from server” error.

The files in question were effectively deleted a while ago, but:
1.) They are still visible in the webui and not deletable
2.) Some people still had them in their local folder
3.) If I move them out of one of those folders and back in after syncing it doesn’t change anything

1 Like

I just manually restored (and renamed) about 40 “deleted” files and folders from a backup.

All of them originally contained Umlaut (äöü). In my backup (from server directly) they had placeholder characters (“ö” for “ü” , some “?” etc.). This seems to be some UTF issues?

Well I don’t think that’s the problem on my end; the files I had problems with sometimes didn’t contain any special characters at all.

Quick update: I tried using the Owncloud client, and then downgrading it to 2.2.4, but the problem’s still there. Only difference is that the error doesn’t appear on the first tab of the client before the list of files on the server, but under the “Activity” tab, in the list of files that aren’t synced.
But then I get some weird stuff, like a folder’s content not being synced at all. This folder containted some problematic files (“deleted from the server”), but also some normal files and none were synced.


was abroad a few days :wink:

I’ve been having the same issue for a few weeks - clients won’t sync, and show one of two messages:

  1. File was deleted from the server.
  2. File with name {FileName} could not be located

File shows up in web-ui, but is not there on server or on client computer.

Upgrading/downgrading client does not help the issue.

I’ve cleared a few by editing the db directly (finding id number from web-ui, and deleting), but the list seems to be growing. I am at the point where I am going to do a complete system backup/upgrade to see if that clears the issue.

Could those having similar problems describe their setup?

Debian 8.X latest
Apache 2.4.10
PHP 7.0.20-1~dotdeb+8.1
Ver 15.1 Distrib 10.0.30-MariaDB

Maybe we’ll find some common stuff

I’m running the following:

Nextcloud 12
CentOS Linux 7.2.1511
Apache 2.4.6
PHP 7.0.13
MySQL 5.5.52

After deleting all of the non-existent files, the client started to sync again… then stopped later on in the day with a new list of files. I think I’ve come up with the workflow that causes this issue (at least for me):

  1. All files are owned by me (admin) and shared to users
  2. User copies a folder containing files into local share
  3. User makes sub folder, and moves files into sub folder
  4. Nextcloud creates new folder and adds files to folder, but doesn’t delete link to original location

This happens constantly during the day, so the daily list of dead files is huge.

As a test, users are now going to create folder outside of Nextcloud share (or copy to folder outside of Nextcloud share), make all changes, and then move to new location - will know next week if this works.

oh and btw, this is on github already… but no response yet:

1 Like