File was deleted from server, but still visible on web-ui (also for desktop-client)

Nextcloud version: 11.0.3 (Updated over a few Versions, every neccessary step taken)
Operating system and version: Ubuntu 16.04.2
Apache or nginx version: 2.4.18
PHP version: 7.0
Is this the first time you’ve seen this error: Yes

Can you reliably replicate it?: No

The issue you are facing:

  • Client says that “File has been deleted on Server”
  • file was in a shared folder, has been deleted by file-owner/share-owner previously
  • trying to delete again file via Web-UI (as owner), file reappears with browser refresh
  • file is NOT available via SCP neither via ‘ls -hla’ in the specific directory (or any other), so i guess it’s been sucessfully deleted already
  • script to get rid of straylocks (with maintenance:mode --on) has been applied, no change at all

Nextcloud Log:

“app”:“webdav”,“message”:“Exception: {“Message”:“HTTP\/1.1 503 Error: Unsupported operand types”,“Exception”:“Sabre\\DAV\\Exception\\ServiceUnavailable”,“Code”:0,“Trace”:”#0 [internal function]: {closure}(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#1 \/var\/www\/html\/nextcloud\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Object(Closure), Array)\n#2 \/var\/www\/html\/nextcloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(466): Sabre\\Event\\EventEmitter->emit(‘beforeMethod’, Array)\n#3 \/var\/www\/html\/nextcloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(254): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#4 \/var\/www\/html\/nextcloud\/remote.php(70): Sabre\\DAV\\Server->exec()\n#5 \/var\/www\/html\/nextcloud\/remote.php(170): handleException(Object(Error))\n#6 {main}",“File”:"\/var\/www\/html\/nextcloud\/remote.php",“Line”:68,“User”:“NG”}",“level”:4,“time”:“May 03, 2017 14:53:38”,“method”:“PROPFIND”,“url”:"/remote.php/dav/files/NG/05-innovation/3.%20INITIATIVES/BIOSTART:1",“user”:“NG”,“version”:“11.0.3.2”}

The output of your config.php:

<?php
$CONFIG = array (
  'instanceid' => '***SENSITIVE***',
  'passwordsalt' => '***SENSITIVE***',
  'secret' => '***SENSITIVE***',
  'trusted_domains' =>
  array (
    0 => '***SENSITIVE***',
  ),
  'datadirectory' => '***SENSITIVE***',
  'overwrite.cli.url' => '***SENSITIVE***',
  'dbtype' => 'mysql',
  'version' => '11.0.3.2',
  'dbname' => '***SENSITIVE***',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_administrator',
  'dbpassword' => '***SENSITIVE***',
  'logtimezone' => 'Europe/Zurich',
  'installed' => true,
  'trashbin_retention_obligation' => 30,
  'trashbin_auto_expire' => true,
  'logdateformat' => 'F d, Y H:i:s',
  'log_rotate_size' => 104857600,
  'versions_retention_obligation' => '30,auto',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0,
    'dbindex' => 0,
  ),
  'maintenance' => false,
  'singleuser' => false,
  'data-fingerprint' => '***SENSITIVE***',
);

The output of your Apache-Error-Log:

PHP Fatal error: Uncaught Error: Access to undeclared static property: OC\Files\Filesystem::$normalizedPathCache in /var/www/html/nextcloud/lib/private/Files/Filesystem.php on line 806

Anyone has an idea how to get rid of this? because several clients

1 Like

I think I recall running into this, is this on a samba share by any chance? I know you have to enable an experimental function in Nextcloud’s config.php to check storage that was modified outside the scope of Nextcloud operations. I think the reason why you see it in webui is because NC doesn’t know it’s gone, but can’t delete it yet again because it’s gone

nope, its not a samba-share, its located on the same disk as the whole system (BTRFS).

so do i probably have to midify the db by my own? and if, how’s the proper way to do this?

What about scanning all files on the server to get a clean state?

sudo -u www-data php occ files:scan

unfortunately didnt help either, its still shown on the web-ui

So you’re syncing it from a computer with the desktop sync client right? Try creating a file with the same name, let it sync, then delete it from the webui.

im trying to do what youve mentioned, but unfortunately im not able to use my computer atm. :slight_smile:

ill come back to you and give a proper response. but thank you very much in advance!

@stratacast actually it didnt help, it just creates a 2nd entry in the webui of which only the newly generated file can be deleted, but not the old one - it remains on the webui.

any ideas? manipulating the SQL-database?

Hmmm interesting. I think that’s your next best option, but be sure to make a backup of your database before you go in and make edits ^^ I’m always leery of making db edits with this kind of stuff, so I would consider manually editing the nextcloud database a last resort

well, anything else didnt help so far… a mysql-dump is made pretty quickly, therefore i’d really appreciate if anyone knows what table/entry to modify or look for. :slight_smile:

I’ve got a similar thing on 11.0.3 since upgrading windows client to latest 2.3.1 (Win7).

Plenty of “…file was deleted from server” . I checked on the server (after occ:scan) and it’s quite a mess. Some files are not there anymore (error), others are there, but winclient gui shows “… File was deleted from server”…

I tried zipping some folders with the idea of shortening path depth and getting rid of special characters - it worked, but it’s a hassle… impossible to go through 3 GB of data. Would really be better, if all the syncable files got synced first and then the errors were thrown and client stops…

Any idea? thanks

Guys - it really seems that I’m losing files since 2.3.1 in my constellation.

I think I can nail it down either to Umlaut files (äöü) or to the combination of path depth and Umlauts, not sure… can anyone confirm something similar?

After downgrading Windows desktop client 2.3.1 back to 2.2.4 , synchronisation works again. (on 11.0.3)

Has something substantially changed in 2.3.1 that could affect synchronisation?

can confirm this!

@victorbw are you able to edit the topic’s title and add “desktop client” as well?

Maybe someone confirms our troubles.

Hi, I think I’m having the same problem since the 2.3.1 update. I’m in a small NGO and everyone has the “file was deleted from server” error.

The files in question were effectively deleted a while ago, but:
1.) They are still visible in the webui and not deletable
2.) Some people still had them in their local folder
3.) If I move them out of one of those folders and back in after syncing it doesn’t change anything

1 Like

I just manually restored (and renamed) about 40 “deleted” files and folders from a backup.

All of them originally contained Umlaut (äöü). In my backup (from server directly) they had placeholder characters (“ö” for “ü” , some “?” etc.). This seems to be some UTF issues?

Well I don’t think that’s the problem on my end; the files I had problems with sometimes didn’t contain any special characters at all.

Quick update: I tried using the Owncloud client, and then downgrading it to 2.2.4, but the problem’s still there. Only difference is that the error doesn’t appear on the first tab of the client before the list of files on the server, but under the “Activity” tab, in the list of files that aren’t synced.
But then I get some weird stuff, like a folder’s content not being synced at all. This folder containted some problematic files (“deleted from the server”), but also some normal files and none were synced.

done!

was abroad a few days :wink: