File Drop: Cannot upload files larger than 100MB

Hi there,

With a public File Drop page, a user cannot upload files larger than ~100MB. Logged in users are fine, large uploads working okay inside Nextcloud, the issue just seems to be on public File Drop pages only. Visitors say this is error message they get:

We have not had this issue with past Nextcloud versions until Nextcloud 24.

We have configured the settings for nginx and PHP and the Nextcloud config according to the documentation.


Nextcloud version: 24.0.4
Operating system and version: Ubuntu 20.04.5 LTS
Web server: nginx/1.18.0 (Ubuntu)
PHP version: PHP 8.0.14

Steps to replicate:

  1. Share a folder and set to ‘File Drop’
  2. Visit link and upload a file larger than 100MB.

Hoping this will get a fix soon as it looks like an issue has been open for it since 2017: Allow chunked public upload · Issue #4109 · nextcloud/server · GitHub


change this line to
client_max_body_size 0;


change this line to
client_max_body_size 0;

sudo service nginx restart

retry to upload big files

Hi there, thanks for the suggestion.

I tried client_max_body_size 0; as well as several very large values on nginx with Nextcloud 25.0.2 and unfortunately, I get the exact same behaviour.

I hope the addition of file chunking here fixes the problem?

did you restart nginx ?
did you use cloudflare ?

try client_max_body_size 0; and pass trough internal ip as public File Drop page. for me cloudflare block but not directly from ip


Yes, I restarted nginx service after any config file change like usual: sudo systemctl restart nginx

Yes, using Cloudflare, but I think the addition of file chunking for file drop pages would be great to fix the underlying problem, regardless of having Cloudflare (or any other provider) as a CDN.


I just wanted to chime in and say I’m experiencing the same issue. I’m running nextcloud via docker and using nginx reverse proxy. Large uploads work fine via my phone as I use photo/video backup all the time and also tested uploading a 4 GB file to the drop folder via the Android app. My max upload size is set to 40 GB and my nextcloud admin page confirms this. The only time I’ve experienced issues is with browser uploads via the drop folder, and doing so results in a 413 error once the file fully uploads (the upload is not rejected outright).

I’m happy to try out any potential solutions to this. Running the latest version of nextcloud.

i run lastest version of nexcloud … and no chunking for file drop.
only file chunk for loged user …
request the option to nextcloud directly …
but only cloudflare free package need it because of restrict to 100mb up.

I have the same situation as mentioned above.
Is there some news on how to fix it?

This doesn’t sound like the case for the OP, as he states it’s only an issue for guest users, but for some of the rest of you be aware the web interface is limited by the max size php allows. The relevant setting in the php.ini is:
I have mine set to 1G

I can confirm when I disable Cloudflare for DNS, the upload issue disappears. Now everything is working fine, no crash during upload.