Failed Update to 18.0.6

Ok, I’m very new to Nextclound but I just tried to update to 18.0.6. (The update was for Community Document Server (documentserver_community)) but after trying to run the update it failed with the following log…

Update to 18.0.6

Exception: sh: …/…/tools/allfontsgen: not found

Detailed logs

Preparing update

Set log level to debug

Turned on maintenance mode

Repair step: Repair MySQL collation

Repair info: All tables already have the correct collation -> nothing to do

Repair step: Repair SQLite autoincrement

Repair step: Copy data from accounts table when migrating from ownCloud

Repair step: Drop account terms table when migrating from ownCloud

Updating database schema

Updated database

Repair step: Rebuild font library

Exception: sh: …/…/tools/allfontsgen: not found

Now I every time I try to login to the website I just get brought to the start update screen.

Please help

2 Likes

Hello i have the same problem. My installation is on an unraid server with docker.

1 Like

Same here, please help (Unraid Docker Also)

Hi
Same for me (unraid docker)

Hi,
Same problem with docker :cold_sweat:

Solved guys just oper the docker therminal and write this command:

occ app:disable documentserver_community

This will disable the plugin and let you update.

1 Like

i try both commands and it finally work :

  • occ maintenance:mode --off
  • occ app:disable documentserver_community

Hi there I followed the instructions and it was telling me that the command was not found. I see the file is there something I can add into that file?

Update: was able to get the update to install to the system after getting the latest update to the container from Linuxserver.io. Now getting a 502 gateway error and not sure where to go from here.

Update 3: Still unable to get past the 502 gateway error, went through and tried everything again by retracing the steps of my install but unable to get it. Phone is still able to access the site for some reason but in my browser I am not getting access to the site either via reverse proxy or from the IP address, please help!

Hi

It worked fine after disable document server. Thanks.

After update, I am not able to enable document server, same error: sh: …/…/tools/allfontsgen: not found. Do someone now how to fix?

Delete cash and cookies on your navigator and try again to connect to NC

I think we need to wait for an update to fix it

I too am facing an installation that will not upgrade with the same error as the op.
occ app:disable documentserver_community did not help.
Also on unraid docker.
Tried updating to nextcloud 19 also with no luck.

I was able to clear it from all my browsers and still having issues. It also appears that my mobile app is now giving me a 502 bad gateway error now. Tried my other things that I am hosting and they are working just fine. Not sure what else to do.

Well I narrowed it down, it appears that I can not access the nextcloud locally due to the service being busy, any ideas?

I had the problem updating the nextcloud docker running in unraid
I followed the instructions below the all worked fine

So… the docker updates, upgrade the docker itself it doesn’t perform the upgrade on Nextcloud.

You can do it through the webui but i find the wheels fall off that sometimes and it becomes a pain.

I prefer doing mine through the CLI its also easier to fix if something goes wrong if your in the CLI.

Open a console on the docker image.

cd /config/www/nextcloud/updater/

root@bd32ce1bcd66:/config/www/nextcloud/updater# sudo -u abc php updater.phar

This will launch the CLI upgrade tool which will tell you what version you are and you can do the upgrade.

Nextcloud Updater - version: v14.0.2RC2-7-g57268cb

Current version is 15.0.5.

Update to Nextcloud 16.0.3 available. (channel: “stable”)
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-16.0.3.zip

Steps that will be executed:
[ ] Check for expected files
[ ] Check for write permissions
[ ] Create backup
[ ] Downloading
[ ] Verify integrity
[ ] Extracting
[ ] Enable maintenance mode
[ ] Replace entry points
[ ] Delete old files
[ ] Move new files in place
[ ] Done

Start update? [y/N] y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[:heavy_check_mark:] Check for expected files
[:heavy_check_mark:] Check for write permissions
[:heavy_check_mark:] Create backup
[:heavy_check_mark:] Downloading
[:heavy_check_mark:] Verify integrity
[:heavy_check_mark:] Extracting
[:heavy_check_mark:] Enable maintenance mode
[:heavy_check_mark:] Replace entry points
[:heavy_check_mark:] Delete old files
[:heavy_check_mark:] Move new files in place
[:heavy_check_mark:] Done

Update of code successful.

Should the “occ upgrade” command be executed? [Y/n] Y

sit back, drink a coffee and wait for it to finish. it can take a while before there is any output here.

And then say No here

Keep maintenance mode active? [y/N] N

If you say yes you need to run another command to disable maintenance mode and get Nextcloud back up and running.

This is for if you want to do other things after the upgrade before making Nextcloud live again.

First connect to the webui you will need to do a quick start upgrade button but it just does a DB check and starts.

Edited July 23, 2019 by Maticks

I tried this but it is saying that the current version is 18.0.6 and no new update is available. Nothing to do. Did the latest update screw up something else that I am not aware of?

@Ray_Fielding i’d suggest to remove the solution tag from that post, as it is only a workarround that causes people other issues they might not expect if they dont read the posts after that.

Actually the solution to that issue is to wait for 18.0.7 if you need collabora working which i expect, if you have documentserver_comunity installed.
If not, you can disable documentserver_comunity app and try again and the update will run through but you can not use collabora anymore.

Start à new post for helping. We need Apache log.

I have the same problem. Do you already have a fix? Please explain exactly how it works, I’m a newbie. hopefully there will be one or in the next time.

I had same issue and did fixed it like @pajac wrote already.

A bit stange that you can install the community_server if its not supported on RaspPi!?
At least in never got it running and now it creates this update problem.

This is a bug in the updater. Same issue here. It hangs on the communicator app that is not even used. Only the Document server app could be used by my client. This is running on an other server that is not running the full communicator environment.
Why the updater is hanging on an app that is not used/active? Normally these apps are disabled when updating. Not now.
I wil delete the app and see what happens after that.

And YES.
Delete the community app in the apps folder.
Edit config to maintenance mode ‘false’
Wait a few minutes and refresh the nextcloud browser window.
After pressing the update button, everything went correct. Except that the user.ini is overwritten and I have to put the line for memory 512 again in this file.