Failed to load "nextcloud office"

Bonjour,

After a long search in the forums, I stumble
upon a problem: the link “nextcloud office” and collabora,
on a newly installed server. I want a little help because I can’t do
it. Thanks in advance. `

### Description of the problem:

The setting seems ok

Yet when I try to edit a document I get the following message:`

image

translation: Failed to load document Failed to load NextCloud Office. Check again later

Here are the logs of Collabora online office suite

https://paste.yunohost.org/paduwicili

as well as that of Nginx`

https://paste.yunohost.org/bigonocota

I observe several errors:

At the end of the collabora logs

Apr 06 14:24:13 coolwsd[653]: wsd-00653-164053 2023-04-06 14:24:13.627207 +0000 [ docbroker_010 ] ERR  loading document exception: Access denied. WOPI::CheckFileInfo failed on: https://intra.resohabitat.fr/yunohost/sso/?r=aHR0cHM6Ly9pbnRyYS5yZXNvaGFiaXRhdC5mci9uZXh0Y2xvdWQvaW5kZXgucGhwL2FwcHMvcmljaGRvY3VtZW50cy93b3BpL2ZpbGVzLzUyX29jNmlyNmNiOHdtaj9wZXJtaXNzaW9uPWVkaXQmYWNjZXNzX3Rva2VuPUt4aTlYSkIyanllZEVyQVd0bkljS0s2Wkh6QmxxMnBIJmFjY2Vzc190b2tlbl90dGw9MTY4MDgyNzA1MTAwMA==&access_token=Kxi9XJB2jyedErAWtnIcKK6ZHzBlq2pH| wsd/DocumentBroker.cpp:2456
Apr 06 14:24:13 coolwsd[653]: wsd-00653-164053 2023-04-06 14:24:13.627232 +0000 [ docbroker_010 ] ERR  Failed to add session to [/nextcloud/index.php/apps/richdocuments/wopi/files/52_oc6ir6cb8wmj] with URI [https://intra.resohabitat.fr/nextcloud/index.php/apps/richdocuments/wopi/files/52_oc6ir6cb8wmj?access_token=Kxi9XJB2jyedErAWtnIcKK6ZHzBlq2pH&access_token_ttl=1680827051000&permission=edit]: Access denied. WOPI::CheckFileInfo failed on: https://intra.resohabitat.fr/yunohost/sso/?r=aHR0cHM6Ly9pbnRyYS5yZXNvaGFiaXRhdC5mci9uZXh0Y2xvdWQvaW5kZXgucGhwL2FwcHMvcmljaGRvY3VtZW50cy93b3BpL2ZpbGVzLzUyX29jNmlyNmNiOHdtaj9wZXJtaXNzaW9uPWVkaXQmYWNjZXNzX3Rva2VuPUt4aTlYSkIyanllZEVyQVd0bkljS0s2Wkh6QmxxMnBIJmFjY2Vzc190b2tlbl90dGw9MTY4MDgyNzA1MTAwMA==&access_token=Kxi9XJB2jyedErAWtnIcKK6ZHzBlq2pH| wsd/DocumentBroker.cpp:2418
Apr 06 14:24:13 coolwsd[653]: wsd-00653-164053 2023-04-06 14:24:13.627256 +0000 [ docbroker_010 ] ERR  Unauthorized Request while starting session on /nextcloud/index.php/apps/richdocuments/wopi/files/52_oc6ir6cb8wmj for socket #20. Terminating connection. Error: Access denied. WOPI::CheckFileInfo failed on: https://intra.resohabitat.fr/yunohost/sso/?r=aHR0cHM6Ly9pbnRyYS5yZXNvaGFiaXRhdC5mci9uZXh0Y2xvdWQvaW5kZXgucGhwL2FwcHMvcmljaGRvY3VtZW50cy93b3BpL2ZpbGVzLzUyX29jNmlyNmNiOHdtaj9wZXJtaXNzaW9uPWVkaXQmYWNjZXNzX3Rva2VuPUt4aTlYSkIyanllZEVyQVd0bkljS0s2Wkh6QmxxMnBIJmFjY2Vzc190b2tlbl90dGw9MTY4MDgyNzA1MTAwMA==&access_token=Kxi9XJB2jyedErAWtnIcKK6ZHzBlq2pH| wsd/COOLWSD.cpp:4933
Apr 06 14:24:13 coolwsd[653]: wsd-00653-164053 2023-04-06 14:24:13.631989 +0000 [ docbroker_010 ] ERR  #25: Read failed, have 0 buffered bytes (ECONNRESET: Connection reset by peer)| net/Socket.hpp:1150
Apr 06 14:24:13 coolwsd[653]: wsd-00653-164053 2023-04-06 14:24:13.632060 +0000 [ docbroker_010 ] WRN  #25: Unassociated Kit (164052) disconnected unexpectedly| wsd/COOLWSD.cpp:3426

In : LOGFILE: /var/log/nginx/collabora.resohabitat.fr-error.log

open() "/usr/share/nginx/html/healthcheck" failed (2: No such file or directory),

in : LOGFILE: /var/log/nginx/error.log

*440 SSL_do_handshake() failed (SSL: error:141CF06C:SSL routines:tls_parse_ctos_key_share:bad key share) while SSL hands

in : LOGFILE: /var/log/nginx/resohabitat.fr-error.log

46370#46370: *78 "/usr/share/nginx/html/yunohost/sso/index.html" is not found (2: No such file or directory),

Any idea? Thanks

hi @pierre-yves56 welcome to the forum :handshake:

take a look at this guides:

sounds like the request from Collabora is redirected to some Identity Provider - are you running some OAuth in front of your systems? do you force all connections to authorize first before connecting to Nextcloud application?

this logs from you NC are weird as well because of /cool prefix… this wrong somehow

2a01:cb08:8442:4b00:3109:5dbb:d9a6:560e - py [05/Apr/2023:18:30:47 +0000] "GET /cool/https%3A%2F%2Fintra.resohabitat.fr%2Fnextcloud%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F61_oc6ir6cb8wmj%3Faccess_token%3Dgtt1GVYghmww00iwVd8y7D5UzCz1nCNm%26access_token_ttl%3D1680755445000/ws?WOPISrc=https%3A%2F%2Fintra.resohabitat.fr%2Fnextcloud%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F61_oc6ir6cb8wmj&compat=/ws HTTP/1.1" 101 114 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/111.0"
2a01:cb08:8442:4b00:3109:5dbb:d9a6:560e - py [05/Apr/2023:18:30:48 +0000] "GET /cool/https%3A%2F%2Fintra.resohabitat.fr%2Fnextcloud%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F61_oc6ir6cb8wmj%3Faccess_token%3Dgtt1GVYghmww00iwVd8y7D5UzCz1nCNm%26access_token_ttl%3D1680755445000%26permission%3Dedit/ws?WOPISrc=https%3A%2F%2Fintra.resohabitat.fr%2Fnextcloud%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F61_oc6ir6cb8wmj&compat=/ws HTTP/1.1" 101 114 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/111.0"
2a01:cb08:8442:4b00:3109:5dbb:d9a6:560e - py [05/Apr/2023:18:30:48 +0000] "GET /cool/https%3A%2F%2Fintra.resohabitat.fr%2Fnextcloud%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F61_oc6ir6cb8wmj%3Faccess_token%3Dgtt1GVYghmww00iwVd8y7D5UzCz1nCNm%26access_token_ttl%3D1680755445000%26permission%3Dedit/ws?WOPISrc=https%3A%2F%2Fintra.resohabitat.fr%2Fnextcloud%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F61_oc6ir6cb8wmj&compat=/ws HTTP/1.1" 101 114 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/111.0"

Hi @pierre-yves56 , there seems to be a deeper problem with Nextcloud office / richdocuments in combination with a reverse proxy. I also had nothing in the logs that made any sense. I switched to onlyoffice .

Thank you for your answers @wwe and @davidwuest
It works by removing IP addresses from Allow list for WOPI requests, in Nextcloud office’s advanced settings. I had placed the IPV4 and IPV6 of the nextcloud server, to comply with the message:

You have not configured the allow-list for WOPI requests. Without this setting users may download restricted files via WOPI requests to the Nextcloud server.

and the following recommendation:

It is highly recommended to restrict WOPI requests to the IP addresses of the Collabora servers that are expected to request files from the Nextcloud installation. This can be done by setting the Allow list for WOPI requests option from the Office admin settings.

So it works, but not in a secure way as I understand it. If anyone can help me, I would be grateful.

I’m stuck, same issues, says connected, spinning wheel, nothing… fails.

I tried various things in the WOPI feild, didn’t help me, blank and/or actual IP made no difference. Benn messing with it a few days, is there a way to pay single incident support, I really could use this thing working.

System (domain/server name edited):

## Server configuration detail

**Operating system:** Linux 5.15.0-69-generic #76-Ubuntu SMP Fri Mar 17 17:19:29 UTC 2023 x86_64

**Webserver:** Apache/2.4.56 (Unix) (fpm-fcgi)

**Database:** pgsql PostgreSQL 15.2 on x86_64-pc-linux-musl, compiled by gcc (Alpine 12.2.1_git20220924-r4) 12.2.1 20220924, 64-bit

**PHP version:** 8.0.28

Modules loaded: Core, date, libxml, openssl, pcre, sqlite3, zlib, ctype, curl, dom, fileinfo, filter, ftp, hash, iconv, json, mbstring, SPL, PDO, pdo_sqlite, bz2, posix, readline, Reflection, session, SimpleXML, standard, tokenizer, xml, xmlreader, xmlwriter, mysqlnd, cgi-fcgi, apcu, bcmath, Phar, exif, gd, gmp, imagick, imap, intl, ldap, memcached, pcntl, pdo_pgsql, pgsql, redis, smbclient, sodium, sysvsem, zip, libsmbclient, Zend OPcache

**Nextcloud version:** 25.0.6 RC1 - 25.0.6.0

**Updated from an older Nextcloud/ownCloud or fresh install:** 

**Where did you install Nextcloud from:** unknown

<details><summary>Signing status</summary>

[]
</details>

<details><summary>List of activated apps</summary>

Enabled:

  • activity: 2.17.0
  • admin_audit: 1.15.0
  • announcementcenter: 6.5.1
  • calendar: 4.3.3
  • circles: 25.0.0
  • cloud_federation_api: 1.8.0
  • comments: 1.15.0
  • contacts: 5.2.0
  • contactsinteraction: 1.6.0
  • dashboard: 7.5.0
  • dav: 1.24.0
  • deck: 1.8.3
  • federatedfilesharing: 1.15.0
  • federation: 1.15.0
  • files: 1.20.1
  • files_accesscontrol: 1.15.1
  • files_antivirus: 5.0.0
  • files_automatedtagging: 1.15.3
  • files_fulltextsearch: 25.0.0
  • files_pdfviewer: 2.6.0
  • files_rightclick: 1.4.0
  • files_sharing: 1.17.0
  • files_trashbin: 1.15.0
  • files_versions: 1.18.0
  • firstrunwizard: 2.14.0
  • fulltextsearch: 25.0.0
  • fulltextsearch_elasticsearch: 25.0.0
  • groupfolders: 13.1.2
  • logreader: 2.10.0
  • lookup_server_connector: 1.13.0
  • mail: 2.2.5
  • nextcloud-aio: 0.3.0
  • nextcloud_announcements: 1.14.0
  • notifications: 2.13.1
  • notify_push: 0.6.2
  • oauth2: 1.13.0
  • password_policy: 1.15.0
  • photos: 2.0.1
  • privacy: 1.9.0
  • provisioning_api: 1.15.0
  • recommendations: 1.4.0
  • related_resources: 1.0.4
  • richdocuments: 7.1.3
  • richdocumentscode: 22.5.1301
  • serverinfo: 1.15.0
  • settings: 1.7.0
  • sharebymail: 1.15.0
  • socialsharing_facebook: 2.5.0
  • spreed: 15.0.5
  • support: 1.8.0
  • survey_client: 1.13.0
  • systemtags: 1.15.0
  • tasks: 0.14.5
  • text: 3.6.0
  • theming: 2.0.1
  • twofactor_backupcodes: 1.14.0
  • twofactor_totp: 7.0.0
  • updatenotification: 1.15.0
  • user_ldap: 1.15.0
  • user_status: 1.5.0
  • viewer: 1.9.0
  • weather_status: 1.5.0
  • workflowengine: 2.7.0
    Disabled:
  • bruteforcesettings
  • encryption
  • files_external
  • suspicious_login
</details>

<details><summary>Configuration (config/config.php)</summary>

{
“memcache.local”: “\OC\Memcache\APCu”,
“apps_paths”: [
{
“path”: “/var/www/html/apps”,
“url”: “/apps”,
“writable”: false
},
{
“path”: “/var/www/html/custom_apps”,
“url”: “/custom_apps”,
“writable”: true
}
],
“memcache.distributed”: “\OC\Memcache\Redis”,
“memcache.locking”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “REMOVED SENSITIVE VALUE”,
“password”: “REMOVED SENSITIVE VALUE”,
“port”: 6379
},
“overwritehost”: “server.domain.net”,
“overwriteprotocol”: “https”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“localhost”,
server.domain.net
],
“datadirectory”: “REMOVED SENSITIVE VALUE”,
“dbtype”: “pgsql”,
“version”: “25.0.6.0”,
“overwrite.cli.url”: “https://server.domain.net/”,
“dbname”: “REMOVED SENSITIVE VALUE”,
“dbhost”: “REMOVED SENSITIVE VALUE”,
“dbport”: “”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“installed”: true,
“instanceid”: “REMOVED SENSITIVE VALUE”,
“check_data_directory_permissions”: false,
“maintenance”: false,
“updater.release.channel”: “stable”,
“updatedirectory”: “/nc-updater”,
“loglevel”: “2”,
“app_install_overwrite”: [
“nextcloud-aio”,
“socialsharing_facebook”
],
“log_type”: “file”,
“logfile”: “/var/www/html/data/nextcloud.log”,
“log_rotate_size”: “10485760”,
“log.condition”: {
“apps”: [
“admin_audit”
]
},
“preview_max_x”: “2048”,
“preview_max_y”: “2048”,
“jpeg_quality”: “60”,
“enabledPreviewProviders”: {
“1”: “OC\Preview\Image”,
“2”: “OC\Preview\MarkDown”,
“3”: “OC\Preview\MP3”,
“4”: “OC\Preview\TXT”,
“5”: “OC\Preview\OpenDocument”,
“6”: “OC\Preview\Movie”,
“0”: “OC\Preview\Imaginary”
},
“enable_previews”: true,
“upgrade.disable-web”: true,
“mail_smtpmode”: “smtp”,
“trashbin_retention_obligation”: “auto, 30”,
“versions_retention_obligation”: “auto, 30”,
“activity_expire_days”: “30”,
“simpleSignUpLink.shown”: false,
“share_folder”: “/Shared”,
“tempdirectory”: “/mnt/ncdata/tmp/”,
“one-click-instance”: true,
“one-click-instance.user-limit”: 100,
“one-click-instance.link”: “https://nextcloud.com/all-in-one/”,
“htaccess.RewriteBase”: “/”,
“files_external_allow_create_new_local”: true,
“trusted_proxies”: “REMOVED SENSITIVE VALUE”,
“allow_local_remote_servers”: true,
“preview_imaginary_url”: “http://nextcloud-aio-imaginary:9000”,
“ldapProviderFactory”: “OCA\User_LDAP\LDAPProviderFactory”
}

</details>

**Cron Configuration:** Array
(
    [backgroundjobs_mode] => cron
    [lastcron] => 1681783312
)


**External storages:** files_external is disabled

**Encryption:** no

**User-backends:** 
 * OC\User\Database


**Talk configuration:** 

STUN servers
 * server.domain.net:3478

TURN servers
 * turn:server.domain.net:3478 - udp,tcp

Signaling servers (mode: default):
 * https://server.domain.net/standalone-signaling/ - somelongstringhere


**Browser:** Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/111.0

I would recommend working through the guide mentioned above Nextcloud Collabora integration this will give you good idea what is wrong with the installation

I don’t think so… but try contacts Nextcloud sales through their website… this forum is run by volunteers…

A post was split to a new topic: Android fails to load Nextcloud Office documents