External Storages - FreeNAS 11.1-U6 disabled SMB1 - Can no longer mount SMB share via the External Storages plugin

@tflidd @enoch85

Thanks for the response. I did select the extra security options when setting up the VM. Do you know what I need to do to turn off ModSecurity on the Tech and Me VM?

Here’s the modesecurity script: https://github.com/nextcloud/vm/blob/master/static/modsecurity.sh If that was the one, then undo everything in that.

Hi oRAirwolf,

I was also impacted by this error on Ubuntu 16.04 with Nextcloud 13.0.5. To fix the problem while keeping FreeNAS 11.1-U6 SMB1 disabled, I updated, installed smbclient and modified smb.conf like this:

  1. sudo apt update

  2. sudo apt install smbclient

  3. add in global section smb.conf (/etc/samba/smb.conf):

    client min protocol = SMB2
    client max protocol = SMB3

  4. reboot

NOTE: The fix doesn’t work on Ubuntu 18.04

1 Like

Thank you for the response. I am running the Tech and Me Ubuntu 18.04 VM. That is good to know that it fixed it for Ubuntu 16.04, though.

@enoch85 I deployed a new instance of Nextcloud with the latest Tech and Me OVA and did not enable any of the security features or extras. It is still not able to mount an SMB share from FreeNAS.

This same problem of upgrading FreeNAS to 11.1-U6 affected my Nextcloud’s External Storages app, too.

I cannot use the workaround of installing smbclient as described by Raegedoc above, because of the SMB downloading of large files issue described in this github issue. It seems that the PHP implementation of SMB is preferred by Nextcloud.

I think I’ll downgrade the security of SMB on my FreeNAS server because the PHP implementation of SMB in Nextcloud is not keeping up.

@ShaunCurrier Please let me know if you are able to get it working with FreeNAS. I tried downgrading my SMB to allow SMB1 and I am still having the same problem.

@oRAirwolf I followed your steps by adding the Tunable to FreeNAS, and after stop/start of SMB service I am now able to access my CIFS shares.

Are you using the Tech and Me appliance? I tried with mine and I am still getting diddly.

SMB access has been partially broken for over a year- the last version that completely works is 10. @enoch85 has worked extensively with us on it and verified that it’s a bug.

Not stating that this is the cause of your issue, just that there are certainly some SMB issues with versions 11 and 12.

1 Like

For you to know, I had to revert to SMB1 since my HP printer scan2folder “feature” stopped working because of SMB2.

I am not in the mood of buying a new printer for now :frowning:

Yup, SMB has been somewhat broken since 11.0.3, I don’t know if it’s fixed yet, but apparently not since this is still and issue.

SMB all over Linux distros have been broken. I had an issue on CentOS and Fedora with Thecus NAS where system would hang with mass rename operations. Nothing pertaining to NC. Reverting and forcing SMB v1 protocol fixed it. So I don’t think this is specifically NC’s fault, the thing is broken everywhere.

Hey Daniel,

Been trying to get hold of you - what is the best way as I need some help?

Hi Alan, the best way is always to send me an email.

I tried this on my Ubuntu 16.04 and it did not work

Hi oRAirwolf,

Today I got the newly released 18.04/Nextcloud 14.0 1TB from Tech and Me and retried without changing anything to the default configuration and it worked!

I didn’t have to install smbclient like I previously did in my 16.04/NC13 version. Instead, I played around and changed the way I specified the external storage in NC14 following some reading I did over the www for that problem.

External storage = SMB / CIFS
Authentification = Log-in credentials, save in session
Host = FreeNAS’ IP (x.x.x.x)
Share = FreeNAS’ SMB share
Remote subfolder = /

Filling in domain as WORKGROUP made it all working :slight_smile:

NOTE: My printer still won’t scan to folder but this is another problem I will solve for now by using the scan to email feature

o_O My god that worked!

Thank you sooooooooo much!

No joy here with NC 14.0.3 adding SMB external storage from Windows servers. Tried the same settings that worked with 11.x as well as everything else I could think of. I was hoping the long-standing WebDav bug would finally be fixed, only to find out that I can’t even check that because SMB is now broken.

A post was split to a new topic: Cannot mount external smb storage from FreeNAS