External Storages - FreeNAS 11.1-U6 disabled SMB1 - Can no longer mount SMB share via the External Storages plugin

Yup, SMB has been somewhat broken since 11.0.3, I don’t know if it’s fixed yet, but apparently not since this is still and issue.

SMB all over Linux distros have been broken. I had an issue on CentOS and Fedora with Thecus NAS where system would hang with mass rename operations. Nothing pertaining to NC. Reverting and forcing SMB v1 protocol fixed it. So I don’t think this is specifically NC’s fault, the thing is broken everywhere.

Hey Daniel,

Been trying to get hold of you - what is the best way as I need some help?

Hi Alan, the best way is always to send me an email.

I tried this on my Ubuntu 16.04 and it did not work

Hi oRAirwolf,

Today I got the newly released 18.04/Nextcloud 14.0 1TB from Tech and Me and retried without changing anything to the default configuration and it worked!

I didn’t have to install smbclient like I previously did in my 16.04/NC13 version. Instead, I played around and changed the way I specified the external storage in NC14 following some reading I did over the www for that problem.

External storage = SMB / CIFS
Authentification = Log-in credentials, save in session
Host = FreeNAS’ IP (x.x.x.x)
Share = FreeNAS’ SMB share
Remote subfolder = /

Filling in domain as WORKGROUP made it all working :slight_smile:

NOTE: My printer still won’t scan to folder but this is another problem I will solve for now by using the scan to email feature

o_O My god that worked!

Thank you sooooooooo much!

No joy here with NC 14.0.3 adding SMB external storage from Windows servers. Tried the same settings that worked with 11.x as well as everything else I could think of. I was hoping the long-standing WebDav bug would finally be fixed, only to find out that I can’t even check that because SMB is now broken.

A post was split to a new topic: Cannot mount external smb storage from FreeNAS