Email Server STMP funktioniert nicht

Hallo ich versuche gerade Nextcloud auf meiner QNAP einzurichten. Bin also noch recht neu mit Nextcloud.
Dabei habe ich Probleme mit der Email Server Konfiguration unter STMP. Ich wei├č, dass ich die Anmeldeinformationen alle korrekt eingeben habe, aber ich bekomme bei der Test Mail einen Fehler:
"Beim Senden der E-Mail ist ein Problem aufgetreten. Bitte ├╝berpr├╝fe Deine Einstellungen. (Fehler: Unable to connect with TLS encryption)"
Im Logfile steht folgendes:
stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed at /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php#95
Leider kann ich mit der Meldung nicht viel anfangen. Hat jemand eine Idee warum SMTP nicht funktioniert unter PHP funktioniert die Test Mail
Danke schon mal f├╝r eure Hilfe

Die Meldung besagt, dass die Verbindung zu deinem Postfach nicht mit TLS-Verschl├╝sselung hergestellt werden konnte.

Bitte ├╝berpr├╝fe, ob dein Mail-Anbieter diese Funktion unterst├╝tzt und ggf wie diese konfiguriert werden m├╝ssen.

Hallo, danke f├╝r deine Nachricht, ich bin mir sehr sicher, dass der Mail Anbieter das anbietet (t-online), da ich mit den exakt gleichen Einstellungen problemlos von der QNAP Mails bekomme.Nur bei NextCloud scheint das nicht zu funktionieren??

Ok. Dann bin ich ├╝berfragt.

Welcher port wird hier verwendet?
Ich habe schon oft erlebt das es am port liegt, also bestenfalls einfach alle ports durchprobieren. (25, 465, 587)

Hallo, die Ports sind es nicht habe schon alle probiert, aber mit ist in den Logfiles etwas aufgefallen, evtl. sagt das ja jemanden etwas

stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed at /share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php#95

Ich habe auch Probleme sowohl mit Mail als auch mit Rainloop.

Rainloop akzeptiert nach einer Abmeldung meine Logindaten in die Wbegui nicht mehr. Wo ich da meine Emailadresse eingeben kann, wei├č ich bis heute nicht.

Wie kann man die Einstellung von Mail ├Ąndern? Emails empfangen geht zwar, aber senden nicht ÔÇťfailedÔÇŁ, obwohl die Daten richtig sind. Habe mal Testweise nochmal hinzugef├╝gt und nun habe ich eine doppelt vorkommende, nicht sendende EmailapplikationÔÇŽwie kann ich ein Konto wieder l├Âschen??

@chma73, welches zertifikat hast du denn? ein selbst-gesigntes? oder ein offizielles?

@Nobody
vielleicht solltest du deine anfrage besser hier stellen --> https://help.nextcloud.com/c/apps/rainloop (auch wenns englisch ist)

und schau doch gleich mal, ob dir diese antwort von dort auch weiterhilftÔÇŽ [SOLVED] Reset admin password in Rainloop

Hallo, ist ein selbst gesigntes,

daran kann das durchaus liegen. mancher code macht probleme mit selbstsignierten zertifikaten.

Ich habe das selbe Problem. Vorher konnte man wenigstens dann noch auf PHP ausweichen, mit Nextcloud 14 ist dies ja nicht mehr m├Âglich.

Server:
Nextcloud version 14.0.1.1
Betriebssystem Ubuntu 18.04
Apache or nginx version nginx/1.13.8
PHP version 7.2.10
Letsencrypt Zertifikat

beim versenden, der Test-Mail, bekomme ich folgende meldung:

Beim Senden der E-Mail ist ein Problem aufgetreten. Bitte ├╝berpr├╝fe Deine Einstellungen. (Fehler: Verbindung mit TLS-Verschl├╝sselung nicht m├Âglich Logdaten: ++ Start Swift_SmtpTransport << 220 serv15.avernis.de ESMTP >> EHLO *********.de << 250-serv15.avernis.de 250-PIPELINING 250-SIZE 54525952 250-ETRN 250-STARTTLS 250-ENHANCEDSTATUSCODES 250 8BITMIME >> STARTTLS << 220 2.0.0 Startbereit f├╝r TLS !! Verbindung mit TLS-Verschl├╝sselung nicht m├Âglich (Code: 0))

LOG:

stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed at /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php#94

The output of your Apache/nginx/system log in /var/log/nginx/nextcloud.access.log:

[26/Sep/2018:16:33:16 +0200] "POST /settings/admin/mailtest HTTP/2.0" 400 560 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/17.17134" "-" "domain.de" sn="domain.de" rt=0.219 ua="unix:/run/php/php7.2-fpm.sock" us="400" ut="0.219" ul="581" cs=-

Ich habe das gleiche Problem und auch mit meinen Telekom-Email-Account. Der einzige von f├╝nfen, der nicht ├╝ber die NC (13.0.1) Mail-App abzufragen geht.

In Outlook oder Outlook-Android ist das T-Online-Konto problemlos abzurufen, nur ├╝ber NC 13 nicht. Ich habe alle Einstellungen mehrfach durch.
Vielleicht unterst├╝tzt die Telekom das einfach auf dieser Basis nicht.

In NC 14 funktioniert jetzt dann kein Konto mehr. Weder ├╝ber das Autosdicover der Einstellungen noch ├╝ber die konkreten Werte. Hier liegt der Fehler dann wohl in der Mail-App von NC.

Bei mir das Selbe. Geht ├╝berall, ausser bei NC. SSL:465 kontrolliert. Ohne Erfolg.

Bitte nicht immer uralte Threads wieder er├Âffnen. Mach einen neuen auf und gibt dazu soviel wie m├Âglich Infos. Verlinke dabei gerne auf diesen oder andere gefundene Threads