Earn a t-shirt by testing Nextcloud 12 Beta 2!

Errors after manual update on Ubuntu 17.04, PostgreSQL, PHP 7:
1.

Error
file_get_contents(/var/www/nextcloud/apps/user_saml/appinfo/signature.json): failed to open stream: No such file or directory at /var/www/nextcloud/lib/private/IntegrityCheck/Helpers/FileAccessHelper.php#39

Technical information
The following list covers which files have failed the integrity check. Please read the previous linked documentation to learn more about the errors and how to fix them.

Results

  • user_saml
    • EXCEPTION
      • OC\IntegrityCheck\Exceptions\InvalidSignatureException
      • Signature data not found.

PHP Opcache is not set up correctly.
However, my /etc/php/7.0/fpm/php.ini has the following (recommended) settings:

opcache.enable=On
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

On Firefox 53.0.2 (64 bit), the log in button on the web interface is non-functional. Works on Chrome however…

BTW on https://docs.nextcloud.com/server/12/admin_manual/configuration_server/server_tuning.html#enable-php-opcache you recommend the setting

opcache.enable=On

http://php.net/manual/en/opcache.configuration.php lists

opcache.enable=1

Known issue and fixed for release: https://github.com/nextcloud/server/pull/4651

Until then just ignore it and install the app manually from store, if you need it. Enables you to add IPs to a whitelist for the internal bruteforce protection, not more and not less.

http://php.net/manual/en/opcache.configuration.php1

opcache.enable=1

So are the Nextcloud instructions wrong? Which one is it? On or 1?

Dont appear a button for closing the video player

Some overall observations:

  1. upgrade from 11.03 to 12.0b2 went OK for dutch localization without issues.
  2. I’m missing now a bit the e-mail template editor? Is it gone or will it come back?
    As we had issues in NC11 to get it updated for Dutch language I now see no way at all to customize e-mail templates
  3. clamav anti_virus; is that gone or is it coming back?
  4. federation was by default enabled; earlier it was disabled; I would think its better to leave it disabled when doing an upgrade
  5. I deleted (I believe) an old calendar some time ago but suddenly that calender showed up again after the upgrade?
  6. some admin related app had in the app list the visibility by default open to all ; should it not be more restricted by default for some apps to have it only listed as admins?
  7. after logging on at personal data Im missing now the field for a users twitter/website/adress & phone info; is this a bug or worked on already?

keep up the good work!

the setting:

opcache.enable=1

is correct. more information can be found here: Nextcloud and PHP

1 Like

Yeah, I was told to create a Server issue - so I did: https://github.com/nextcloud/server/issues/4838 :wink:

i found a bug in the default encryption module…

until v11 the encryption module worked perfectly for uploading files as a guest withour account to a shared folder via Link. but since v11 the default encryption module is broken. it is not possible to upload files as a guest because all files are corrupt.

@bjoern is the issue above known or should it be reported as new?

1 Like

Updated latest 11 to 12.0.0 b2 today. Now, b3 is showing up. But upgrade is not working, because of a js error. The Button “Start Update” is not working.

[Error] Failed to load resource: the server responded with a status of 404 (HTTP/2.0 404) (purify.min.js.map, line 0)

The file is missing. Not sure if it is a known issue? I could upload it manually, but wanted to ensure it is not a global issue…

The updater in Beta 2 sadly doesn’t start when pressing “Start update”. This has been fixed in the beta 3.

To start the update you can either:

  1. Use the CLI updater by executing “php updater/updater.phar”
  2. Open /updater/ directly (e.g. cloud.foo.com/updater/)
  3. Apply the patch from https://github.com/nextcloud/server/pull/4762/files (https://patch-diff.githubusercontent.com/raw/nextcloud/server/pull/4762.patch)
  4. Perform the updater manually from the ZIP file from https://download.nextcloud.com/server/prereleases/?C=M;O=D

whats about that issue?

@bjoern any idea?

Thank you for this update and your work!

A few things:

  1. The login button on Firefox 53.0.2 is still not functioning after this update.

  2. Update fails initially, because the folder “assets” is present.

  3. After the update, code integrity check fails:

Technical information
The following list covers which files have failed the integrity check. Please read the previous linked documentation to learn more about the errors and how to fix them.

Results

  • user_saml
    • EXCEPTION
      • OC\IntegrityCheck\Exceptions\InvalidSignatureException
      • Signature data not found.

Raw output
Array
(
[user_saml] => Array
(
[EXCEPTION] => Array
(
[class] => OC\IntegrityCheck\Exceptions\InvalidSignatureException
[message] => Signature data not found.
)
)
)

I have just updated my Nexcloud 11.0.3 to 12 beta 3.

I am using Debian Jessie with nginx 1.6.2 from debian jessie and php-fpm 7.1 from sury.org

All went quite well exept that in the admin section this is now shown:
The "X-Frame-Options" HTTP header is not configured to equal to "SAMEORIGIN". This is a potential security or privacy risk and we recommend adjusting this setting.

Even though my nginx site-configuration has the option set according to the manual (as here https://docs.nextcloud.com/server/12/admin_manual/installation/nginx.html ).

add_header X-Frame-Options "SAMEORIGIN";

Thanks. I can reproduce this issue and https://github.com/nextcloud/server/pull/4926 should fix this problem.

While the update succeeded, LDAP authentication times are taking a long time. Password reset on LDAP prevents android app from loading due to logon timeout. The desktop client application will also disconnect and state that operation failed and wont re-initialize until remove account and re-add.

12 Beta 3
CentOS7
PHP7
MariaDB

NGINX proxy

upgrade to 12 beta 3 worked smoothly … all previous apps got automatically enabled…

what seems a bit strange is the following:

  1. prior to upgrade I enabled singleuser mode by occ command
  2. after upgrade singleuser mopde was aparently disbled by the process itself
  3. config.php still shows singeleusermode beeing enabled …

just realized… from admin manual 12

there is no singleuser mode anymore ?? I used it mainly for making backups of my database prior to an upgrade… to ensure no users can change /asćcess data while backingup and upgrading …

aaaand some more ERRORS :wink:

finding lots of the following ERRORS:

Error no app in context Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route “theming.Theming.getLogo” as such route does not exist.

/www/htdocs/w005850c/wwwcloud/CLOUD/lib/private/Route/Router.php - line 339: Symfony\Component\Routing\Generator\UrlGenerator->generate('theming.Theming...', Array, 1)
/www/htdocs/w005850c/wwwcloud/CLOUD/lib/private/URLGenerator.php - line 70: OC\Route\Router->generate('theming.Theming...', Array)
/www/htdocs/w005850c/wwwcloud/CLOUD/apps/theming/lib/ThemingDefaults.php - line 156: OC\URLGenerator->linkToRoute('theming.Theming...')
/www/htdocs/w005850c/wwwcloud/CLOUD/lib/public/Defaults.php - line 186: OCA\Theming\ThemingDefaults->getLogo(true)
/www/htdocs/w005850c/wwwcloud/CLOUD/core/templates/layout.guest.php - line 45: OCP\Defaults->getLogo()
/www/htdocs/w005850c/wwwcloud/CLOUD/lib/private/Template/Base.php - line 176: include('/www/htdocs/w00...')
/www/htdocs/w005850c/wwwcloud/CLOUD/lib/private/Template/Base.php - line 151: OC\Template\Base->load('/www/htdocs/w00...', NULL)
/www/htdocs/w005850c/wwwcloud/CLOUD/lib/private/legacy/template.php - line 202: OC\Template\Base->fetchPage(NULL)
/www/htdocs/w005850c/wwwcloud/CLOUD/lib/private/legacy/template.php - line 224: OC_Template->fetchPage()
/www/htdocs/w005850c/wwwcloud/CLOUD/lib/private/Template/Base.php - line 132: OC_Template->fetchPage()
/www/htdocs/w005850c/wwwcloud/CLOUD/core/templates/404.php - line 10: OC\Template\Base->printPage()
{main}

seems to be connected to THEMING ?? my personal theme (logo background picture and colours) do show correct though,

Use the maintenance mode for such cases.