Earn a t-shirt by testing Nextcloud 12 Beta 2!


#1

I just blogged about our 2nd beta which is now available! We’re still squashing bugs but it is time to really give this release a work-out so we’re asking everyone to pitch in and test an upgrade. Most of us have upgraded our private instance (I just did, no problems here) and it is becoming harder to find bugs so - please, help out!

If you find a update/upgrade bug and report it and it’s unique, there is a t-shirt in it for you :wink:

Learn more in our blog!

Oh and on my server, all apps were upgraded and not disabled except some that weren’t yet compatible:


I updated the Collabora Online app but it isn’t compatible (yet), neither are the other apps. Coming soon, hopefully!

And… Love the very detailed tips on mis-configuration:


and yeah, things were dog slow so clearly, this has to be updated :smiley:


Security in Nextcloud 12: new authentication mechanisms
#2

@jospoortvliet if you cant live another day without Audio Player on your test instance, feel free to get the beta from GIT :slight_smile:

We had quite some repairs due to the deprecated IDB class - but will be ready on time for the final 12!


#3

beta alpha :stuck_out_tongue:


#4

I do not need a t-shirt but a working updater. :wink:
Start update in beta.1 does nothing. Do I have to update manually?


#5

So you go to the updater from beta 1, click start update, nothing happens? Yeah, that just sounds like a issue worth reporting :smiley:

Anything in the logs?

Might even result in a t-shirt!


#6

Yes! Nothing.

No, nothing. Not in nextcloud.log, not in error_log, not in console.


#7

I have the same issue. No errors in any logs. Tested in Firefox (Linux 53.0.2) and Chrome (Linux 58.0.3029.96) with Adblocker disabled/removed.

Edit: Github Issue https://github.com/nextcloud/updater/issues/108

Running:
Debian 8
Server version: Apache/2.4.10 (Debian)
PHP 5.6.30-0+deb8u1 (cli) (built: Feb 8 2017 08:50:21)
Nextcloud 12 beta 01

THS


#8

Thanks @LukasReschke :smiley:

EDIT: Manual update from beta.1 to beta.2 via /updater/index.php works!


#9

So if I am correct, that issue will be again with beta 2 to 3, correct?
Can anyone of you close the video player after playing the testfile?


#10

No see here: https://github.com/nextcloud/files_videoplayer/issues/25


#11

i ran the update from 11.0.3 to 12.b1 to 12b2 successfully in the cli.
I went back to the browser and had to perform an update (as shown above) in my web-gui.
Why do i have to use the browser as well?
Is this by design?



Great job guys, thank you NEXTCLOUDERS!


#12

Well, I currently run Beta 12.0beta 1 and trying to click update in backend -get screen

Initializing
Current version is 12.0 beta 1.
Update to Nextcloud 12.0.0 Beta 2 available. (channel: “beta”)
Following file will be downloaded automatically: https://download.nextcloud.com/server/prereleases/nextcloud-12.0.0beta2.zip

It does not. There is a button to click “start update” but it does nothing. Not really a bug report as I cannot provide techy details as I am not one.


#13

Try the command line version.

sudo -u www-data php /var/www/nextcloud/update/updater.phar

#14

Bug is tracked on GitHub (see above). Use the direct update URL instead.


#15

I had that opcache recommendation like you can see it in the OP. I changed all the php.ini files I could possibly find, it still says it is not properly configured. Ideas?

Using nginx + php7.0


#17

Do I get a shirt now? :slight_smile:


#18

Thanks for the hint!

Sadly this way is more time consuming because you will be asked for the unhashed updater-secret.
If you don’t have this value e.g. it was created automaticly then you have to go to the CLI.

Therefore the easiest way to update from b1 to b2 seems to be using the CLI with:
sudo -u www-data php /var/www/nextcloud/updater/updater.phar

as @travisph posted.
This sadly returns the output as follows:

Nextcloud Updater - version: v11.0.3-19-g3e2d9de

Current version is 12.0 beta 1.

No update available.

Nothing to do.

#19

In Google Chrome dont appear the option to permit the webcam and microphone for videocallings

But in firefox is working correctly

I am using a MacBook Pro with MacOS Sierra 10.12.4 and Google Chrome Versión 57.0.2987.133 (64-bit)


#20

Actually it is “…nextcloud/updateR…” :wink: :
sudo -u www-data php /var/www/nextcloud/updater/updater.phar

Got the same issue, worked well with command! Would love to have a t-shirt, but I guess it’s not possible to get one for everybody reporting this same issue here :smile:.


#21

This is caused because Chrome allows WebRTC only via HTTPS. See also https://developers.google.com/web/updates/2015/10/chrome-47-webrtc

Great to hear the workaround is working for you folks. And thanks a lot for testing. Much appreciated! :rocket:

We have a patch for this specific issue ready at https://github.com/nextcloud/server/pull/4762 and will release a beta 3 soon also containing this patch. From then on updates should work also again directly by clicking the button.

This bug was basically caused by a security hardening that we recently introduced: https://statuscode.ch/2017/03/CSP-unsafe-eval-and-jquery/. Basically, when you click the “Open updater” button we instructed jQuery to load the HTML from /updater/index.php and inject that into the current view. With the security hardening applied the JavaScript wasn’t executed but the HTML was loaded.

Thus this also works by opening /updater/index.php manually because there we don’t use jQuery for injecting the JavaScript.