Download timeout getting CODE server from the app store NC 19

This is the error I get from Nextcloud 19.0.0:

cURL error 28: Operation timed out after 120000 milliseconds with 78927427 out of 345102997 bytes received (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

How do I fix it? Thanks!

Do you have access to OCC or OCC Web?
Then you can perhaps install the app with occ:

app:install install selected app

https://docs.nextcloud.com/server/19/admin_manual/configuration_server/occ_command.html

Perhaps test it first with a small app to exclude app specific errors.

Thank you @devnull. That was just what I needed. :smile:

This happens to me too because my internet is so slow. 450Kb/s. if you can change the timeout, in a file called Fetcher.php (capital F), from 10 to I don’t know, 30 or 60 it will work. So it is already running at 60 so it was 300 that I changed it too. Unless your running a snap, cant change it even as root.

Not sure if I should create new topic or I can bump it here.

I tried using OCC-web, I still get the curl error 28.

Error message is the same as jkoop.

I tried SSH, I used hanssonit VM so I SSH to 192.168.1.10 to the nextcloud VM

What I got from putty is root@nextcloud.

I have limited understanding for linux in general but I recall I cannot use this code

sudo -u wwwrun php -d memory_limit=512M ./occ app:install richdocumentscode

because I’m already root.

I tried
su - wwwrun php -d memory_limit=512M ./occ app:install richdocumentscode
error for this one

php -d memory_limit=512M ./occ app:install richdocumentscode
cannot find file occ

I wonder what else should I try.

Any help would be appreciated.