Desktop client cannot sign in after beeing logged out

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version: 24.0.1
Operating system and version: KDE Neon (based on Ubuntu 20.04)
Desktop client version: 3.5.1 (KDE)

I got logged out of one NC instance cause I made changes to my LDAP user. Everything is back on and I can logging fine with the user using the web ui.

My desktop client however does not sign in again. Opening the client Settings and selecting that account, all sync folders all greyed out (grey cloud) and it says on top: Singed out from https://server.name as “my username” .
When I click on https://server.name in the setting page it opens the web ui in a browser just fine with all my files but does not display the “grant access” page as it does when you first install the client. Unfortunately I cannot see anyway to sign in again.

Restarting the client does not help. Backup up and deleting the config directory, then restarting the app and login into the account with the set-up wizard works but when putting back the old config directory it is still signed out.

The other odd thing is that ever since that happened I cannot open the client main dialog, only opening the settings works.
Using Desktop Client Version 3.5.1 (KDE)

Anyone got any idea on how to sign in again on the desktop client if the account has been singed out?

I wonder if there is any section in the nextcloud client config file that could be amended to trigger the client to sign in again but I couldn’t quite see where. Would anyone know?

I feel a bit stuck with this situation, anyone able to help?
Do you need any more info?
It seems strange to be stuck in a “signed out state” with the client with no way to to make it login again.

Can you check the logfiles? So if I understood correctly, you used dedicated app-passwords for your client?

Thank you for your reply.

I’m not entirely sure what you mean with dedicated app-password. When I first installed the the client, I connected to my account using the set-up wizard (when it automatically open the web ui to grant access).

Then what happened is that my user got signed out (of both client and web ui) because LDAP config / password changed. I restored LDAP config and I can login fine with the web ui but the the user is still signed out in the desktop client and I cannot see any way to sign in again.

When I remove the config file and restart the client I can sign in again using the set-up wizard but when I restore the old config file the user is still signed out. (I’d rather keep my original config file as I have several NC accounts with specific folder config for each and so I don’t really want to have to reconfigure and resync everything).

I checked the log files but couldn’t see much about it… Happy to share additional info if a more knowledgeable eye can spot something I missed.

As mentioned above, what’s also odd is that since that user is signed out I cannot “Open main dialog” (nothing happens), I can only open “Settings”.

Seems like some ran into a similar issue but no proposed solutions work: Cannot log in after password change

Updated to 3.5.2 and still the same issue. Also since I cannot access the main dialog, I also cannot remove (and readd) the broken account. Anyone got any idea?

Just bumping this, anyone got any suggestions?

Many thanks

Problem solved using the flatpak version! The issue really was that I could not get the main dialog to pop up. For some reason there is an issue with the repo version and main dialog works fine with the flatpak version. From there I could select the broken and login again.

I wonder if there is something broken regarding opening the main dialog, I’ll open a different topic.