Delete old files core/shipped.json is not available

The Update from NC 16.0.4 to NC 16.0.5 fails with

  • Delete old files

core/shipped.json is not available

What am I doing wrong? Or what I have to do to avoid that failure?

Download the Nextcloud 16.0.4 archive, extract the shipped.json file and copy it to the core folder in the Nextcloud web root directory.

1 Like

Is this the core folder in the Nextcloud web root directory?

pi@raspberrypi:/var/www/html $ ls -al
insgesamt 44
drwxr-xr-x  7 www-data www-data 4096 Okt  1 19:33 .
drwxr-xr-x  3 root     root     4096 Mai 12 23:28 ..
drwxr-xr-x 11 www-data www-data 4096 Okt  1 19:31 apps
drwxr-xr-x  2 www-data www-data 4096 Okt  1 19:31 config
drwxrwx---  7 www-data www-data 4096 Jul 25 21:00 data
-rw-r--r--  1 www-data www-data   57 Okt  1 19:31 index.php
-rw-r--r--  1 www-data www-data   57 Okt  1 19:31 public.php
-rw-r--r--  1 www-data www-data   57 Okt  1 19:31 remote.php
-rw-r--r--  1 www-data www-data   57 Okt  1 19:31 status.php
drwxr-xr-x  2 www-data www-data 4096 Okt  1 19:31 themes
drwxr-xr-x  2 www-data www-data 4096 Aug 20 22:30 updater

Yes, that seems to be the directory, although there are already several folders missing from my point of view, because usually it contains the following sub directories:

3rdparty
apps
core
lib
ocm-provider
ocs
ocs-provider
resources
settings
themes
updater

Have you already tried to kick-off the update/install process again?

Yes. Without success.

I don’t know if it is possible to run the web update again if half of the files have already been delete, because I’m personally not using that function.

Afaik, the updater creates a backup which you could try to restore on the console, but I would recommend to directly extract the files from the archive and upgrade the system on the console.

Maybe someone else knows a better way to get the upgrade done?!

Could you please explain in detail, how it works?

I’m personally not using a RaspberryPi so that the command can slightly be different. Eventually it would be good to ask as RaspberryPi specialist for some advice. I would try upgrading the system as follows:

  1. Stop the running web server, e.g.
    /etc/init.d/apache2 stop
    
  2. Backup the existing files
    cd /var/www
    tar cvzf nc-old.tgz html
    rm -rf html
    
  3. Download the archive file
    wget https://download.nextcloud.com/server/releases/nextcloud-16.0.5.tar.bz2
    
  4. Extract the archive, rename the directory and set the file ownership
    tar xvjf /var/www/nextcloud-16.0.5.tar.bz2 -C /var/www
    mv /var/www/nextcloud /var/www/html
    chown -R www-data:www-data /var/www/html
    
  5. force the Nextcloud upgrade
    sudo su - www-data
    cd /var/www/html
    php ./occ upgrade
    
  6. Start the web server again, e.g.
    /etc/init.d/apache2 start
    

Thank you. I’ll try it tonight. One additional question: Does it make a fundamental difference that my installation not runs apache but nginx?

It could make things a little bit more complicated, but it should work the similar.

Unfortunately, the backup was stopping after appr. eight hours. What can I do now in order either to make it continuing or to abort it without data loss?

At first you should already have a reliable data backup solution in place to make sure that you aren’t loosing any data in case of a problem, e.g. with your hard disk. Second, it might be possible that

a) there isn’t enough space left on your hard disk. If so, then make sure that you use a different location where you’re going to create/store the archive file.

b) your data files are included in this archiving command, because there is usually a data directory inside that folders. You can try to exclude this data from archiving by modifying the command like e.g. tar cvzf nc-old.tgz --exclude html/data html.

Sorry, as I wrote at the beginning, I’m not an expert on Nextcloud@RaspberryPi and therefore cannot provide you an absolutely matching solution.

How can I stop tar now? Then I want to delete nc-old. And I hope the content of html is intact. Because there are a few files, of which I don’t have a backup at the moment.

Press CTRL-C to interrupt a running tar command and delete the created, incomplete archive file afterwards.

root@raspberrypi:/var/www/# sudo su - www-data
This account is currently not available.

How can I make this account available?

To be honest, I don’t know how this is handled on a RaspberryPi.

Download the Nextcloud 16.0.4 archive , extract the shipped.json file and copy it to the core folder in the Nextcloud web root directory.

This works also at update to 18.0.14… on my way to 19.0.8 … :see_no_evil:
but…
i had to create “/core”
hangs shortly… because i hadn’t set the rights…
“sudo chmod a+rwx ./core” …works for the short way… now i have to look for the right user and rights… on vserver from strato… :face_vomiting:

I got the same error on an upgrade from 21.0.3 tot 21.0.4. I copied recreated the folder ‘core’ and copied shipped.json and signature.json from a backup into the folder. Don’t forget to check ‘www-data’ ownership…

Then a ‘retry upgrade’ finished without further issues.