Davdroid no longer works with NC 10.0.1 / OVH

I just moved from owncloud 9.0.4 to nextcloud 10 and I face a very similar issue as in Davdroid no longer works with NC. I created another issue because 579 is solved.
I use davdroid 1.3.1-ose on Android 5.1
Everything works well on web interface and with ligthning on my thunderbird but I am facing this 503 issue (see 579 support ticket) on my mobile phone (and on my wife’s mobile phone as well) since I adopted nextcloud 10. Owncloud webdav client still works well also.
Here is the log : http://cxg.de/_4f35e0.htm

Thank you

Are you already using version NC 10.0.1? There was a fix (https://github.com/nextcloud/server/pull/1331) for some of these issue (perhaps not enough for davdroid).

I was not using 10.0.1 but 10.0.0.
And I was really confident about your answer since my NC is hosted on OVH as it is mentionned in the github link you sent to me.
Unfortunately, after upgrading to 10.0.1, nothing has changed.

Thanks for the try!

See the comments here:

Basically you can fix it by adding one more line to the file. The problem is basically that OHV renders many user agents invalid, but we can’t blacklist all of them.

So, in lib/base.php find:

		$incompatibleUserAgents = [
			// OS X Finder

After add:


Thanks for the answers.
I tried the addition of ‘/^DAVdroid/’, but I still have a problem. The maybe good new is that it is a different one now. It is no more the 503 one but another one. Here is the new log : http://cxg.de/_b5eca6.htm
Probably the problem is now about “PROPFIND/OPTIONS on user-given URL failed” and “Well-known URL detection failed

Well, that sounds like a setup issue with your server or with the davdroid app. But without access to the instance it’s hard to tell.

Thanks Nick,
I posted a “twin” post on davdroid : https://forums.bitfire.at/topic/1218/davdroid-not-working-with-nextcloud/3
Let’s see what they think about that…

It’s a server misconfiguration: your server sends Content-Length: 0 together with Content-Encoding: gzip in the reply to the OPTIONS request, which is invalid. A gzip-ed response body can’t have 0 bytes length. DAVdroid (to be exact, the okhttp LoggingInterceptor) wants to read the gzip-ed response with its GzipSource reader, which fails with an EOFException because there are no gzip “members” (compressed data sets).

For more information, see https://forums.bitfire.at/topic/1218/davdroid-not-working-with-nextcloud/8.

Thanks to last davdroid reply, I disabled the gzip compression on my nextcloud website. Indeed, the gzip compression was by default enabled on the Apache server provided by OVH. To do that, we just have to add the 3 following lines to the .htaccess file which is at the root of the nextcloud directory:
< IfModule mod_deflate.c > (without space next to the < and > char)
SetEnv no-gzip 1
< /IfModule > (without space next to the < and > char)

And everything now works perfectly back!!!
Thanks a lot to Nick for the first fix and to davdroid for the second one!