cURL error 6 (msg says: server has no internet connection)

Nextcloud version: 11.0.0
Operating system and version: ubuntu 16.04 ARM
Apache version: 2.4.18
PHP version: 7.0
Is this the first time you’ve seen this error and can you replicate it?: It was present in version 10 also. The error is constantly there.

The issue you are facing:

  • I have the following message on the admin warning page, although I am reaching the server from the internet, though as said in the error message I cannot install apps from the store.

This server has no working Internet connection: Multiple endpoints could not be reached. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features.

  • Also see further below the log output for cURL error 6 message. Note that when I run curl in the cli on the server, it works but when I check the output of this php file, I get this:
HTTP Status: 0 HTTP Status: 0 
  • I tried the php file on a computer behind the same router as the server and the output was this:
HTTP Status: 302 HTTP Status: 302 

The output of your Nextcloud log in Admin > Logging:

  • Here is one of the curl error 6 of the many:
GuzzleHttp\Exception\ConnectException: cURL error 6: Couldn't resolve host ''
  • see expanded version of the above log entry here

The output of your config.php file in /path/to/nextcloud:

  • didn’t modify it

The output of your Apache/nginx/system log in /var/log/____:

  • the log is full of this line (I think it’s because I disabled ipv6 on the server)
  • main issue was the same with enabled ipv6
[Mon Jan 09 23:18:48.681392 2017] [core:warn] [pid 27409] (101)Network is unreachable: AH00056: connect to listener on [::]:80 

So how could I start resolving this error? Any help is appreciated.

The resulting page is blank.

I don’t really know what I’m doing here, but as I said curl works fine from the command line.

Thank you for your help, I will look into it.

I tried it and I’m getting the following.
Array ( [0] => Array ( [host] => [class] => IN [ttl] => 1799 [type] => A [ip] => ) )

I figured out the issue.
I have dual WAN on my firewall and 2 IP ranges for each WAN. I realized that the nextcloud server was using a different public IP address for outgoing than the IP address being used for inbound.

I also have this issue. I’m on arch linux arm.
How can I resolve this?
I have enabled in php.ini but my curl gives me an error 6

If you don’t have dual WAN, your issue is different. Please use a new topic.