Curl error 28 ,appstore blank ,no apps shown ,request timeout

An error occured during the request. Unable to proceed.

Continuing the discussion from AppStore is empty:

as @SmallOne and thanks to @Terence_Van_Dam for mention it
> Change line 404 in 3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php

increase 1000 to 10000

In lib/private/App/AppStore/Fetcher/Fetcher.php

On line 98 change the timeout from 10 to 30 or 90

in lib/private/Http/Client.php

On line 66 change the timeout from 30 to 90

what don’t work for you?
try changing just TIMEOUT in Client.php and max_execution_time & max_input_time in php.ini or even .httaccess don't work
look like same issues:


https://help.nextcloud.com/t/no-app-store-in-nc-18/



https://help.nextcloud.com/t/downloading-certain-apps-not-working/
https://help.nextcloud.com/t/curl-error-28-operation-timed-out-after-xxxxxx-milliseconds-with-xxxxxx-out-of-xxxxxx-bytes-received-see-http-curl-haxx-se-libcurl-c-libcurl-errors-html/
https://help.nextcloud.com/t/curl-error-28-connection-timed-out-with-latest-docker-image/
Hoping this help

4 Likes

I can confirm this worked for me on my 18.0.3 versión.

A few days before making these modifications 18.0.4 arrived, then all files were restored in the process of updating to their original version. So I reapplied these modifications, and solved the problem again.

Hi there - I have/had this isse of timeout as well in my NC18 (inside docker).
I modified the timeout in Fetcher.php from 10 to 30, but still nothing changed.

Somehting which is worth noting: I run a Pi-Hole on the same physical machine as docker.

Some weeks ago I did an upgrade to v5 of it and - I can’t proof it - since than the issue started.
So I deactivated the DNS functionality via the pi-hole GUI. No changes. Than I modified the network in my FritzBox. A final restart of the whole server helped to bring back NC’s appstore as before.
[ A service networking restart on the server didn’t help. Maybe another way to refresh the network settings could avoid the reboot, but I have no gluh for the moment :wink: ]

Maybe someone else outside can confirm this behaviour as well?

Oliver

I’m having the exactly same issue since upgrading from nextcloud 18 to 19.0.1 (apache version).

{
  "reqId": "WOhK4zlx5BcmPRfV4ZZB",
  "level": 2,
  "time": "2020-07-28T06:46:40+00:00",
  "remoteAddr": "172.30.0.3",
  "user": "admin",
  "app": "appstoreFetcher",
  "method": "GET",
  "url": "/settings/apps/list",
  "message": "Could not connect to appstore: cURL error 28: Connection timed out after 60001 milliseconds (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)",
  "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:78.0) Gecko/20100101 Firefox/78.0",
  "version": "19.0.1.1"
}

I don’t think increasing the timeout makes any sense. 60 seconds more than exceeds than expected time.
Any ideas?

Ok, it seems that the appstore itself was down for a while. It was just a coincidence :slight_smile: