Continual Thunderbird Lighting Authentication Requirement with NC12

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):


Nextcloud version (eg, 10.0.2):12.0.2
Operating system and version (eg, Ubuntu 16.04):Windows 7Pro 32bit
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 5.6):
Is this the first time you’ve seen this error?: Yes

Can you reliably replicate it? (If so, please outline steps): Opening and running Thunderbird & Lightning

The issue you are facing:
After creating the CalDav calendar shares in NC Calendar and setting the correct paths in my desktop Thunderbird with Lighting, I get a continual “Authentication Requirement” script in Thunderbird popping up every few minutes. I have the username and password filled in and checked to be remembered using the Password Manager but it continually cycles every 2-3 minutes no matter how many times I keep hitting OK.
The login script reads:
"Authentication Required: https://www.XXXXXXX.com is requesting your username and password. WARNING: Your password will not be sent to the website you are currently using.
Username: xxxx
Password: xxxxxxx
OK / CANCEL"
I had my Lighting calendars shared through Google before so I could access the information on both the PC and my laptop without issue. When I switched over to Nextcloud, however, that is when this issue started. Web searches are coming up dry.
Environment:
OS: Windows 7Pro 32Bit
Thunderbird: v52.3.0 (32 Bit)
Lightning: v5.4.3
Nextcloud: v12.0.2 (Hosted through Hostiso.com)

Perhaps this is related, but the Nextcloud Desktop Client software also cannot connect to my website. It shows the dialog in the red box:
"No connection to Nextcloud at https://www.XXXXXX.com/dir. Operation canceled."
Logging out and back in fails to connect either. So synchronizing with the local folder isn’t working currently either.
(NC Desktop Client for Windows, v2.3.2 (build 1) and it says the current installation is up to date).

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:


Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.Capture copy

wow… it’s getting packed of questions in here…
but first of all: i don’t think it’s a nextcloud-related problem. since everythink works well with me.

have you tried accessing your instance without /dir? where it your instance located?

there are several (german) topics about this one in the forum. do you speak german? try searching for “thunderbird”… often it turned out to be a problem with passwords… some special characters aren’t allowed due to security reasons. another guy came up with the idea of turning http2 off. so… i don’t know what may be fitting here.

but be sure it works in other set-ups.

JimmyKater,
Thanks for the responses.

  1. Not sure what took place overnight but the Nextcloud Desktop Client was connecting and synching fine up to a few moments ago. Then it dropped the connection and I couldn’t get it back. I tried dropping the /dir in the address and it gave me an instant NOT FOUND prompt for the URL. I deleted the connection it had in memory and started over again and seems to be working for the moment.

  2. Alas no I don’t speak German but I suppose I could copy and paste into Google Translate if necessary. I don’t have any special characters in my password and I never had this issue before with Thunderbird. I tried switching to the non-secured address (http://…) but that didn’t work either as it gave me a 404 NOT FOUND error. Besides which I’m not keen on connecting unsecured for my data and files (even if it just my personal calendar/contacts/tasks).
    Initial research, while inconclusive, seemed to point possibly towards security settings on the server side of the equation. I have asked Hostiso.com (the Name Server host for Nextcloud) but they pointed me to here at NC forums. Since I switched the NS’s, GoDaddy (the domain host I set up the URL with first) shut out access to any of the DNS settings on their end.

Thanks, the search continues.

why not trying a different one? duckdns, no-ip, freeDNS? they all seem to be tested (not by me but by other guys here) and declared to be working well with NC.

strange.

understandable. but at the same time if it would work unsecured that would narrow the search for your problems… but wells… :frowning:

JimmyKater,

  1. Name Servers: Yes I could try another, but I have an account started with Hositiso.com and have money invested already. If I cannot find a (reasonable) solution, then trying alternate NS’s is on the agenda.

  2. Shortly afterwards, it failed to find a connection. It is a repeating pattern: starting up PC at start of day = connection. After a few hours, connection is lost and cannot be re-established without a PC restart. Irritating but I can use Nextcloud without the Desktop Client, just use the web browser interface. (Unless this is indicative of a bigger problem…). Hopefully this is an update issue with NC for their Windows client(?)

  3. As mentioned, I tried this and was not able to establish a connection through http://, so it’s a moot point.

@vinceg101

ad 1: really? all of the NSses i pointed out are for free. at least they have free plans. no need to spend more bucks than neccessary.
ad 2: for me it sounds more like a problem of your PC than of your NC-instance.
ad 3: was understood before. so it was more like a farewell to another opportunity to find out more about your problems. sometimes i really use subjunctive… :wink:

I would have to find out if Hostiso would let me do this (?) They are my Linux server host since I don’t have a physical native Linux server to run NC on (otherwise I would do has you suggest).

Maybe, I have been waiting to resolve the whole thing before I re-path the T-Bird Calendar shares on my Win10 laptop. But maybe I will just go ahead and do this to see if the same problem persists in that environment.

Ha, gotcha. And yes, it would have been informative to see if that worked. Oh well.

Okay, as for the Desktop Client issue, searched and found this thread which was related to my issue:


Down at the bottom a poster suggested Whitelisting my IP address and Bingo, that seems to work. As soon as I reopened the Desktop Client it automatically connects.
One issue down (hopefully).

1 Like

Okay, so it appears that Whitelisting the IP address solved both issues:

  1. NC Desktop Client Connection and
  2. Thunderbird Authentication Script loop.

I knew deep down the two issues were related somehow and seems it was a server-side security issue. I knew I was on the right track when, after adding my IP to the Whitelist, upon restarting Thunderbird I was prompted to log into all my calendars & tasks again.

It has been a little less than 24 hours since I initiated this fix and it seems to be working; I haven’t been prompted to re-enter my NC login when T-Bird starts (password manager is working), nor has a single Authentication Verification script appeared. This has been the case with my laptop also.

Also my NC Desktop Client has been maintaining a near-permanent connection to my URL & NC as well.

So to re-cap: It’s probably a good idea to include Whitelisting your IP addresses as part of Nextcloud setup if you have any indication of login or connection issues; or at least try this as part of troubleshooting.

1 Like

very well done… and tricky to find out about.
though i think it’s a bug that your own IP gets blacklisted…