"Collabora Online - Built-in CODE Server" Not working

The Collabora Online - Built-in CODE Server is not working. Tried opening a document, and it just stuck at loading.

  • Collabora Online App version 4.2.3
  • Collabora Online - Built-in CODE Server App version 21.11.4
  • NC version 22.2.3 (running in docker)
  • OS Linux 5.10.0-9-amd64 x86_64

Any ideas?


please use search function, there are quite fresh threads about collabora integration

I gave it up with Collabora. I tried to fix it several times. It is known bug.
Finally, I switched to OnlyOffice and it is working fine for me.
I have the same versions of apps as you.

But with OnlyOffice, can you even save files? I’ve tried using it, but all I could do was ‘save as a new copy’… :confused:

There is no “save function” because all changes are saved automatically. There is no need for it.
But you can save a copy of the file.

Are you using the “Community Document Server” for OnlyOffice? It’s got some pretty negative reviews. How do you find it so far?

I am using:
Community Document Server 0.1.11
Everything is working fine for me.

I like to mention that I use Nextcloud for the Home server (family use - 6 souls :grinning:).
So it fills my needs.
I use Onlyoffice software on my desktop comps as well.

Are you sure your files are being saved? There’s a long standing issue that files edited in OnlyOffice are not actually saved in the file themselves.

I’ve just confirmed this myself:

  • Opened document in nextcloud onlyoffice
  • Made some edits
  • Saved, and closed. When I reopened the file, the changes are still reflected by the only office app.
  • But when I downloaded the file, the changes are not there.

Collobora doesn’t have this issue, and I’ve gotten it working thanks to this solution

So I tried to check it as you do and I confirmed this.
DOCX document created ONLINE - downloaded locally with the changes - it is OK.
XLSX document created ONLINE - downloaded locally - empty document- it is not OK.

But when I started the synchronization app on my desktop pc, both files were downloaded and synchronized. Everything was OK.
XLSX document contained the changes as its online version.

So for me, it is OK. Because I use the Nextcloud app on every device (PC and notebooks).

I like to try the Collabora fix but it is a shame that the new version of Nextcloud 23 still contains this problem.

And yet there is no solution for many. Or, at least, it seems like that by the other comments on this thread. At least one person says that they gave up Collabora. I want Collabora back but there seems to be no solution even though I get a green light in the settings. NO suggested solution works for me.

I just now uninstalled the “built-in CODE server” and that made my own Collabora server work again! I thought I had tried everything! Seems that the only problems were that these two installations were in conflict somehow. Hooray! :partying_face:

upgraded to version 24.0.6 and I could not open any collabora file anymore… stumbled upon this thread and installed ONLYOFFICE.

I tested if changes are saved, that looks fine.

The odd thing this is, that the ‘apps tab’ tells me I installed version ONLYOFFICE 7.5.6… but when I open and ODS file and click ‘help > about’:

Nextcloud Office

COOLWSD versie:

LOKit versie: built on a great technology base

Collabora Office

Copyright © 2022, Collabora Productivity Limited.

I want to ask how did you handle making the Onlyoffice app work.
I try to connect the app with Community Document server 0.12 but it does not work.
Thank you.

Well, I disabled Collabora and then enabled OnlyOffice in the app section of Nextcloud… nothing more, nothing less…

Thank you for your answer. I like to know what Document server you use.

Could that be the ‘Nextcloud Office’ app?

What combination have you?

  1. Onlyoffice + Community Document server
  2. Nextcloud Office + Collabora

These are the apps I’ve installed:

Collaborative tags 1.14.0
External storage support 1.16.1
File sharing 1.16.2
Nextcloud Office 6.3.1
Collabora Online - Built-in CODE Server 22.5.702 => installed but not active

Thank you very much.
It does not work for me by default settings.
Can you please send me your settings for Settings → Administration → Onlyoffice → ONLYOFFICE Docs address?

both setting fields are empty