Collabora & NC19 - Slow Performance

Hi Guys,

I just installed the new Nextcloud 19 and tried out the Collabora Office. To me this is slow as hell, and I’m really not sure why is that so? When I type something the symbols appear like 1-2 second later or so. Can this be optimized somehow? I didn’t find anything…

I run Nextcloud on a Plesk managed root server with Debian 9.
PHP 7.3.18 with PHP FPM
PHP Memory Limit 512 MB
Maria DB 10.1.44

Any ideas? The MD Text editor just works fine.

Thank you for your help in advance!

What I did not mention before: It’s a clean new install of Nextcloud and I’m the only user at the moment. Encryption is enabled for secruity reasons.

I upgraded the available PHP memory for my Nextcloud to 1 GB with no change. The server runs a only few websites and has 32 GB RAM and a Intel E3 1246v3 CPU. I’m running Debian 9.12 and Plesk Obsidian 18.0.27

I checked the webserver logs and the Nextcloud Logs but cannot find any errors…

Anyone has an idea?

i hope i can help you altough i also had problems with office apps in nextcloud, well theres noone who does answer u so i hope it helps.

https://contabo.de/?show=vps the 300 one is that what i am using, i am running nextcloud through docker and collabora code through docker with nginx proxy using these configs https://www.collaboraoffice.com/code/nginx-reverse-proxy/

for me it works pretty good, maybe u shouldnt use the built in code server because it could be older version, u can try installing collabora through docker

                docker pull collabora/code
                docker run -t -d -p 127.0.0.1:9980:9980 -e 'domain=cloud\\.nextcloud\\.com' --restart always --cap-add MKNOD collabora/code

for me it does not lag and i am even connected to a free vpn to be able to connect to ssh.

it doesnt take much time to try it out through docker…

Hi @markusbln,
have you found a solution, yet?

For me it is the same and it is related to the built-in CODE server. You can just validate it by enabling in the configuration a demo-server - with that, the performance is much better.

I will set up now a separate CODE server…

Sadly didn’t had the time yet to set up a seperate CODE server. Thel latest update didn’t solve the issues.