Client 3.3.1 & 3.3.2 (Windows) Failing to connect to server

Nextcloud version: 20.0.11
Operating system and version: Mint 19.3
Apache or nginx version: Apache 2.4.29
PHP version: 7.2.24

The issue you are facing:

I get errors like:
you have been loged out of <user>@<server> as user <user>. Please login again.
from the windows app, I am able to log in on the website, and other apps accessing this Nextcloud seem to work here.

Is this the first time you’ve seen this error? : yes

Steps to replicate it:

  1. start up nextcloud windows client app

The output of your Nextcloud log in Admin > Logging:

nothing related

The output of your Apache/nginx/system log in /var/log/____:

please advise on what to look for in these files.

Same issue (Windows and macOS), I have tested 3.3.2 too and I cannot connect Nextcloud client with my server after log out.

how to reproduce the issue:

  1. log out from the Nextcloud client
  2. Chose “log in” in the app
  3. Log in to your Nextcloud server and select “Grant access”
  4. Back to the Nextcloud app on the taskbar

After that you will see a window “You have been logged out … Please log in again”

The issue start occurs after update client from 3.2.6 to 3.3.1

Workaround:

  1. Go to your the client app
  2. Select “3 dots” next to your account
  3. Select “Remove account” and “Remove connection”
  4. Close the client by “Exit Nextcloud”
  5. Run Nextcloud app
  6. Add the account again to the client app
  7. Select your previous local folder
  8. Select what you want to sync

After the workaround Nextcloud client will be work until next log out.

Please to resolve the issue ASAP

Thank you for the work-around, I have followed a similar process in the past. Unfortunately I have multiple folders set up to sync, so the effort to re-do is a bit more than trivial in my case. Also, I am trying the newer ‘virtual files’ thing, and I am not sure how complicated things might get while disrupting that.

Until this gets more annoying, I am going to leave this client in it’s broken state in a vague hope that I might get some guidance here on how to volunteer some of my troubleshooting effort to advance toward a fix to whatever bug is causing this.

Here is our bug report:

Client updated to 3.3.2 today, and this is not fixed.

Can anyone advise on what would need to be done to downgrade to a working client while preserving all my account and sync settings?

1 Like

Every time they update the desktop client, I have to delete my config and re-download 70 Gigs of data, to every machine. It’s really getting awful, I need to downgrade too.

The client must store the sync settings and account somewhere - If there was a configuration file, one could save that and re-use it on a reinstall, or regression motivated downgrade to avoid the hassle of re-setting everything up again. Anybody know where to look for this?

Such a thing might also be useful in a bulk deployment scenario wanting specific defaults.

Got the same problem, tried to find an answer here too:

Update to 3.3.3 received today seems to restore the client function for me.

I have updated to version 3.3.3 and it seems the issue has been resolved. After log out from the desktop app I can log in. I have checked on Windows and macOS.

It worked when I first started the desktop-client. I had to authorize and then it woked.

But: Just started the CLkient again and it, again, wanted to authorize the client…

And now, for first time, i get “undefinierter Zustand”, something like “undefined status”