Can't install on Armbian 23.5.1 - Bookworm

Hi,
I’m using Armbian 23.5.1 with Bookworm Debian in it.
After runnig install.sh script, it shows me, that this version is not supported.

nashome@espressobin:~/programs/nextcloudpi$ sudo ./install.sh
Hit:1 http://security.debian.org bookworm-security InRelease
Hit:2 http://deb.debian.org/debian bookworm InRelease
Hit:3 http://deb.debian.org/debian bookworm-updates InRelease
Hit:4 http://deb.debian.org/debian bookworm-backports InRelease
Hit:5 https://www.deb-multimedia.org bookworm InRelease
Hit:6 http://fi.mirror.armbian.de/apt bookworm InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
git is already the newest version (1:2.39.2-1.1).
ca-certificates is already the newest version (20230311).
sudo is already the newest version (1.9.13p3-1+deb12u1).
lsb-release is already the newest version (12.0-1).
wget is already the newest version (1.21.3-1+b1).
The following packages were automatically installed and are no longer required:
  libavcodec59 libavformat59 libavutil57 librav1e0 libssh-gcrypt-4
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Getting build code...
Cloning into '/tmp/nextcloudpi.QyVaVR/nextcloudpi'...
remote: Enumerating objects: 14533, done.
remote: Counting objects: 100% (607/607), done.
remote: Compressing objects: 100% (349/349), done.
remote: Total 14533 (delta 324), reused 490 (delta 250), pack-reused 13926
Receiving objects: 100% (14533/14533), 8.17 MiB | 6.18 MiB/s, done.
Resolving deltas: 100% (10118/10118), done.

Installing NextCloudPi...
ERROR: distro not supported:
Armbian 23.5.1 Bookworm \l

nashome@espressobin:~/programs/nextcloudpi$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Armbian 23.05.1 bookworm
Release:	12
Codename:	bookworm
nashome@espressobin:~/programs/nextcloudpi$ uname -a
Linux espressobin 5.15.113-mvebu64 #1 SMP PREEMPT Wed May 24 16:36:55 UTC 2023 aarch64 GNU/Linux

Is there any hack, how to install it please?
Thank you.
Tomino

Which script is this? Please provide a link to the script you are using, otherwise we can’t really help.

This one: https://github.com/nextcloud/nextcloudpi/blob/master/install.sh
I’ve tried also this one from wiki:

Curl install scripts

This is executed as root as indicated by the #

# curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | bash

Both shows me same result.

You could remove the following section from the script:

# check distro
check_distro etc/ncp.cfg || {
  echo "ERROR: distro not supported:";
  cat /etc/issue
  exit 1;
}

Or you could change the release name in this file https://github.com/nextcloud/nextcloudpi/blob/master/etc/ncp.cfg

However, I would not recommend doing so, becauase the script obviously is not yet tested on Bookworm, which could lead to further issues.

EDIT:
Debian 12 Bookworm is not yet supported: Debian 12 Bookworm Support · Issue #1730 · nextcloud/nextcloudpi · GitHub

So, I’d recommend using an Armbian Image based on Bullseye, in order to avoid issues. Once Booworm is officially supported by the NCP team, I’m pretty sure there will be an upgrade path to Bookworm.

I also put your post into the Appliances section and added the tag ncp to it. Maybe someone from the NCP folks would like to comment here, otherwise you can follow the GitHub issue I linked to for news regarding Bookworm support.

1 Like

I’ve tried that, but it crashed due to dependancy issue on php8.1 version from sury’s repository, which is also just for bullseye :-/

Get:1 http://security.debian.org bookworm-security InRelease [48.0 kB]
Hit:2 http://deb.debian.org/debian bookworm InRelease
Hit:3 http://deb.debian.org/debian bookworm-updates InRelease
Hit:4 http://deb.debian.org/debian bookworm-backports InRelease
Hit:5 http://mirrors.xtom.de/armbian bookworm InRelease
Hit:6 https://www.deb-multimedia.org bookworm InRelease
Fetched 48.0 kB in 3s (15.4 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
git is already the newest version (1:2.39.2-1.1).
ca-certificates is already the newest version (20230311).
sudo is already the newest version (1.9.13p3-1+deb12u1).
lsb-release is already the newest version (12.0-1).
wget is already the newest version (1.21.3-1+b1).
The following packages were automatically installed and are no longer required:
  libavcodec59 libavformat59 libavutil57 librav1e0 libssh-gcrypt-4
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Getting build code...
Cloning into '/tmp/nextcloudpi.09WMBG/nextcloudpi'...
remote: Enumerating objects: 14533, done.
remote: Counting objects: 100% (607/607), done.
remote: Compressing objects: 100% (349/349), done.
remote: Total 14533 (delta 324), reused 497 (delta 250), pack-reused 13926
Receiving objects: 100% (14533/14533), 8.17 MiB | 5.82 MiB/s, done.
Resolving deltas: 100% (10116/10116), done.

Installing NextCloudPi...
Installing lamp
+ wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
--2023-08-06 14:31:17--  https://packages.sury.org/php/apt.gpg
Resolving packages.sury.org (packages.sury.org)... 185.152.64.17
Connecting to packages.sury.org (packages.sury.org)|185.152.64.17|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1769 (1.7K) [application/octet-stream]
Saving to: ‘/etc/apt/trusted.gpg.d/php.gpg’

/etc/apt/trusted.gpg.d/php.gpg                              100%[========================================================================================================================================>]   1.73K  --.-KB/s    in 0s

2023-08-06 14:31:18 (12.5 MB/s) - ‘/etc/apt/trusted.gpg.d/php.gpg’ saved [1769/1769]

+ echo 'deb https://packages.sury.org/php/ bullseye main'
+ apt-get update
Hit:1 http://security.debian.org bookworm-security InRelease
Hit:2 http://deb.debian.org/debian bookworm InRelease
Hit:3 http://deb.debian.org/debian bookworm-updates InRelease
Hit:4 http://deb.debian.org/debian bookworm-backports InRelease
Get:6 https://packages.sury.org/php bullseye InRelease [7,551 B]
Hit:7 https://www.deb-multimedia.org bookworm InRelease
Hit:5 http://mirrors.xtom.de/armbian bookworm InRelease
Get:8 https://packages.sury.org/php bullseye/main arm64 Packages [387 kB]
Get:9 https://packages.sury.org/php bullseye/main arm64 Contents (deb) [103 kB]
Fetched 497 kB in 4s (134 kB/s)
Reading package lists... Done
+ apt-get install -y --no-install-recommends apt-utils cron curl
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
apt-utils is already the newest version (2.6.1).
cron is already the newest version (3.0pl1-162).
curl is already the newest version (7.88.1-10+deb12u1).
The following packages were automatically installed and are no longer required:
  libavcodec59 libavformat59 libavutil57 librav1e0 libssh-gcrypt-4
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
+ ls -l /var/lock
total 0
+ apt-get install -y --no-install-recommends apache2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libavcodec59 libavformat59 libavutil57 librav1e0 libssh-gcrypt-4
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  apache2-bin apache2-data apache2-utils libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.3-0
Suggested packages:
  apache2-doc apache2-suexec-pristine | apache2-suexec-custom www-browser
Recommended packages:
  ssl-cert
The following NEW packages will be installed:
  apache2 apache2-bin apache2-data apache2-utils libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.3-0
0 upgraded, 9 newly installed, 0 to remove and 4 not upgraded.
Need to get 2,145 kB of archives.
After this operation, 14.0 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian bookworm/main arm64 libapr1 arm64 1.7.2-3 [94.1 kB]
Get:2 http://deb.debian.org/debian bookworm/main arm64 libaprutil1 arm64 1.6.3-1 [84.4 kB]
Get:3 http://deb.debian.org/debian bookworm/main arm64 libaprutil1-dbd-sqlite3 arm64 1.6.3-1 [13.5 kB]
Get:4 http://deb.debian.org/debian bookworm/main arm64 libaprutil1-ldap arm64 1.6.3-1 [11.8 kB]
Get:5 http://deb.debian.org/debian bookworm/main arm64 liblua5.3-0 arm64 5.3.6-2 [110 kB]
Get:6 http://deb.debian.org/debian bookworm/main arm64 apache2-bin arm64 2.4.57-2 [1,257 kB]
Get:7 http://deb.debian.org/debian bookworm/main arm64 apache2-data all 2.4.57-2 [160 kB]
Get:8 http://deb.debian.org/debian bookworm/main arm64 apache2-utils arm64 2.4.57-2 [199 kB]
Get:9 http://deb.debian.org/debian bookworm/main arm64 apache2 arm64 2.4.57-2 [215 kB]
Fetched 2,145 kB in 0s (7,227 kB/s)
Selecting previously unselected package libapr1:arm64.
(Reading database ... 50462 files and directories currently installed.)
Preparing to unpack .../0-libapr1_1.7.2-3_arm64.deb ...
Unpacking libapr1:arm64 (1.7.2-3) ...
Selecting previously unselected package libaprutil1:arm64.
Preparing to unpack .../1-libaprutil1_1.6.3-1_arm64.deb ...
Unpacking libaprutil1:arm64 (1.6.3-1) ...
Selecting previously unselected package libaprutil1-dbd-sqlite3:arm64.
Preparing to unpack .../2-libaprutil1-dbd-sqlite3_1.6.3-1_arm64.deb ...
Unpacking libaprutil1-dbd-sqlite3:arm64 (1.6.3-1) ...
Selecting previously unselected package libaprutil1-ldap:arm64.
Preparing to unpack .../3-libaprutil1-ldap_1.6.3-1_arm64.deb ...
Unpacking libaprutil1-ldap:arm64 (1.6.3-1) ...
Selecting previously unselected package liblua5.3-0:arm64.
Preparing to unpack .../4-liblua5.3-0_5.3.6-2_arm64.deb ...
Unpacking liblua5.3-0:arm64 (5.3.6-2) ...
Selecting previously unselected package apache2-bin.
Preparing to unpack .../5-apache2-bin_2.4.57-2_arm64.deb ...
Unpacking apache2-bin (2.4.57-2) ...
Selecting previously unselected package apache2-data.
Preparing to unpack .../6-apache2-data_2.4.57-2_all.deb ...
Unpacking apache2-data (2.4.57-2) ...
Selecting previously unselected package apache2-utils.
Preparing to unpack .../7-apache2-utils_2.4.57-2_arm64.deb ...
Unpacking apache2-utils (2.4.57-2) ...
Selecting previously unselected package apache2.
Preparing to unpack .../8-apache2_2.4.57-2_arm64.deb ...
Unpacking apache2 (2.4.57-2) ...
Setting up libapr1:arm64 (1.7.2-3) ...
Setting up liblua5.3-0:arm64 (5.3.6-2) ...
Setting up apache2-data (2.4.57-2) ...
Setting up libaprutil1:arm64 (1.6.3-1) ...
Setting up libaprutil1-ldap:arm64 (1.6.3-1) ...
Setting up libaprutil1-dbd-sqlite3:arm64 (1.6.3-1) ...
Setting up apache2-utils (2.4.57-2) ...
Setting up apache2-bin (2.4.57-2) ...
Setting up apache2 (2.4.57-2) ...
Enabling module mpm_event.
Enabling module authz_core.
Enabling module authz_host.
Enabling module authn_core.
Enabling module auth_basic.
Enabling module access_compat.
Enabling module authn_file.
Enabling module authz_user.
Enabling module alias.
Enabling module dir.
Enabling module autoindex.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module filter.
Enabling module deflate.
Enabling module status.
Enabling module reqtimeout.
Enabling conf charset.
Enabling conf localized-error-pages.
Enabling conf other-vhosts-access-log.
Enabling conf security.
Enabling conf serve-cgi-bin.
Enabling site 000-default.
Created symlink /etc/systemd/system/multi-user.target.wants/apache2.service → /lib/systemd/system/apache2.service.
Created symlink /etc/systemd/system/multi-user.target.wants/apache-htcacheclean.service → /lib/systemd/system/apache-htcacheclean.service.
Processing triggers for man-db (2.11.2-2) ...
Processing triggers for libc-bin (2.36-9+deb12u1) ...
+ mkdir -p /run/lock
+ apache2ctl -V
Server version: Apache/2.4.57 (Debian)
Server built:   2023-04-13T03:26:51
Server's Module Magic Number: 20120211:127
Server loaded:  APR 1.7.2, APR-UTIL 1.6.3, PCRE 10.42 2022-12-11
Compiled using: APR 1.7.2, APR-UTIL 1.6.3, PCRE 10.42 2022-12-11
Architecture:   64-bit
Server MPM:     event
  threaded:     yes (fixed thread count)
    forked:     yes (variable process count)
Server compiled with....
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_PROC_PTHREAD_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=256
 -D HTTPD_ROOT="/etc/apache2"
 -D SUEXEC_BIN="/usr/lib/apache2/suexec"
 -D DEFAULT_PIDLOG="/var/run/apache2.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="mime.types"
 -D SERVER_CONFIG_FILE="apache2.conf"
+ id -u systemd-resolve
996
+ install_with_shadow_workaround --no-install-recommends systemd
+ restore_shadow=true
+ [[ -L /etc/shadow ]]
+ restore_shadow=false
+ [[ false == \f\a\l\s\e ]]
+ DEBIAN_FRONTEND=noninteractive
+ apt-get install -y --no-install-recommends systemd
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
systemd is already the newest version (252.12-1~deb12u1).
systemd set to manually installed.
The following packages were automatically installed and are no longer required:
  libavcodec59 libavformat59 libavutil57 librav1e0 libssh-gcrypt-4
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
+ [[ false == \f\a\l\s\e ]]
+ trap - EXIT
+ apt-get install -y --no-install-recommends -t bullseye php8.1 php8.1-curl php8.1-gd php8.1-fpm php8.1-cli php8.1-opcache php8.1-mbstring php8.1-xml php8.1-zip php8.1-fileinfo php8.1-ldap php8.1-intl php8.1-bz2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'php8.1-common' instead of 'php8.1-fileinfo'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgd3 : Depends: libavif9 (>= 0.8.4) but it is not installable
          Depends: libtiff5 (>= 4.0.3) but it is not installable
          Depends: libwebp6 (>= 0.5.1) but it is not installable
 php8.1-cli : Depends: libssl1.1 (>= 1.1.1) but it is not installable
 php8.1-common : Depends: libffi7 (>= 3.3~20180313) but it is not installable
                 Depends: libssl1.1 (>= 1.1.0) but it is not installable
 php8.1-fpm : Depends: libssl1.1 (>= 1.1.1) but it is not installable
 php8.1-intl : Depends: libicu67 (>= 67.1-1~) but it is not installable
 php8.1-ldap : Depends: libldap-2.4-2 (>= 2.4.25) but it is not installable
E: Unable to correct problems, you have held broken packages

You could try to change the release name in this file https://github.com/nextcloud/nextcloudpi/blob/master/etc/ncp.cfg. Whether this will work depends on whether they are using the variable from the ncp.cfg file or if they hardcoded the deb sources for the Sury Repos.

Anyways, as I already added to my previous post, NextcloudPi doesn’t support Bookworm just yet. This means, even if you somehow manage to install it via the script, you still cannot be completly sure that everything will work without issues after you installed it.

So unless you want to go through all the files and scripts, and basically maintain your own version of NextcloudPi, I’d suggest you install it on Bullseye and upgrade to Bookworm once it is officially supported.

Finally, I’ve managed to do it myself :slight_smile:
Few problems occurs, but it was ok I’ve solve them without problem, mainly about different name of php libs, exfat utils and so on.
Some problem with installing and starting up dnsmasq service.
One issue after installing with activating, but this thread helped: NextCloudPlus not yet initialized, trying again in a few seconds
So actually I’m on NCP 27.0.1 on Debian 12 - Bookworm.