NextCloudPlus not yet initialized, trying again in a few seconds

Hey guys,

Some weeks ago, I bought some Raspberry Pis 3 B+ for some different projects.

One of these was intended to be running NextCloud and I chose to use the official NextCloud Pi/Plus project image.

Unfortunately, I was not able to get it to work yet…

First, I had problems concerning my router and ‘ssh’ but those problems are fixed now. Now after the first devices are running fine, I am running into problems with NextCloud Plus…

On the activation page, when I click activate the installer only shows the message: ‘NextCloudPlus not yet initialized, trying again in a few seconds …’ and when I wait for a longer time: ‘Something went wrong. Try refreshing the page’. I tried different browsers, different computers but it just will not work.

I do not know what to do anymore… even that I am not a newbie, I followed the guides on GitHub systematically but cannot find the problem.

I would be very happy if you could help me :smile:

Greetings

Borotes

1 Like

I can confirm this issue, latest Docker image seems broken:
from Docker logs:

Starting Redis
Starting Cron
Starting Postfix
Nextcloud is not installed - only a limited number of commands are available


  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.


Init done

By the way, please tag the Docker images and do not override the images, because we do not have the possibility that we can checkout an older image, if the newer one is broken.

(I am using Nextcloudpi a few month now and till now I am really satisfied - thanks for the awesome work!)

1 Like

hi,

did you try to upgrade by pulling? how did you end up in this situation?

the docker container is not broken, just tested it now. Maybe you tried to upgrade by pulling, or you tried to start from zero but didn’t do so in a clear volume? you can pass any folder to the -v /myfolder:/data parameter to verify that it works (will start a clean instance), without deleting/losing your current volume.

1 Like

I deleted the old container and pulled the new image. I also tested it with new volumes (-v test:/data) with the following command:

docker run -d -p 4443:4443 -p 443:443 -p 80:80 -v ncdata:/data --name nextcloudplus ownyourbits/nextcloudplus-armhf 192.168.0.222

It gets always stuck in the situation mentioned in my previous post, which therefore does not progress on the activation web interface.

I luckily found an old image because Docker has also updated the systemd service config to use the default docker directory again, so I was able to use the Docker image from February again.

With the new image I could not get it up and running.

(on another thread somebody has written about the same issue:
RPi 3B+ install issue: "...no commands defined in the "config:system" namespace")

I have tested the x86 image on my laptop and it is working, only the image for the arm architecture is not working for me on the rpi3.

Thanks for your work!!

1 Like

You are absolutely right. The armhf version does have that problem. I am building it again.

Interesting that the tests seemed to go ok, must be a mistake from my side.

Thanks for the feedback

1 Like

I have pushed the updated docker image, with NC 13.0.2. I verified manually that it works

Thanks again for the feedback!

1 Like

Thanks a lot for your help! I am glad that I was not the problem :joy:

But now, it is not clear for me what I have to do or install :persevere:

Do I still have to use the NC Plus Image or the latest Raspbian and install the docker on it?

Are the tutorials still up to date? :thinking:

I would be very happy if you could help me again! :slight_smile:

your issue is unrelated to @patrick0210’s ( he kinda hijacked the thread xD )

just go for the SD card version. If weird things fail (your case) suspect a hardware issue which is very commonly due to cheap power supplies and SD cards.

1 Like

Thanks for your quick answer :smile:

I have got the official power supply and an Samsung SD card, I don’t really think they could be the problem (my other raspis work fine) :thinking:

that’s what everyone says xD

trust me it’s worth a shot

you shouldn’t have any problems with flash SD card -> turn on -> navigate to IP -> click activate

1 Like

Doing so results in:
" Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later."

:sob:

hardware problems… try giving it a minute, but better buy a good SD card / power supply

1 Like

I can confirm the problem from Borotes. I tested my sdcard with H2testw. I do not think this is a hardware problem.

1 Like

people never do, what about the power supply?

1 Like


I think it should be alright since it is from a reputable german seller.

1 Like

Yeah, it is easy to call it a hardware problem… All my other projects are working fine even on this raspberry. I am really disappointed to be honest… I could think of wrong settings in my router or my PC but the raspberry is fine…

Same for me, i got the official one

Can I diagnose anything for you?

1 Like

Trust me, I deal with this everyday, several times a day, I don’t just say it because it’s easy.

NCP is just taking Raspbian and installing NC on top. There are plenty people running NCP on the rpi3B+, so I doubt this is a NCP issue.

In any case, you can always try to run the docker container or install yourself through the curl installer on top of Raspbian.

Diagnostics can be obtained through sudo ncp-report

1 Like

Sorry, I did not meant to offend you :slight_smile: I was just using it as an expression.

But in this case I doubt something different could be the problem, funny that Dieter_Muller an I both are German maybe a local issue? Router/Firewall/IP/ Provider… could that cause problems?