Can't Get SMB External Storage Working v10

I’ve read the existing posts about SMB external storage and none appear to apply to my scenario.

I have Nextcloud 10 installed on Ubuntu 16.04 and for the life of me can’t get external storage working. Here are my settings…

  • I’ve installed php-smbclient (sudo apt-get install php-smbclient)
  • From Nextcloud I turned on External Storage
  • From External Storage I entered…
  1. External Storage = SMB/CIFS
  2. Authentication = Global creds with the appropriate credentials entered in the Global creds section
  4. Name of shared folder on Windows Host (shared folder name = NEXTCLOUD)
  5. Available For = Admin group which includes me
  6. Checked “enable sharing”

These settings result in a little green dot next to the settings which suggests all is well however when I go to Files, I can see the new shared folder but when I click it, I get a message stating “Storage not available” To make sure the credentials and settings were accurate I accessed the shared folder using the credentials from another PC and Mac.

Assuming I’ve missed something and any help would be much appreciated.

Unfortunatelly same here.
NC10 on Ubuntu 16.0 with a new install
First tried with php-smbclient only. This gives error as the smbclient.ini file is placed in the wrong location.
/7.0Moved it from /etc/php/mods-available to /etc/php/7.0/mods-available but to no avail.

Only after installing smbclient the SMB/CIFS option becomes available.

Making a “succesfull” connection with the green dot is no problem however the map is not available.

All other maps, (home, local, sftp) work fine.

Have you tried with using the Host Name instead the IP address?
Don’t have the same conf as you have (PI with Jessie - PHP7 also - and external storage on Synology NAS), but I’m using the host name and it works well.

Hey AlexM. Thanks for the reply. I hadn’t tried that yet so I just attempted and same error. I tried various combinations of IP, host name, with slash without slash, even with slash on share name and each of those resulted in a green dot but share not available when I tried.

My guess is that the green dot only validates login credentials but does nothing to validate the path to the share.

Agree, green dot must be succesfull authentication

get the following in the log:
Exception":“OCP\Files\StorageNotAvailableException”,“Message”:"/data" where data is the subfolder on the share.

Created folder shows up in clients but no contents and cannot upload to it.
When there are no permissions assigned the folder is not visible in the client anymore. This al seems to work.

When using smclient from the server console it asks for password and connects succesfull, browsing etc. all fine.

smbclient //server/share -U username

Removed php-smbclient en php-smb as they didn’t work.

I have the same problem (NC10 + ubuntu server 14.04.5), did you find a solution?

Unfortunately, I haven’t. I’ve abandoned the issue since I can’t find a working solution.

Open an issue on github with full information about your system + logfiles. There is perhaps a related issue on owncloud:

Have you test this one?

Update: On current Ubuntu/ PHP7 servers it’s php-smbclient

sudo apt install php-smbclient
1 Like