Can't access outside my home

Newbie here. Got NextcloudPi running successfully over WiFi. Gave it a static IP address. Opened Ports 80 and 443 on my Google Mesh Router (at least I think I did). Set up a redirect via FREEDNS, which again works great from inside my home.

Outside the home my Nextcloud server is unreachable. Even pinging the IP address from outside my LAN fails.

I’m guess this explains why the LetsEncrypt certificate fails and half the music streaming apps on my phone fail too. They can’t see the server either.

Is there anything obvious I’m not doing?

Thanks and apologies if this is a common question!

Hi Gary,

could you go a bit more into detail what you did when you “opened ports 80 and 443”? Did you forward the specifically to your NextcloudPi?


Excellent question. The best way I can answer that is via configuration app screenshots:

[Screenshot removed for security reasons]

(The Google Mesh Router has a completely different UI and setup process than any other router I’ve used.)

Does this help?

Hi Gary,

not sure it helps exactly but it makes me more confident that the problem is somewhere there.

I don’t know the Google Mesh Router, so I’m just looking at your screenshot and try to interpret what I’m seeing. It seems to list devices with their open (listening) ports, so we see that your nextcloudpi as well as your Google Home hub seem to have webservers running and are listening on the HTTP and HTTPS ports.
There are mutliple entries for the Google Home hub, with the first one stating “443 -> 443” which looks like what might be a port forwarding. But even if so, it ends at the wrong device…

Googling a bit for Google (ha, ha) I found this tutorial:

Is that what you did?


That is indeed what I did, but since I don’t know what I’m doing I’m not sure I did it right.

First, I configured Google Home Hub to forward from Port 80 to Port 80, for both IPv4 and IPv6.

Then Google Home Hub to forward Port 443 for IPv6.

Then I configured NextCloudPi to do the same thing.

Did I need to do both? Should the Starting Port and Ending Port have been the same numbers?

Here’s what the configuration screen looked like: (removed for security reasons)

Sorry; I meant to say "Then Google Home Hub to forward Port 443 ending at Port 443 for IPv6.

I must say I find this interface a bit, let’s say, peculiar… :slight_smile:

So what you want is basically that your router forwards all external requests that reach it on port 80 and port 443 to your nextcloudpi box. Now how you can achieve that with this router settings interface is unclear to me - sorry for that!

Well, I don’t feel so bad then. :slight_smile: OK, I’ll go to the Google Mesh Router group for help. Thanks for your quick responses!

Are you in the DMZ

De-milititarized zone? Not sure I know enough to answer that. I can say that when I’m in my home everything works great; but if I use my laptop and go through my phone’s wi-fi hotspot, then the NextCloudPi server cannot be reached.

It puts your server out of the firewall on your router, even if your firewall is off you need to put it in that.

Search Results

Featured snippet from the web

A DMZ , short for demilitarized zone, is a network (physical or logical) used to connect hosts that provide an interface to an untrusted external network – usually the internet – while keeping the internal, private network – usually the corporate network – separated and isolated form the external network .
this is a good video about the DMZ

I’m not sure this is heading the right way. In principle with port forwarding there is no need for a DMZ - it might even be dangerous. A good read on the topic is e.g. here:

I recommend not port forward I just use the DMZ and I never have had a issue, if I do not use the DMZ it dose not ever let my server though.

Well, thank you both. I’m watching the video now while I’m waiting for a google chat representative to come online. :slight_smile: Just learned something new. Sounds like sturtz_nate was having the same problem as me and couldn’t get it resolved either.

What do you mean?

I mean you had the same problem and solved it using a DMZ.

Yes I had had that issue, just make sure like @simonspa said it can be risky but make sure you have firewalls set up

So thank you for the DMZ suggestion. I don’t believe my Google Mesh Router supports that. :frowning:

ok, I would ask about that