Cannot map external storage (USB, NTFS)

Hello,

I have a Raspberry pi 3 b+ with nextcloud installation (I suppose, the version is 14.0.1, since I made an update today) on it. I am trying to configure the External storage. I have successes to create an external storage, which is located on my SD card. The path is:
/home/pi/test_nextcloud

However, then I tried to do the same with external USB flash. The path is:
/media/pi/SANDISK-16GB/test_raspberry

And I do not see this folder in main menu.

What have I done already:
I have found this answer: [solved] External storage config for hard disk
I have followed this tutorial to map the external NTFS Flash disk:
https://retroresolution.com/2016/06/10/automatically-mounting-an-external-usb-hard-disk-on-the-raspberry-pi/
Everything went fine, but I have not succeed to set the user rights for user www-data. I found another solution here:
https://wiki.epfl.ch/icit/kb/linux-mount-ntfs-with-permissions

So how I have the following rights on the Flash folder:
> ls -ld /media/pi/SANDISK-16GB
drwxr-x— 1 www-data www-data 4096 Sep 30 16:07 /media/pi/SANDISK-16GB

And when I execute the following command
> sudo nano /etc/fstab

I receive:

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p6  /boot           vfat    defaults          0       2
/dev/mmcblk0p7  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
UUID=20688AD4688AA7DC /media/pi/SANDISK-16GB ntfs-3g permissions 0 1

However, the folder still does not appear in main menu of nextcloud.

I would be grateful, if somebody can help me and point, where the mistake is. Thank you in advance.

Kind regards,
Oleksandr

Any news? Even with not as good performance, it would be very useful to have access to NTFS external disks.