Cannot get Nextcloud Office to work!

Hi everyone,
I have NC 23.0.3 installed on my OVH Shared Hosting (php 7.4) and the following situation:

Collabora Online - Built-in CODE Server

You have the Collabora Online app enabled. For further information and configuration, please check: Settings > Administration > Collabora Online

Nextcloud Office

Use the built-in CODE - Collabora Online Development Edition

But the odt files are not managed through Nextcloud Office but rather downloaded.

Which is the part that I am missing?

Thanks!

I am having the same issue. I used to host a Collabora server, but that stopped working. I tried the Build-in version, but I have the same problem. I’ve removed everything for the time being. Any suggestions would be appreciated.

same issue
Snap [Nextcloud Hub II] (23.0.2)
Collabora Online - Built-in CODE Server, 21.11.204
Nextcloud Office, 5.0.3

Same problem, upgraded to NC 23.0.3, and I cannot open documents in NC any more. They are only proposed for download.
No entry for editing it in context menu either.

after some new tries, it seems to be working when using Chrome (the document is opened in collabora), but not with Firefox (the document is proposed for download only).

Thanks for the reply. I’ve tried with chromium and I say the same behavior as in Firefox: a request for download.

Search the forum because there are a lot of people with the same issue with temporary fixes that may help:

Most likely your shared hosting cannot meet the minimum system requirements of Nextcloud Collabora CODE.

It actually requires some serious system resources, which are restricted through shared hosting. You must unfortunately install Collabora on a separate server where it can receive the system resources it needs to run properly.

Note these requirements are the absolute minimum for Collabora for nextcloud. Nextcloud itself requires more!


    Linux x86-64 or ARM64 (aarch64) platform
    2 CPU cores
    1 GB RAM + 100 MB RAM / user
    100 kbit/s network bandwidth / user
    350 MB space on disk
    Nextcloud 19 with Collabora Online app 3.7.0 or higher
    glibc (AppImage does not support musl libc)
    Fontconfig (libfontconfig.so.1 - required by Collabora_Online.AppImage)