Cannot copy share links on truenas/docker

Nextcloud version (eg, 20.0.5): 27.0.0
Operating system and version (eg, Ubuntu 20.04): truenas/docker ( Linux 5.15.107+truenas x86_64)

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): yes, it’s a fresh install

Steps to replicate it:

  1. install nextcloud as an app in truenas
  2. create a folder
  3. share the folder using a public or internal sharelink
  4. attempt to copy the link

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


I’m trying to use nextcloud to use as an alternative for sharing photo’s and videos from vacation and stuff with a simple to use interface for my less techsavvy friends, the public share link is precisely what i was looking for, but with this issue I can not use it, does anyone have an idea of how to solve it? i have allready tried the “overwritehost” config to see if that solved the issue, but no luck.
If there is no solution for the time being, could you guys recommend some other dummy proof file drop/share solutions i can run in a docker environment(preferably without docker-compose)

take a look at this thread