Share link can not be copied

Hi ,
I use NextCloud for two years, and it works well. Thanks !
Recetly, when I need to share to my friends, I can not copy the link,
why that happened? What should I do?
My NextCloud version is 25.0.4.

1 Like


Maybe Javascript problem. Can you test another browser. Check browser settings and browser addons.

Thanks for your reply!
I tried Google Chrome and Microsoft Edge browser, It’s the same. Maybe I should clear cookie and try again?

I think if you have the problem with different browsers than it is no cookie problem. But you can press F12 for browser dev tools. Maybe you find a hint.

Hi huaKing,

are you conecting with http or https?

1 Like

İ’m here to find any solution about same problem. Temprorarly i solve with “snap revert nextcloud” command. İt’s not solution but NC runs normally now.

nextcloud reverted to 25.0.3snap3
thank you , now it works well.

i have this same problem on a clean install on my truenas system, has anyone found a solution yet?

Likely HTTP is in use. Switch to HTTPS.

I have the same problem, the version is 25.0.7, no response after clicking the copy link, can I update this problem to handle it? I am using http and don’t want to switch to https.

That was the reason, why I asked

before, but nobody answered. :thinking:

1 Like

“Switch to https” also is the solution for me with Version