Cannot add Nextcloud/Webdav as auto upload service in Android Scanbot app

Scanbot Android app and other Android webdav clients work fine with my Nextcloud 19 server installation.

Only when trying to add my Nextcloud as auto upload cloud service in the Scanbot app I receive an error message within the Scanbot app when trying to connect: “Cannot establish connection. Please check host, username, password correctness and your internet connection.”

Nextcloud server logs show “Expected {DAV:}propfind but received {DAV:}o as the root element” error messages which correspond with each connection request from within scanbot.

Tried those three connectors that are available within Scanbot app: Nextcloud, Webdav and OwnCloud… many different variations of URLs and following step by step instructions online.

I had the auto upload working some time ago but revoked the app password and tried to set it up again (I think there was an upgrade from Nextcloud 18 to 19 in between).

Any pointers on how to fix this? Extensive google searching did not yet help.


I have the exact same problem.
Same log message, tried different Users, URLs and Nextcloud, Owncloud and WebDav directly in the App.
Syncing with Docutain (another scan app that has the flaw of not uploading the pdfs directly, but the internal database and .DAT files) works fine.

Eventually the problem lays in the Scanbot App.

@wolf-gang have you tried to use sftp/ftps to connect to your nextcloud server?

My guess too is that the problem lies within the underlying webdav implementation of the Scanbot app., as other webdav clients connect fine with the Nextcloud server.

Temporarily switched to Google Drive upload. SFTP/FTPS would be a good alternative, but don’t know if/when I find the time to try.

Thank you for confirming the same issue - that gives at least some relief that I might not have missed anything. I guess I’ll try again if there are Scanbot app updates. After all it was working at some point.

Just too lazy to maintain an additional SFTP/FTPS installation - still preferring Nextcloud webdav as it would not cause additional maintenance work (using inbuilt sever functionality including centralized user management).

I send a request to Scanbot for further information. The answer was the following:

Scan Pro App (Scan Pro App)

Aug 26, 2020, 7:59 AM PDT

Please check that you have correctly entered the complete path to the WebDAV folder
(i.e. [https://server.ip:port/root/folder]).

Also, please check your WebDAV server settings or ask your administrator to enable HTTPS. After you have enabled HTTPS on your server, you simply need to change the “http://” in your address to “https://”.

Not very satisfying. I’m staying in contact with them and will post any solution.

Perhaps the problem is the fact that Nextcloud WebDAV is not really a SERVER:PORT/PATH . Perhaps the App do not divide the parts correctly.

I was also spending todays afternoon with this exact same issue.
Any progess so far?


No progress for me. My guess is that we have to wait for Scanbot to acknowledge the problem and release an updated app, as other webdav clients work just fine.

Edit: Temporarily switched to another cloud service for auto upload. Will switch back as soon as a fix is available.

I have installed
There is not only “WebDAV”. There is also “nextcloud”. Both do not work for my nextcloud test account. SFTP to my sftp-test-account seems ok.

Hi there,
facing the same issues but can confirm it’s on the ScanPro side, as I manage to access my nextcloud via WebDAV on my laptop with the same credentials as in the ScanPro app.
Bit of a bummer after spending the money on the app…
Can see the same errors in the log as @wolf-gang, seems to be a xml parsing issue.

Seems as if scanbot app does not have any other form of feedback than their support email address. Maybe if we all can give them a nudge so that they take note of the issue.

As they do offer native Nextcloud integration/adapter they might want to fix it.

You can see their support email address here:

Just received an update from Scanbot support that they are aware of the issue:

“Thanks for reaching out to us.
The development team is already looking into the Nextcloud issue encountered in the ScanPro app. We hope to have it fixed as early as possible. For now, we recommend backing up your scanned documents using other methods available in the app to prevent unnecessary issues.”

I’ll keep you updated if I receive further information.

I also sent them an email, let’s hope they fix it soon…

1 Like

Same here. Thanks @wolf-gang and @quickcoffee for stepping up.

same problem here… @wolf-gang, @quickcoffee any news yet?

@abijma sorry for the late reply. Sadly no news yet. Checking the scanbot app version every few days but no update yet. I have version 7.6.2.RC-GP-Free(286)

Scanbot support aknowledged the issue in my comment on Google Play and said they are looking into fixing it, but no news since months now.

Please consider rating low with a comment why on the Google Play store. Hopefully we can bump the issue on their roadmap.

It’s not really a “solution solution”…but a temporary work-around:
To my perception, the last updates of ScanBot (now SwiftScan) have not really brought thaaat many noticeable improvements or features. Hence, just rolling back to an older version is actually not a big step backwards and solves the WebDAV issue:

  1. Uninstall the current app.
  2. Download an older Version from here:
    (I don’t know, which one exactly is the latest working one… works for me.)
  3. Allow installation from unknown sources in the android settings and install the downloaded APK
  4. Restore your license in the app an connect to your NextCloud using WebDAV (Find the correct URL in your NextCloud --> Files --> “Settings” (lower left corner) --> “WebDAV”)
  5. If everything works: Open the Play Store --> “My Apps and Games” --> “Installed” --> “SwiftScan” --> 3-dots-menu in the upper left corner --> uncheck “Automatic Updates”

SwiftScan was recently updated to version 7.7.3. Sadly no fix implemented.


I have the same Issue Wofgang. I sent to the App Support a email with my issue and a suggestion to help the dev-team(for momey of course), because i don’t understand why it takes so long time. In my opinion its not a big issue.

@alabama Thanks for your initiative. Hopefully they’ll bite. In my mind there could be many reasons why it takes them so long. Best case other priorities and at the bottom of the backlog, worst case they are in financial trouble due to the pandemic?

It’s quite sad that they are responding on the Play Store comments with assurance that they are aware of it and plan on fixing it. Sadly nothing happened over several months and even a new published version.

Still… fingers crossed that this will work again in the future.

Hi @Markus_Windisch,

Thanks for the tip. I installed version of which I used the WebDav connector. This does work.

The Nextcloud connector does not want to be opened :sob:

So I will follow this thread to see how things evolve.