Cannot add Nextcloud/Webdav as auto upload service in Android Scanbot app

I assume that this problem is here to stay due to the age of the problem.

I’ve set a workaround up to circumvent the problem for now on Android with the Nextcloud app.

  • In the SwiftScan app
    Go to Settings > Advanced Settings > Storage Location and set a new location within the Internal Storage. Example: Internal Storage/Documents/SwiftScan/

  • In the Nextcloud app
    Go to Auto upload > Set up a custom folder and use the following settings:

  1. Local folder: Point to the folder we set up in the SwiftScan app.
  2. Remote folder: Choose a folder on your Nextcloud server.
  3. Only upload on unmetered Wi-Fi: optional
  4. Only upload when charging: optional
  5. Also upload existing files: checked
  6. Use subfolders: unchecked
  7. Original files will be…: kept in the original folder
  8. What to do if the file already exists?: Rename new version

This allows me to upload all files within SwiftScan to a Nextcloud folder.

What a great workaround. Did not think about that :slight_smile:
Thank you @GllsBe

this sounds stupidly simple :wink: thanks for the tip!

The current SwiftScan version allows for native uploads to Nextcloud.

The workaround is no longer needed, so it would be best to disable it the auto-upload in the Nextcloud App and re-enable the upload feature in the SwiftScan app.

Hi, what version of SwiftScan do you have? We are talking about Android right?

My version is 7.8, 28 dec 2020
In that one it’s not working yet…

I’m currently on version 7.8.0.RC-GP-Free (306) and it does work for me now.

lucky you :slight_smile: may’be a reinstall of the app will help.

For those struggling on iOS:

Adding the nextcloud URL as https://your-nextcloud/remote.php/dav/files/USERNAME should work now.

Unfortunately, if you were to redirect all “SwiftScan” user agents to that webdav location on the nginx side, that’s not going to work unless we find a way how to use the username submitted to the webdav service (it’s not standard web auth /$remote_user based on my tests).

I found that for the Android version of Swiftscan, the Webdav URL needs to contain the port number.


Now the upload works again with SwiftScan Version 8.4.4(617)