CalDAV sync broken in iOS12

I can’t confirm that: I just added a CalDAV account to my iOS12 phone from my testinstallation with self signed certificate without any problems (without installation profile) - so selfsigned certificates do work with iOS 12 (of course you have to tell iOS12 to trust the certificate when adding the CalDAV account).

@regatta: could you add a selfsigned certificate and try whether that solves the issue for you?

All right. I have to find out, how such a certificate can be added (the machine is not reachable from the internet). I will give feedback as soon as I have more information.

[EDIT: how the certificate can be created, not added]

generate a key with:
openssl genrsa -out internal_4096.key 4096
then generate the certificate (10 years valid):
openssl req -x509 -new -out internal.crt -sha512 -days 3650 -key internal_4096.key

Also not using SSL because of a local and filtered access.

/edit: Nextcloud 14.0.0

Patrick

Hi Guys,

I tried to connect my nextcloud calendar with an iOS12 device and it didn’t work. I used this server address:

https://XXX.next-cloud.org/remote.php/dav/principals/users/USERNAME/.

It worked on iOS 11 but won’t on 12. Can someone help me? Btw: I don’t know anything about certificates in this context yet.

Thanks

@danguba:
Try this (and the according answers):


Or this:

Good luck!

Thank you Bernie, solved! But it wasn’t the port number. When setting up the calDav-account it is cruical to write the server address the very first time correct. And dont write “https://” when typing the server address.

1 Like

For me i have to put https:// because i closed port 80.
It’s strange that on your iOS12 it didn’t work with https:// in your server address.

Still no luck here even without http/https.

To me it looks like Apple has dropped support for synching CalDAV without SSL with iOS12. So, what in your case probably might help, is configuring your webserver to serve Nextcloud via https and then delete/add your account in iOS again.

Switching to https worked for me. Thank you.

2 Likes

Now you can modify your topic to wrote it as solved.

Look at the end of your first post you will have an icon for marking this topic as solved and poiting the post who helped you.

It’s important to do that, when scrolling the forum you can see that this topic is solved and if you wanna to see why, you get a shortcut to the answer

Good morning!

I will happily do that when the problem is solved. Currently, there is a workaround for the problem which is a completely different thing. Marking the thread solved would lower the chances to get the bug in either iOS12 or nextcloud fixed.

Patrick

So what is your problem now with iOS 12 ?
Is that you can’t have it working in http or self signed cert ?

Hi!

Self-signed-cert aka snakeoil works, http does not (see initial post for details).

Patrick

Hi!
Same problem here: we’ve got four iphones 6 & 7. One have updated to ios 12, and then had no more reacted to authentication “status 401” from nextcloud.

Other iphones (until "iOS/11.4.1 (15G77) dataaccessd/1.0"… ) and thunderbird/Lightning (on windows) are still working well; the fault seems to come from ios service “iOS/12.0 (16A366) dataaccessd/1.0”.

Server config:
FreeBSD 11 + nginx 14 + php7.1 + postgresql 9.6 + nextcloud 14 (all upgraded and uptodate as yesterday).
nextcloud: http (not ssl) in lan only.

Any help would be great…

It looks like Apple dropped cal-/carddav sync support for plain http.
So you have to configure your server to serve Nextcloud via https and not via http to make the synchronization work again with your iOS12 devices (you might then have to delete the accounts from the devices and readd them).
A selfsigned certificate is good enough.

1 Like

I had the same problem with my iPhone 6S.
I solved it by going to Setting>Accounts and Passwords>Accounts>
Selecting the Calendar Account for the server.
…>Account>Advanced Settings

Then change the URL from http to https:
ie from this…
http://www.servername.com.au/nextcloud/remote.php/dav/principals/users/user@servername.com.au/
to this…
https://www.servername.com.au/nextcloud/remote.php/dav/principals/users/user@servername.com.au/

Then set the port number to 443. Go back to the CalDAV screen, press ‘Done’.

It all worked.

My server is just a straight hosted server using 14.

Hi everyone

Adding caldav works for me (https behind reverse proxy) but after in calendar app, it shows ‘no internet connection’ for my nextcloud calendar.

Any ideas why I have this error ?

  • I can open URL in browser
  • Contact sync work well

Hey everyone,
I really need your help cause i can´t add any caldav calendar to my iphone se and I have tried all the solutions of this forum and from the
I have:

  • iPhone Se with IOS 12.1.3
  • Next cloud latest Version 14
  • Server with https:// (My next cloud address is: https://xyz.ocloud.de)
    Please let me know if u need more infos…I´m getting crazy with this Calendar Sync!
    Thanks in advance