CalDAV sync broken in iOS12


#21

Hi!
Same problem here: we’ve got four iphones 6 & 7. One have updated to ios 12, and then had no more reacted to authentication “status 401” from nextcloud.

Other iphones (until "iOS/11.4.1 (15G77) dataaccessd/1.0"… ) and thunderbird/Lightning (on windows) are still working well; the fault seems to come from ios service “iOS/12.0 (16A366) dataaccessd/1.0”.

Server config:
FreeBSD 11 + nginx 14 + php7.1 + postgresql 9.6 + nextcloud 14 (all upgraded and uptodate as yesterday).
nextcloud: http (not ssl) in lan only.

Any help would be great…


CalDAV connection on iOS devices
#22

It looks like Apple dropped cal-/carddav sync support for plain http.
So you have to configure your server to serve Nextcloud via https and not via http to make the synchronization work again with your iOS12 devices (you might then have to delete the accounts from the devices and readd them).
A selfsigned certificate is good enough.


#23

I had the same problem with my iPhone 6S.
I solved it by going to Setting>Accounts and Passwords>Accounts>
Selecting the Calendar Account for the server.
…>Account>Advanced Settings

Then change the URL from http to https:
ie from this…
http://www.servername.com.au/nextcloud/remote.php/dav/principals/users/user@servername.com.au/
to this…
https://www.servername.com.au/nextcloud/remote.php/dav/principals/users/user@servername.com.au/

Then set the port number to 443. Go back to the CalDAV screen, press ‘Done’.

It all worked.

My server is just a straight hosted server using 14.