Built-in CODE: Could not establish connection to the Collabora Online server

I started having issues with OnlyOffice recently so decided to give the built-in Collabora Online server a try again, assuming teething issues were fixed. Alas, it still doesn’t work for me.

My Nextcloud installation is bare metal using Apache2. Everything else works fine. I installed both the “Nextcloud Office” and “Collabora Online - Built-in CODE Server” apps. If I go to Settings → Built-in CODE Server", it says:

You have the Collabora Online app enabled. For further information and configuration, please check: [ Settings > Administration > Collabora Online ]

If I click the link and choose “Use the built-in CODE - Collabora Online Development Edition”, it just shows an error with zero other useful information:

Could not establish connection to the Collabora Online server.

Documentation suggests this should “just work”, so why is it not working? Do I need to change something in my apache config? Where can I see a more detailed error message?

If I try to run the AppImage manually it errors, but I don’t know if this is expected or not:

Logging at warning level to file: /tmp/coolwsd.6lADayGT2F/coolwsd.log Failed to listen on Server port(s) (9983-9983). Exiting.

Support intro

Nextcloud version (eg, 20.0.5): 23.0.3
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.53-1+ubuntu20.04.1+deb.sury.org+1
PHP version (eg, 7.4): php-fpm 7.4+75

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it: Install both the “Nextcloud Office” and “Collabora Online - Built-in CODE Server” apps.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' =>
  array (
    0 => 'my.domain',
    1 => '',
  'datadirectory' => '/always-on/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://my.domain/nextcloud',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '',
  'installed' => true,
  'default_phone_region' => 'GB',
  'mail_smtpmode' => '',
  'mail_from_address' => '',
  'mail_domain' => '',
  'mail_smtpsecure' => 'tls',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => '',
  'mail_smtpport' => '',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '',
  'mail_smtppassword' => '',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'cache_path' => '/var/cache/nextcloud',
  'maintenance' => false,
  'theme' => '',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => 1,
  'mail_sendmailmode' => 'smtp',
  'updater.release.channel' => 'stable',
  'filesystem_check_changes' => 1,
  'allow_local_remote_servers' => true,
  'onlyoffice' =>
  array (
    'verify_peer_off' => true,
    'jwt_header' => "AuthorizationJwt",
    'jwt_secret' => "poop",
  'twofactor_enforced' => 'true',
  'twofactor_enforced_groups' =>
  array (
  'twofactor_enforced_excluded_groups' =>
  array (
    0 => 'Test',
  'app_install_overwrite' =>
  array (
    0 => 'files_snapshots',
    1 => 'richdocuments',

Please fill out the support template and add to your post. Thanks!

Hi @DragonQ

You can refer to the configuration in my article.

Use HTTPS with Ubuntu 22.04, apache, Nextcloud and Collabora(Docker)

Hi @DragonQ ,

have you found a solution?
I have the same problem :frowning:

Best Regards

i seem to have the same issue as well. hopefully someone can help. i was seeking a selfhosted cloud solution that “just worked” and this is the closest i’ve come to it. i don’t need nextcloud office to work, but it’d be nice if it did