Blank admin logs page after upgrade to NC 20.0.4

A week ago I updated from NC 18 to NC 20.0.4. Since then the admin logs/warnings/errors page remains blank/empty. All log files are up & running. What to do?

Nextcloud version: NC 20.0.4
Operating system and version: Ubuntu 18.04.5 LTS
Apache version: Apache 2.4.29-1ubuntu4.14
PHP version: 7.3.25

Many thanks in advance for helping!

you can set the path of log in you config.php :
‘logfile’ => ‘/var/log/nextcloud.log’,

Thx, @Mageunic! I did add that but the problem still exists.
I even found Logging admin page does not show any log entry - #3 by godfuture and updated oc_appconfig using
UPDATE oc_appconfig SET configvalue=‘11111’ WHERE appid=‘logreader’ AND configkey=‘levels’;
but without success.
I would be happy for another idea… :bulb:

@PK.L try to move your nextcloud.log file into another directory and see if another is created and the blank page desappear.
maybe this can help you but not sure :

done this command in your nextcloud server directory :
sudo -u www-data php occ maintenance:repair

Thx again, @Mageunic. :+1: When moving files, a new nextcloud.log has been created. maintenance:repair done. Unfortunately the problem is still there. I checked sudo -u www-data php occ log:file and params were enabled/path fine/logrotate works. Best regards!

@PK.L maybe reinstall log reader app …

@Mageunic: Nice idea, really worth a try.

1 Like

I have the same issue on two servers - both upgraded today to 20.0.4 from version 19.06. Both on Ubuntu 18.4. One has PHP 7.3 another PHP 7.4. One has Apache second nginx.
When I go to Logging I can see only blank page - also file nextcloud.log is empty. On top of this, when I try to change settings on some applications (e.g Activity , Onlyoffice) they don’t save.

@PiotrIr all user permission is ok on your data directory and nextcloud directory ?

if not :
sudo chown -R www-data:www-data /path-directory-of-nextcloud
sudo chmod -R 750 /path-directory-of-nextcloud

sudo chown -R www-data:www-data /path-directory-of-data-user
sudo chmod -R 750 /path-directory-of-data-user

if you have the same error again maybe make a backup of your config.php, data user and your database. Try to reinstall nextcloud and restore your data

backup : Backup — Nextcloud latest Administration Manual latest documentation

restore backup : Restoring backup — Nextcloud latest Administration Manual latest documentation
( don’t forget to set the correct directory permissions after downloading nextcloud and transferring your data)

Hi Mageunic,
Thank you for your reply. Yes, permissions are correct (in fact it was first thing which I checked). I can’t reinstall Nextcloud - this is production environment with many people working on it.

@PiotrIr I keep looking for a solution but I don’t know exactly where the error comes from.
maybe this can help you :