Auto-upload on android not uploading anything

Hello, I’m new on next cloud and has just finished setting up next cloud on my raspsberry pi, however i just found out today that auto-opload on android is not working for me, it doesn’t seem to upload old nor new pictures. I am using version 3.13.0 of the android app on a samsung s10. Thanks in advance!

1 Like

Did you exclude it from cleaning ram in samzungs shitty power management? Also in android energy settings you have to disable power optimization.

For some reason, i cant find the app on the “not to put to sleep” list, it just doesnt exist there. And for the battery optimisation, i already disabled it for the app.

Unfortunately (or in that case actually fortunately) i dont own a samsung device to check how to do that, but i know it has to be done on two places in samsjng devices, one, the one you most likely missed is somewhere in samsungs ram optimization, it needs to be excluded there as well, otherwise samsung will not allow the app to do anything in background. Samsung has never been good building Software and have totally broken android battery, ram and background task management instead of configuring androids stock ram management correctly in the first place

1 Like

Ah ok, thanks for the input.

Hi @Darrell_Octavianus,

Have you configured the correct options in the NC android client app?

In NC Android app -> Menu -> Auto upload.

For each folder you want auto uploaded (e.g Camera) is the item enabled?

354-768-max

The enabled icon is a solid coloured cloud.

Then if you go into the sub-menu for a selected auto-upload directory what options do you currently have set in there? Are they compatible with your connection method (e.g not set to ‘Only upload on unmetered Wi-Fi’ when you are reliant on a mobile data connection only.)

Let us know how you get on!

I’m having the same issue on Android, Nextcloud version 3.13.0.

The “Uploads” page is empty. I already chose to exclude the app from battery optimizations.

Probably doesn’t matter, but the app install was made via F-Droid, not the Play Store.

NOTE: JUST as I was about to submit this reply, the uploads page started showing all the pending uploads! It literally took over an hour of fiddling, changing settings, until I just gave up. I didn’t change anything at the end, the uploads just showed up. Is there a delay between choosing upload settings and having them trigger for existing files?

I decided to still make this post since the delay is likely still an issue.

EDIT: I pressed the cloud icon again to disable auto uploads. The uploads continued to upload. I pressed the X button in the Uploading group to stop the pending uploads. Then I went back and enabled the cloud icon again. So far the auto uploads have not started, so I confirm there is a delay. I will update again if I see that the uploads start on their own. This is on Android 8.0.0, on an LG G5, while the phone is plugged in and charging.

Yes, it suddenly works for some reason, didn’t change anything and suddenly bam, 20gb of my internet data was gone, it uploaded everything while i was using data connection, but anyways, it now works like a charm!

Well, unfortunately I’ve been completely unsuccessful at getting the files to upload again. I’ve tried turning off the cloud icon and then turning it back on. I also tried unticking the option to upload existing files, saving, then ticking it again. The upload screen still shows “upload some content or activate auto upload.”

It really would be great to get this critical functionality working! If you need any help debugging the issue, just let me know what to do. I’m willing to help.

In worst case you still could remove the share and create it new

Oops… I realized we are discussing some slightly different things, very sorry about that! The auto-upload feature DOES work fine for uploading pictures as they are taken. It’s the “Also upload existing files” feature that doesn’t work. All existing files don’t get uploaded (except seeming randomly, though like I said I have no idea what triggered it that one time.)

As for creating a new share, the same issue happens with brand new “custom” folders. Basically I turned off the default syncs for images/videos in the Camera folder, and created a new custom sync for the Camera folder, but it doesn’t autosync existing items.

Sorry for the confusion. Let me know if you need any more info. Would love to get this to work.

1 Like

I want to warm up this topic again: I still have the same issue as @nextcloud4me described above in it’s post. Any updates on this or more experience?

It would be simply great to have a rescan button or something like this to actively counter this situation.

I would also like to see a rescan button or similar. For the most part the instant upload is working for me, but occasionally I’ll have a failure when I’m not connected to any network. It would be nice to be able to tell the app to try again, even if it’s been a few days. Or maybe in the app it could be an option on a photo-by-photo basis?

the ONLY thing for me that syncs correctly on Android → Nextcloud for me is the “Instant upload” camera folder, and even then it will ONLY auto upload .jpg files.
If a .mp4 / video is taken with the camera, this will not upload automatically.

Any folders manually created do not sync in the same way as the desktop/windows client. (any file or folder created or modified on either side is synced) ← this is what id expect android to be able to do but it cannot.

If i setup a folder to be synced on android, yes it can upload it to the nextcloud folder, and any filese uploaded, if they are modified, you can then manually press “sync” and they will sync.
however any new files or folders created on the android side do not get synced, ONLY modified.

Is very weird and unusual behaviour for a “sync” and i personally use syncthing on android for more normal sync duities, would love to see the android client work in the same way the windows desktop nextcloud client does, the windows Client seems really good and reliable for me.