Auto-upload on android not uploading anything

FolderSync supports using “timestamped folders” for one-way sync.

Also see Settings - FolderSync Documentation

You can also define custom patterns for the foldername like “yyyy-MM-dd” for date including day of month or “yyyy-MM” if you only want to have folders for each month.

However I did not try these options yet since I use two-way sync to keep a identical backup of my images folder on the smartphone in Nextcloud. So when I delete a file in Nextcloud (or move it out of the backup folder to an archive folder), it will get deleted on the phone automatically.

1 Like

It isn’t in the test version of the app. I think

I was wrong. I tried a smb upload while I had to choose nextcloud upload.

Sadly this creates a folder for each sync instead of assigning the file to the correct folder :cry:

I gave “yyyy” and it started uploading files from 2021 to the 2023 folder.

Sorry to hear that - it seems “timestamp” means the time of upload and not the creation date of the file.

This might happen, if files have been copied or modified in year 2023 in the folder of the mobile device.

To clarify, this happened with FolderSync. When the Nextcloud app worked, and before it started and infinite upload loop, it uploaded the files correctly per year.

I was and still am a big fan of nextcloud but it is just sad and disapointing that it takes years and still the autoupload fails.
It failed to sync all my family member photos, all spread around the globe, most of them know very little and want a photo upload that just works without PhD for config.

I enocunter the same error on newest nextcloud server version and nextcloud android clients as well

But still simple rescan button would make sense for troubleshooting

cool, we are in 2024 and this problem still exists. :))

On android my existing files upload, but only about 8 at a time then i have to close the app and reopen and refresh the uploads page to re-initiate my 2000 photos and it gets about 8 copied over then stops until i close the app completely and reopen it. Has there been any fix to this issue? I am running nextcloud on a ubuntu 22.04 server VM running in proxmox with 4 cores and 8GB of ram.

Edit: I do not have a redis server running as it is just a family cloud for maximum 3 people so did not think the cache would be nessessary. Also when I tried to enable filelocking and redis no files were visible to me so I commented out the portion of the config that enabled file locking and the redis server.