Any Problems with Web Updater on 15.0.0.RC1?

Hi,

ca nnot Update via Web Updater from 15.0.0.RC1 to 15.0.2 ?!
Nothing happens after i push the [Start Update] Button. Any hints for me?

it’s the first time with a problem like that…

Regards,

ccb

worked fine for me, running php 7.2.10

Hi

I always instal new version with new configuration

z poważaniem

Kind regards

Mit freundlichen Grüßen

Marcin Adamek

Dipl.-Ing. [FH Oldenburg]

ECEM - Europäisches Baumanagement

Maklererlaubnis nach § 34c GewO

Am Hohen Feld 129,

13125 Berlin

T: +49-30-23354689

F: +49-160-4008060

M: marcin.adamek@gmx.de

same here. after:

cd /var/www/html/nextcloud/data/updater-*
mv .step .step-previous-update

the web updater had no problems.

regards
martin

The web updater used to work for me on the first time, but it broke a long time ago - so I have to do it manually now. I think the latest time it worked was when Nextcloud was still ownCloud…

Worked fine for me. PHP 7.1

For me, it seemed to have run but after the update I was sent back to my old Nextcloud 14.0.6. I reran the update and that did the trick (for NC14.0.6 to 15.0.2)

If you’re able to install via Docker, you might want to give that a try. Updating seems to be easier when you’re running Nextcloud within a Docker container.

See this recent thread.

Here i have the same issue. When I click on start the update, I have this screen and it never ends

Also got problems with the web updater.
Running Nextcloud 14.0.3 on a FreeNAS-11.2-RELEASE-U1 I did a upgrade via the freenas shell.

iocage upgrade nextcloud

This worked fine, but now i got stuck in the webupater.

Possible CSRF attack. Connection will be closed.

Screenshot%20from%202019-01-18%2012-35-31

Then I switched to shell, having more issues:

root@nextcloud:/usr/local/www/nextcloud # chmod +x occ

root@nextcloud:/usr/local/www/nextcloud # ./occ upgrade

Console has to be executed with the user that owns the file config/config.php Current user: root Owner of config.php: www Try adding 'sudo -u www ’ to the beginning of the command (without the single quotes)

root@nextcloud:/usr/local/www/nextcloud # su www ./occ upgrade

This account is currently not available.

Any suggestions? I don’t want to change to much via the shell and also don’t want to change the owsership of the config.php because it might break even more stuff!

On the Internet I found nothing usefull…
https://forum.owncloud.org/viewtopic.php?t=31068
https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/occ_command.html
https://docs.nextcloud.com/server/9/admin_manual/configuration_server/occ_command.html

Check you owner and group
work with chgrp/chmod…

and check here Apache
https://doc.owncloud.org/server/8.2/admin_manual/configuration_server/occ_command.html#http-user-label

Just upgraded via UI without any problems…