Any Experiences upgrading Debian from Buster to Bullseye?

i’m about to upgrade some nc-instances running on debian from buster (“10”) to bullseye (“11”).
i’m quite certain everything will work (as i’ve upgraded some other systems w/out problems - but they do not run nextcloud) but i cannot afford too much downtime. the systems are pretty much standard and up-to-date and do not use any custom repos; one runs apache and the other one runs nginx. the only thing differing a little from the proposed debian-install is that all systems use sysvinit.
So, do you have any hints or experiences to share?
THX for your input!

Hi Pete, just upgraded yesterday and lost my NC instance, which is not returning HTTP 500!
Some context:

  • Debian 10 + Virtualmin + Nextcloud (last release, upgraded right before Deb upgrade)
  • Applied the whole update/upgrade/dist-upgrade stuff with some warnings but no error, kept existing config files, cleaning
  • Launched Virtualmin = OK
  • Launched NC = > Syntax error on line 18 of /etc/apache2/sites-enabled/

Aug 20 15:15:30 server1 apachectl[16761]: Invalid command ‘FCGIWrapper’, perhaps misspelled or defined by a module not included in the […]

I tried to install libapache2-mod-fcgid and php-fpm, which look missing, updated and verified Apache2 config and now get the HTTP 500 error…

Do you know if there’s any way to re-install NC without losing the current config?

Thanks in advance for any help!

Will you be backing up your system before the update? If you don’t need downtime, just wait on upgrading and cement your backups. :slight_smile:

of course! i only start stuff like this if i have a tested and proved fallback-solution.

just finished it on the nginx-system and so far everything seems to run quite smoothly. some stuff to keep in mind:

  1. BACKUP! (as always, but it’s much more relaxed when you have a working fallback.)
  2. (again!) dpkg ignored the manual change to apcu.ini required to make occ and cronjobs run. re-added the line from the backup-file
    /etc/php/7.4/mods-available/apcu.ini now looks like this:

the last three lines had to re-added

  1. i double-checked, but no php-modules had to be reinstalled - YMMV.
  2. all nginx-configs and modules were correctly updated or left intact, but at first “nextcloud” greeted me with “nginx - bad gateway (507)” the reason was the hard-coded path to the php-fpm-socket in the nginx-nc-config which still had the path to the php7.3-socket in it; it corrected it to server unix:/var/run/php/php7.4-fpm.sock; and it worked.

@jlgarnier Maybe you have to enable the corresponding apache-module (a2enmod…) or configure it? What’s in line 18?

Hi Pete, thanks for helping!

Shouldn’t say that, but no backup (no excuse, I was in no hurry, just working on Sunday… :man_facepalming:)

Regarding the apcu.ini, I corrected it as displayed but to no avail, so it’s clearly not enough!

Line 18 of the conf file says “FCGIWrapper /home/nextcloud/fcgi-bin/php7.3.fcgi .php”: maybe I have to point to php7.4 module, don’t you think so?

Thanks again for your help!

the apcu.ini is relevant for php-cli, i.e, if you run cronjobs with php or use the occ-command

yes, i would definitely try that.

AND i had to adjust all the settings in the different php.ini-files in the new version 7.4, and esp. (since using php-fpm) /etc/php/7.4/fpm/pool.d/www.conf.
(i think the next time i’ll just make a backup-copy of the default-php7.4-configs and copy over the existing ones from 7.3, since the canges in the new files seem pretty minor)

Hi Pete,

My config was a bit tricky to maintain and I took the opportunity, as the server is not yet in production, to wipe everything and start back from sratch: Debian installation, Docker, Portainer and everything else as a container!

Hope this will ease the config and lower the console work! :wink:

Thanks again for your help, have a good day!